image not found img not found

Fan light smartthings indication issue

I installed the new lzw36 fan light switch in smartthings with the required dth parent/child dth and got three devices as expected. the issue is this

  • if i push the parent fan + light from off to on, both fan amd light turn on But individual child tile for fan and light still show off. if i go into the child tile fan or light it will show the correct status.
  • restart from all three switches in OFF, if i switch either fan or light tile ON, the parent fan + light tile shows ON But the child tile fan or light still show OFF. again if i tap on the child tile, the detailed info show that it is ON

now if, i quit the smartthings connected app (back ground it on ios) and hit the smartthings app, the right status will be shown!

if the tile show off or on but the detailed tile show the opposite on or off, hit the power circle on the tile will do nothing. i must go to the detailed page to turn off or on. going from dashboard tile to detailed tile and back to dashboard tile will not change the incorrect status on dashboard tile.

What am i doing wrong?
My hub is smartthings v3. i do have aeotec power strip installed using Eric’ virtual switch sync app to control its mutiple endpoints.

Please advised

1 Like

I am seeing a similar behavior on mine.

Im not sure its the exact same, but i need to hit refresh any time i make a change to the fan/light. For example, if i turn on the light the state will stay “Turning On” until I hit refresh and then the state updates with ‘On’. This means also that any local changes (me pressing the button on the switch) dont make their way to smartthings without a manual refresh.

I’m going to try excluding and including into my z-wave network again later today probably - but i just got it all configured the way i want it :disappointed:

Curious if anyone else is seeing this though!
-John

Yea seems like its not updating the dashboard tile quickly. I think automations and what not reference the actual status of the device still so that’s good.

i think it is a dth issue coz there is a note indicating that this is a place holder in the parent dth. i put in simple log.debug inside the parent dth and found the dni passed on to it from each child but the childsendevent does nothing to the dashboard tile as well as putting a sendevent inside the child dth. this incorrect status issue is true for all switches create by the parent! i.e. the notification child for fan or light has the same issue.

i wish Eric/novelli address this one way or another. i do think this issue is important for remote control bcoz you want indication that it was turned on/off!

Hey we’ll be talking about this today at 4pm EST – I’ll have @EricM_Inovelli or myself answer this later today.

EDIT: We’re working with Jody from ST to get this resolved – basically, the new way child devices are implemented in ST are different than what we’re used to, so we have to modify some code in the device handler to allow this.

In regards to this statement – we definitely agree. What I’ve found is that if you click into the child device, press off, then go back to the main screen, the status should update correctly. It also should not interfere with any of your automations. In other words, the device will turn on/off when you press it, the problem is the app does not reflect it until you click out of the app. We definitely understand this is annoying and we’re working on a solution with ST.

Thank you. I will wait fot the updated dth then.

Is the switch zwave portion of this switch the master for the 2.4ghz canopy module? That is the canopy cannot be on if the zwave switch is off.

Thks

No response from SmartThings and I’m honestly not sure if their is a way to correct this in the current app with a device handler update. I have tried every possible fix that I can think of. Even if we do get the children to update while you are changing them in the app, child devices still aren’t supported by the new Alexa / Google Home integration. We will still pursue this route though of course.

In the meantime I have created a solution that will solve both the issues mentioned above. It requires the use of a SmartApp that creates two virtual devices and keeps them in sync with the physical device. It is actually a modified version of an app that I created 4 years ago because SmartThings didn’t have child / component devices yet. I feel like I’m taking a step backwards doing things this way, but it is the only alternative that I can think of right now.

This is intended to be a stop-gap solution until proper component / child device support is implemented in the new app and in the Google Home / Alexa integration, but it should work really well right now (as long as I worked out all the bugs). If interested, give it a shot and let me know. Here is a post that I just put out about it:

1 Like

Thak you. I removed two lzw36 switches from zwave, removed the dths and before doing anything i did the following on each switch:

Install the new dths for using with snartapp, including the smartapp. All published. Only have to do once for both switches

Hold A + B for 20 seconds (red light came on) to reset zwave

Hold D + E for 20 seconds ( red light came on) to reset the fan module

Include each switch with QR scan

Three devices came up once the inclusion completed

Run smartapp to create virtual devices. Once done now i have 5 switches, 2 from the smartapp

Open the main fan + light switch created by dth, click three dots, click settings and change the first option to yes ( to use virtual switches.) if this is option is not set to VS, changing any parameters the dth will recreate the fan and light switches if they were deleted

Remove the child switches created by the dth NOT the one created by smartapp

Turn on/off local or via the dashboard tile now totally in sync BUT

The unit in my dad room, MBR, i can turn on light, fan, or both via smartthings but NO local . Change in local will show the correct status in the app but nothing turn on

The unit in family room however cannot be controlled via the app ONLY local. The status will sync but send command remotely to turn the switch on/off does not turn light or fan on/ off. Actual light or fan On/ off can only be done locally.