Firmware Update - unable to receive=0x01 - SOLVED

@Eric_Inovelli @EricM_Inovelli (Sorry I forget which Eric is which so I tagged you both!)

  • Unable to update firmware on LZW30-SN or LZW31-SN devices
  • Current various firmware versions from 1.36 to 1.57 on the 31’s and 1.20 I think on the 30’s.
  • Following directions outlined here
  • Using latest version of ZWave PC Controller from SimplicityStudio, Aeotec Z-Stick Gen5+
  • UNABLE TO UPDATE FIRMWARE - ERROR - unable to receive=0x01

After many hours of fruitless attempts I finally stumbled across a workaround!

The directions for including the device on the controller tell you to cancel when prompted for the security inclusion type.


When attempting to update following these directions it hangs here.

Here is the log.



Instead of cancelling the security level prompt, UNCHECK both S2 options and leave S0 CHECKED. (If you leave either of the S2 options checked you get a packet size error when attempting to update the firmware)


By including the devices using this option I was able to update the firmware on a couple dozen LZW31’s and a handful of LZW30’s using this method without issue.

I see a lot of people with Hubitat some with HomeAssistant using the Zwave2MQTT to update the firmware are having what appears to be a similar issue. Perhaps this solution will work for them also.

Hope this saves someone some time.

I believe the intent of cancelling that prompt is to join the device without security. S0 is a secure protocol and actually has more overhead than S2 does. There seem to be less issues updating firmware when not using any security for the switch and then if you desire it, performing an exclusion/inclusion to rejoin the switch with security.


However, with both the zwave stick and the devices in question both having had a factory reset done (and therefore not included anywhere with any security level) then being including on the blank zwave stick with no security level (cancelling that prompt) gives the results outlined above.

Including on the stick with S0 allows the firmware update to be performed. I don’t pretend to understand why, I just know I verified this several times with several different devices and it worked every single time.

All of the devices were subsequently included on my actual zwave network after the firmware updates with S2 security level (not much more overhead than no security!) without any issue.

At any rate - if someone is having difficulty updating their firmware with the outlined instructions this option might be worth a shot.

1 Like

I was having the exact same issue, and this also solved the issue for me. Thanks for putting this out there!

I haven’t figured out how to update the Holtek MCU with the .bin file, though - the PC Controller instructions from Inovelli only describe how to update the Z-Wave MCU. The software only seems to accept .hex and .otz files.

In the Open File dialog, select the File Type dropdown to the right of the File Name box and select “All Files”. You will then be able to select the .bin.

1 Like

Just make sure you select the correct target (Target 1) before pushing the .bin file.

1 Like

Got it - thanks!

Thanks for sharing. It is strange that some are having that problem. I’ve probably updated hundreds of devices without security enabled and haven’t seen that issue (on several different computers). For confirmation I just tried a dimmer and a switch and everything seemed to work.

Good to know that there is an option for some that may run into this issue though. Thanks for posting.