image not found img not found

Firmware update with Z-flash

Has anyone had success updating firmware using HomeSeer’s Z-flash software?

I am able to use Z-Wave PC Controller software to update individual devices. But, I wanted to use Z-flash to update multiple devices without removing them from the network.

For the moment I’m stuck. I’ve connected my stick to ST as a secondary controller. The Z-flash software initializes the stick, but none of the Z-Wave devices show up in the “Step 2 Device Management” box.

I have used the Z-Flash software with some my other devices, but gave up on it for the Inovelli, not be cause it didn’t work, but because it didn’t seem to have a way to support the second flash location for the Dimmer MCU

Attached is a Red Series Switch being updated, but I was forced to rename the provided .otz file to a .hex.

If you use the Z-Wave PC Controller Software and the Z Stick included as a secondary controller there is no reason to remove the switch from the Hub… (This is the same switch after the flash…)

Thanks for your response. It’s good to know that it CAN be done!

However, when I connect as a secondary controller, I don’t get any of the current firmware information and the file icon is not clickable. Any thoughts on why? (I am using the Zooz S2 stick if that makes any difference)

Looks like you may need to go back to network management and get the node info, first with primary controller, then the node you want to update. That should complete the security handshakes and then Get should work for you.

1 Like

Found this in another post, I don’t have S0 configured on my install but I suspect you may…

Yes I have S0 configured, mostly for associations with bulbs.

Looks like your PC controller is S2, which I’ve not gotten to work. I have all of my switches and pc controller as S0.

Thanks for all the responses. You guys are awesome.

I guess the next step is to figure out how to switch the controller to S0? I’m sure I can figure that out on my own, but for now I have to get back to work. I’ll work on that tonight.

You’ll have to reset/exclude from the ST hub, then change the security setting to S0 on the controller then re-include the controller as secondary.

I am working on an article for the secondary controller method that may help you out. It should work even when the device is included with S0 or S2.

1 Like

Pefect!
This was exactly what I needed. Thanks everyone for all your help!

1 Like