Firmware v1.17 (Beta) | LZW30-SN | Switch - Red Series (Gen 2)

We are releasing a beta firmware for LZW30-SN users that would like to take care of some of the bugs that they may have experienced. There is an enhancement as well for people that have interesting loads that can cause problems with 3-way dumb switch toggling. @harjms mentioned that he was hoping for this feature. I don’t have any unique loads to test so hopefully the community can do some testing.

This firmware should be stable, but if there are any issues, please let us know. I recommend updating one switch and testing it out for a week or two before updating your whole collection.

There are instructions included in the link.


Can you include the URL to the OTZ file, that is needed to update it through Hubitat? Thanks.

1 Like

You can try this on:


Thanks, that worked, it’s uploading to the switch now.

1 Like

I updated a switch yesterday and everything has been good so I updated the rest today. Everything is looking good with this firmware so far.


I did have trouble after updating the firmware on a LZW30-SN using ST. The switch only worked locally and could not be configured through either new or classic app only via config button on the switch. Upon further investigation I realized I had included with S2 on. I downgraded security and was able to confirm changes from app to switch. The IDE didn’t even update disabling the relay or LED Color . This was also after the recent Firmware update from ST which has caused some issues with all my devices. This was the first device I tried with S2 Authenticated.

When it was included with S2, did you include it as a new device or did you use the “replace” feature of SmartThings? Also, what is your method of downgrade? Just curious.

I did a replace first, scanned the SDK to include, wasn’t getting a response, reset it and forgot to shut hub off so full reset happened. After a couple Airgaps and resets I realized it was set to S2, prior I had used the SDK it just went to legacy automatically as S2 wasn’t fully functional on ST, I guess it is now lol. I tried a replace again then just excluded it and used the config without SDK to include it went back to Legacy. I figured it out after that the devices would be different security and “not replace” after the firmware update as it did before. I am also curious about how to get the LED to function Digitally on/off with the relay disabled as I saw that in the latest DTH?

@GrantsAuto Hmmm, you could turn the LED off and on and have that sync with some other load. Interesting, I’ve never thought about that. If you send a setColor command to the switch with a level of 0 it should turn the LED off and any other level will turn it on. That is a clever way of having the LED represent whether the other load is on or off.

Side note: Has anyone who has had problems with a 3-way dumb switch tried the new Parameter 13? If so, did it fix the problem?

@EricM_Inovelli The latest ST Update seemed to mess up some things, I am running the Beta to see If I can get things back to normal. I have had trouble communicating to the switch to change LED color in general, it remains the last color chosen until a factory reset and will not change until it is reset again. I tried the airgap but it remained the same, but that was after the update and I have been chasing ghost devices and nonsense z wave routes.

Edit: After some clean up and ensuring the Beta firmware(V30.4) was on the hub, excluding the switch the next day and inclusion as S2 it seems to be fully functional again. The new app didn’t see any activity from the switch after the hub updated to V30.3 but controlled functions. The Classic App worked and showed activity past the update. That was when some changes were taking effect on the switch but LED changes were non responsive. However since its operational again I can set the notifications through automations to show when the load is on or off. Looking forward to playing in webCore when I get the time now for my dimmers too. Keep up the good work!

1 Like

@EricM_Inovelli - would it be possible to get an API or rss for latest firmware releases? Would be awesome to add an integration to Home Assistant to watch for new updates to devices.

1 Like

Would there need to be a single feed for all devices or a feed for each device?

Either would work. Individual would be a simpler integration but not by much.

So I am wondering if you can use the search and json functionality of discourse (this forum). For example, this returns a json feed of the LZW31-SN firmware:


Edit: I had to copy and paste these links because the forum is doing something weird to them.

This returns a bunch of useful information that you could parse.

@EricM_Inovelli Every time I try to update the firmware on my LZW30-SN Red Series switch using the Hubitat firmware update driver, it tells me to “Please wake up your sleepy device” and then my switch stops working till I pull the air gap switch for 10 seconds.

I’ve updated all of my LZW31-SN Red Series switches with no problem. Have any suggestions?


Try the steps that GavinCambell found

  1. Change the driver to the firmware updater driver.
  2. Ensure the switch is responding by clicking on Get Version Report.
  3. Put in the URL this is in post 3 of this thread ( and click on Update Firmware let it get to the parsing step
  4. Airgap the switch.
  5. When it says to wake up the sleepy device, push in the airgap switch (quickly). If it takes a few seconds to push in the airgap it likely won’t move on and you’ll have to start over.
    (Slietly condensed version that worked for all of mine)
1 Like

Success!! Thank you so much, what a weird way to make sure the switch is awake… Maybe Team Inovelli @EricM_Inovelli should look into it.

Glad you got it to work!

I think this is more of a Hubitat driver thing as this is not required for normal upgrades via PC Controller. But, interesting steps – we’ll take a look!

1 Like