Firmware v1.19 (Beta) | LZW30 | Switch - Black Series (Gen 2)

Alright all you cool cats and kittens… the update everyone’s been waiting for. The update that has been keeping me up at night wondering why the 700ms delay is psychologically damaging relationships, and how we could’ve let this fatal flaw slip through the cracks.

Yes… this version gives you the option to remove the 700ms delay for TRUE INSTANT ON!!! No more guests wondering why the light switch doesn’t turn on immediately when their finger lifts off the paddle. No more puzzled looks when the light doesn’t turn on quicker than you can blink. Oh yeah baby, this new firmware will bring that WAF factor back!

Lol, thanks everyone for letting me vent a bit – I know this is a hot topic next to light almond paddles and sharp config buttons.

We’re glad to finally be able to release this to you as well as the option to turn your LED white.

Please see the following KB article for the otz file and let us know if you have any questions!

NOTES: This will be the production version if all goes well. We will also create an alternate version with more of the unique suggestions (ie: configuring the delay of the on/off, etc), but for the production version, we needed to still keep a lot of the main config button options on here due to hub/gateways that do not allow parameter changes such as Ring, Wink, etc.

EDIT: Tagging @noriscart, @aecky01, @BigInovelliFan, @SirDeadlystrike, @Dlo747, @wsdavis for reference as I know you guys were really pressing this (thank you)!


Damn @harjms – was that you who clicked through to the 1.19 firmware in less than 700ms? Impressive!

@Eric_Inovelli - Haha, what else do I have to do this time of night? Next time it’ll be instant like this firmware.

Also just waiting on those RGBW strips.


Ah the memories of you walking through that front door and outside to show me how the On/Off switch didn’t work with your bulbs. #nostalgia.

We’ve come a long way my friend lol.

If you can dust off your negotiation skills to get these tariffs down, we’ll make them just for you!

1 Like

Technically, I do work for a man in a White House; however, I have no pull.

Those were the days!

1 Like

@Eric_Inovelli @EricM_Inovelli - Much quicker response!!! Great job. Two flashed so far, no issues.

Edit: One suggestion: Please make the text field a bit more English friendly.disable

Like do I say Yes or No (I know the answer after selection).

1 Like

Also, after flashing firmware, this selection was not needed to be selected. It defaulted Off. However, when I read the No (Default) in the drop down, I thought that is why it needed to be No at first.

1 Like

Updating from the 1.17 firmware, I had more sleepy switches than before. I needed to airgap each of those briefly before the update would work. One thing in common with all those sleepy switches: they were at the far side of the Z-wave mesh from the hub, so the signal delays may have played a part. Except for the airgap need, updates went smoothly (I have 25 LZW30s). Used a zwave stick that was in the network as a secondary controller, so no need to exclude/include or change drivers in the hub.

1 Like

Hi there. First time participant and I’m gonna ask a dumb question. So I’m using an iPad/Hubitat and I can normally drop the web link in for the otz file but I Can’t seem to find it this time with this firmware update. I would be grateful for the enlightenment ty!

@DeadpoolDave - Dang, I can’t get it to do it on macOS either. @EricM_Inovelli Can you provide the download URL?

By the way should host future firmwares it sounds like per Inovelli’s team. Rarely broadcasted feature, but incredibly useful!


Thanks guys!

do you happen to have a link i could use to update my switch with the hubitat tool

Hey @adriang809 - all files can be found here:

Just search the model number and you should be good!

ive got that one but all i can do with it is download it… idk how to proceed on using it with the firmware updater tool…

If you right click on the firmware file and select, “copy URL”, it will give you the URL and you can paste that in the Hubitat tool

gotcha… thanks

1 Like

@EricM_Inovelli With the impending release of Hubitat version 2.2.3, does the firmware for the switches/dimmers need any updating to work/pair correctly?

I’ve been updating a bunch of my LZW30’s from 1.11 (using the secondary controller method with PC Controller v5.39 with a SmartThings v3 hub as primary). All but one of them flashed successfully (as did my LZW30-SN’s and Target 0 on my LZW31s, but that’s a different thread…).

For the switch in question, the first time I tried flashing the switch, I mistakenly allowed the PC laptop to go to sleep in the middle of the flash. By the time I realized this, the flash process was stuck: PC Controller was not able to send any further packets, and after several minutes I had to abort the process.

The switch still shows fw 1.11 in PC Controller. Further attempts to flash the switch end after a few seconds with no packets sent. At this point, the switch becomes unresponsive and will not respond to Node Info commands from the PC Controller, as seen below, and furthermore is unresponsive to physical button presses until air-gapped.

Annotation 2020-08-08b

After being air-gapped, the switch seems to function correctly, except that any further attempts to flash the switch again result in an unresponsive switch.

It seems something in the switch got confused after the failed flash; maybe the partial upload hasn’t been deleted from wherever the chip buffers new firmware during the flash process. However, multiple iterations of air-gap-and-try-again (with a restart of the PC Controller software between each), with the PC closer to the switch have failed to resolve the problem, as has excluding/re-including and factory-resetting (20sec press on the config button) the switch?

@EricM_Inovelli is there some method, beyond what I have tried above to get the chip to forget the bad upload so I can flash the new firmware?