Firmware v1.19 (Beta) | LZW30-SN | Switch - Red Series (Gen 2)

Copying my monologue from the Black Series 1.19 Post

Alright all you cool cats and kittens… the update everyone’s been waiting for. The update that has been keeping me up at night wondering why the 700ms delay is psychologically damaging relationships, and how we could’ve let this fatal flaw slip through the cracks.

Yes… this version gives you the option to remove the 700ms delay for TRUE INSTANT ON!!! No more guests wondering why the light switch doesn’t turn on immediately when their finger lifts off the paddle. No more puzzled looks when the light doesn’t turn on quicker than you can blink. Oh yeah baby, this new firmware will bring that WAF factor back!

Lol, thanks everyone for letting me vent a bit – I know this is a hot topic next to light almond paddles and sharp config buttons.

We’re glad to finally be able to release this to you as well as the option to turn your LED white.

Please see the following KB article for the otz file and let us know if you have any questions!

One thing to note is if you change the delay to instant on, you will lose scene control for buttons 2-6. You will still have it for Button 1 (ie: single tap up and down) and Button 7 (Config button).

NOTES: This will be the production version if all goes well. We will also create an alternate version with more of the unique suggestions (ie: configuring the delay of the on/off, etc), but for the production version, we needed to still keep a lot of the main config button options on here due to hub/gateways that do not allow parameter changes such as Ring, Wink, etc.

EDIT: Tagging @noriscart, @aecky01, @BigInovelliFan, @SirDeadlystrike, @Dlo747, @wsdavis for reference as I know you guys were really pressing this (thank you)!


Nice @EricM_Inovelli @Eric_Inovelli ! Thanks for following through on this! Will test shortly.

Very cool. Got it working, and yes, my wife is very happy! In order to make the new configuration parameter available in Home Assistant, I had to add the following to the device’s xml definition:

<Value genre="config" type="list" size="1" index="51" label="Instant On" min="0" max="1" value="1">
  Enables instant on (ie: disables the 700ms button delay). Note, if you disable the delay, it will also disable scene control except for Button 1 (ie: tap up 1x or tap down 1x) and button 7 (config button). All other buttons (2-6) will be disabled.
  <Item value="0" label="Enabled (no delay)"/>
  <Item value="1" label="Disabled (700ms delay)"/>

Then, I had to exclude the switch, restart Home Assistant, then re-add the switch. At that point, I was able to set the new configuration parameter via the Home Assistant GUI. If anyone knows of a quicker way to get HASS to recognize the new parameter, I’d love to hear it.

Confirm that the white LED and Instant On work correctly in a relay disabled configuration with Hue bulbs.

1 Like

Hey @Eric_Inovelli this is really great. Any idea whether we can expect Instant On to come to the dimmers? If not, I’m gonna have to replace all my dimmers with switches!

Awesome!!! You guys are the best! I’ll be back home on Saturday and will give it a try as soon as I can, thanks again that was super fast!

1 Like

@Eric_Inovelli I don’t know if I should love you or hate you, or both.

2 hours after I just get done updating 38 switches to 1.17, and you drop 1.19 with instant on.

14 Switches flashed with 1.19 so far.

One interesting note, is that instant on appears to be the default state when flashed which is counter to what the info states on the firmware page. So 0 instead of 1.

Also, can we get the OpenZwave Config files updated and PR created so that HA/OZW-Admin can configure instant-on natively.

This is really awesome tho, and fast. Really Fast :stuck_out_tongue:

Amazing man! :heart_eyes:

Time to get a butt load more of these switches. I previously had all GE/Jasco Enbrighten switches but decided to switch to these. This update will solidify the switches as the best out there!! Even the paddles are just more responsive/touchy than the GE ones.

Suggestion for the future. If you could develop a switch with a motion sensor built in that might be a big selling point for some, including me.

Thanks Eric! Keep up the great work and the customer service is unmatched by you guys :heart:


x2 on this. I also have all dimmers

Yes, we wanted to work on the On/Off’s first as they are slated for production this week, but they will be coming to the dimmers as well :slight_smile:

I’m 99% sure it will be on the latest production run, but I’m confirming with Eric M. right now.

Awesome, you’re welcome – happy to get this to everyone!

Let’s go with love :slight_smile:

That is interesting – I guess I’ll defer to Eric M. on this one!

Yeah, I think we can do that once this version is final and everything is flushed out and Eric M. isn’t losing his mind from all the firmware updates, fan/light issues, etc! Tagging @EricM_Inovelli for visibility.

Thanks dude, happy to help and sorry it took so long to get this update out to everyone. We’re definitely looking at a couple of options for a motion sensor switch – we really like a white-label option that our manufacturer is producing, but we’re debating on creating out own as well!


Can you update the location with the new firmware file, all I see there now is the 1.16 and 1.17? Thanks.

I see it’s been added now. Thanks.

Should be up there now – thanks for pointing this out :slight_smile:

1 Like

@EricM_Inovelli Has the updated driver’s manifest been updated for Hubitat Package Manager? It doesn’t see the updated driver at the moment but I see on github, the driver was updated last night.


I had to manually update it vice relying on the Hubitat Package Manager.

The update is now in Hubitat Package Manager:

I noticed this too, but when I excluded it and included it again the default was correct.

Yeah, will get a PR created when I get a minute.


I can confirm this as well. @EricM_Inovelli I’m guessing you don’t want this to be the default for newly produced devices.

Will the config for instant on be toggle-able via the config button at all?

I will verify with the manufacturer but I believe this is the default value based on when I exclude the device it has a 700ms delay and when I re-include it the value of the parameter is 1.

My guess is that the storage space for that parameter already has data in it. When you do the firmware upgrade the storage space is not written over (not sure if this should be part of the z-wave firmware process or not). When I have programmed firmware I have had to write the data upon first boot after a firmware update. Otherwise it retains whatever information was there before.

Another thing that makes me think this is that I queried the parameter after a firmware update and it returned a value of 254 or something really strange.

Thanks for getting this out guys. I downloaded immediately and flashed six switches last night.

I’m gonna have to say, I’m afraid there are some problems. FIVE of the switches were fine, but the sixth one gave me a little trouble. Immediately after I flashed the firmware, the switch jumped out of the gang box it was in, dove over to the counter across the room, and started smacking around my other non-inovelli smart switches. All the while, it was incoherently grumbling something about “the relays ARE off.” After an air gap pull, it calmed down for a bit, but then it started playing some EDM and turned all the lights to strobe mode, waking my sleeping kids.

Finally, after I objected, it called me a racial slur, gave me a good punch in the tummy, and bounced out the glass door leaving shards of chaos and broken dreams in its wake. Oh yeah, and it took my lunch money.

Did I flash the firmware incorrectly?

It switches very quickly though. My relationship with my wife has never been healthier. Nicely done.

1 Like

Figured out a faster way to get the new parameter to show up for existing devices in Home Assistant. No need to remove and re-add the z-wave switches to get the new parameter to show up.

  1. Stop the Z-Wave network (via Configuration… Z-Wave Network Management).
  2. Edit the zwcfg_*.xml in your root configuration directory. For each LZW-30/LZW30-SN device entry, add the below XML to the list of config items. Save the file when you’re done.
  3. Start the Z-Wave network again.

If you don’t stop the z-wave network first, it’ll clobber your changes to the zwcfg.xml file.

<Value type="list" genre="config" instance="1" index="51" label="Instant On" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="1" vindex="0" size="1">
    <Help>Enables instant on (ie: disable the 700ms button delay). Note, if you disable the delay, it will also disable scene control except for Button 1 (ie: tap up 1x or tap down 1x) and button 7 (config button). All other buttons (2-6) will be disabled.</Help>
    <Item label="Enabled (no delay)" value="0" />
    <Item label="Disabled (700ms delay)" value="1" />

Could be. For what it’s worth, in other contexts, reading uninitialized memory leads to all sorts of security problems. That may not be a direct concern here, but it could be a sign of sloppy programming elsewhere. You guys get your hands on the source code yet?