Firmware v1.43 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

Awesome! Thanks! I also noticed now that I am upstairs that the device led bar blinks and switches on/off when done. Makes it easy to tell as well.

Just tried this and I also still notice flicker. It sounds about the same for me as what was reported above: a slight “blip” (think of an old house with incandescents where the fridge is on the same circuit and the compressor turns on…but probably faster and less noticeable) maybe a couple times per minute, sometimes less.

I also share the lack of confidence now that I’ve seen it mentioned: maybe this happened for me on the original firmware too and I never noticed. I’d be willing downgrade to test if needed (suppose I’d need both files and I’m not sure if they’re available anywhere).

More information my setup:

  • No-neutral (I would love to use one if I could in this room…)
  • Two 100W-equivalent (12.5 W) GE Reveal “HD” 2850K LED bulbs (link); I don’t have any others to test with, as all my other switches control smart bulbs, which I’d love to do here, too, but I have no neutral and wanted the Inovelli here more than I wanted those :slight_smile: (and that setup did not work well without one, presumably because on less bright settings, the smart bulbs did not draw enough current for the LZW31-SN)
  • Hubitat, though I can’t imagine anything on the hub side matters for this
1 Like

I am seeing noticeable intermittent flicker as described above. My setup is with Neutral and in a 4-way setup with two GE AUXs. Powering three ~100W equivalent led bulbs.

2 Likes

I have 11 switches upgraded now and have not yet experienced any flicker. I have a combo of 3-way, 2-way, LED, incandescent, and smart bulbs connected with various strategies, but all are connected with neutral. I’ll keep a closer eye out, but nothing noticeable yet.

Edit: all are neutral, sounds like that might be a factor.

1 Like

I can say 100% this did not happen for me on 1.35, had the switch installed for many months with the same light bulbs and it was flawless (as far as flicker). I installed 1.41 at night, and by morning 1.43 had been posted so I upgraded again. So can’t say if I would have seen it on 1.41 but the assumption is yes. It sounds like they knew 1.43 did not fix it since they said a 1.44 would be coming. Just trying to provide any data points I can that might help them troubleshoot the issue.

My symptoms seem to be identical to everyone else, every couple of minutes the lights flicker, like in the old days if something high draw kicked on on the same circuit and the lights cut out for a second. It seems to be semi random, sometimes it happens every 2-3 mins and other times they go a stretch of what seems like 15+ mins with no issues. My setup is without a neutral wire.

2 Likes

If there is anyone else that experiences the flickering can you please post:

Neutral or Non-neutral
Single Pole or 3-way
If 3-way: aux switch or dumb switch
Bulb types and specs
Smart home platform (i.e. SmartThings, Hubitat, etc.)

Thanks!

Also, if you want to try to downgrade to 1.35:
https://files.inovelli.com/firmware/LZW31-SN_1.35.otz
https://files.inovelli.com/firmware/LZW31-SN_MCU_HT32F52241_V1.34.bin

1 Like

Will try to roll back driver this week and see if it helps. Here are my answers more concisely written:

Neutral
4-way(one more than 3-way)
GE AUX switches
3x100W LED Great Eagle (Great Eagle 100W Equivalent LED Light Bulb 1500 Lumens A19 Warm White 2700K Dimmable 14-Watt UL Listed (6-Pack) [https://www.amazon.com/dp/B07RRT8B9L/ref=cm_sw_r_cp_api_i_2kAVEb8J3JRX3](Amazon Product Page)
Hubitat

Update (5/15):
With FW 1.35: Watched TV with lights on last night and did not observe any flicker, will continue to test tonight and this weekend. This was a strong contrast to Tu/Wed night where the flicker bothered my wife and I.

The only other change I made to the configurations was to change the active power reporting interval from 0 disabled, to 45 as with the older firmware the disable does not work as intended.

Update 2 (5/20): still no observed flicker with rolled back 1.35… Night and day difference from 1.41 or 1.43.

I have updated to v1.43 and it still turns off if the brightness is above 80 so that bug still exists. Haven’t had enough time on it to notice if I still have the flicker problem. I am using 3-way with a dumb aux switch with neutral wire.

I just did and haven’t noticed any flicker in the couple hours since I downgraded. However, I did accidentally forget to downgrade target 1 because I forgot which dimmer was which and can say that the 1.35 OTZ with the newer BIN still appeared to cause the problem for me, in case that is of any help. (Or maybe it was the other way around. Did I mention I was confused about devices?) With both at the matching, correct, old (1.35) versions, the flicker is gone.

And just in case I didn’t clearly post what you were looking for setup-wise:

  • Non-neutral
  • Single pole (technically the circuit is three-way but I’ve wired the old switch to be permanently “on” so the dimmer or bulbs shouldn’t really “know” this…)
  • GE Reveal HD 2850K bulbs
  • Hubitat (C-3 with Aeon Z-Stick)

EDIT: Spoke too soon! Now I’m getting flicker but still on 1.35. :open_mouth: (I swear I didn’t notice this before, but with both targets downgraded, I’m not sure I can say the firmware change was related…)

1 Like

Exactly the same arrangement here (1 dimmer with two aux switches using Neutral). Intermittent flicker has been happening since day 1. SmartThings using 3 GE Leds, 2 CE LED can trims, and 3 LED Par20 bulbs.

1 Like

So I have not yet tried to downgrade my switch, here’s what I’ve done and it seems to have helped quite a bit with the flickering. I excluded the LZW31 from Smartthings, did a factory reset (actually twice) by holding the config button for 20+ seconds. I then included it again using the new app (cancelled the S2 stuff and let it add as S0). Went back in and customized my settings for the LED bar color, set params 21 and 22 for Non Neutral and Load Only. Set param 18 for Active Power Reports to 0 to disable it. My understanding is that this is not supposed to work in a non neutral setup anyway.

After all that, I have noticed a lot less flickering. I’ve definitely noticed it a few times, but not as significantly as before and my wife hasn’t been threatening me lately. Other things to note, I typically have the dim level set around 68% and I have my min/max set to 25/85.

Shoot guys, now my 1.43 switches are doing the flicker at 10% with LED lights

These represent a tiny load but it is definitely noticeable and annoying at this setting. I am neutral connected, no bypass. Hopefully @Eric_Inovelli and team can get this figured out quickly.

I’m new to Inovelli dimmers. I am experiencing transient power issues on the dimmer. Usually the power stays on with the lights flickering. Sometimes the dimmer (at least in the Hubitat driver) thinks it’s on, but it is really off. You have to turn the dimmer off then on in the driver to get it back on and in sync.

  • The dimmer is attached to a switched leg containing 3 Philips Hue RGBW bulbs.

  • The dimmer has the internal relay disabled.

  • The dimmer has a neutral wire attached

  • The problem exists on 1.35 and 1.43

  • The issue is more frequent, but not only, at lower dim levels

1 Like

Anyone notice led bulb still faintly on when the switch is off after this update. My wife pointed out to me that in total darkness that all 6 led bulbs are still faintly glowing with the switch turned off but we did not notice this before the upgrade so we couldn’t say if the upgrade did this or not.

It can only be noticed in total darkness but it is glowing and unscrewing bulb will turn it completely off so it not the bulb still retaining power internally.

@TechBill - I have not noticed this, but all my switches are neutral connected. It’d be interesting if you could downgrade and see if there is a difference. Otherwise, you may need to install a Aeotec Bypass to stop the slight dim when the switch is off.

My switch have neutral connected to it.

I plan to downgrade tonight when I get home to test it.

@TechBill - Just downgrade Target 1 first (original .bin file) and see if that solves the problem before you downgrade Target 0. It’d be interesting to see the results.

I used @bcopeland zwave updater to update it so I’m not sure if I would be able to update the bin file with it.

Dang, I’m not sure since I used Z Wave stick…Don’t you just point the file you want to upgrade via his tool? Or did you not update the .bin file to begin with? If not, then my above would be a moot point since you’re probably running the orig .bin file anyways.

I think his tool only update using the otz files. I do have a zwave stick and a window computer with the zwave updater. I will need to dust it off first :slight_smile: