Firmware v1.43 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.41. It addresses some bugs and enhances some features regarding that firmware.

This firmware should be stable, but if there are any issues, please let us know. There are some users that reported some flickering lights with v1.41. If you are a user who has that issue with 1.41 please try this version and let us know if the issue is still there.

Update: Firmware 1.43 has been replaced with 1.44 that has more bug fixes and enhancements. Info can be found here:

Hubitat users that are using @bcopeland’s Z-Wave Firmware Updater tool can use this link to update:


@EricM_Inovelli - I’ll give this a shot in the bathroom where I’ve noticed the flickering tomorrow afternoon.


I updated one of my dimmers to 1.43 with Hubitat and Z-Wave Firmware Updater Tool. However, the firmware listed on the device page still shows “1.35”. When changing the driver to the updater tool, it shows “1.43”. I’ve retried aborting and re-uploading with no change in the above. Is this expected or did the update not complete in its entirety?

Device Page:
Device Events:


The driver only requests the firmware version when the device is first installed or when you click on “Save Preferences”.

1 Like

@Nope @EricM_Inovelli - You can also hit the “Configure” button under the device and it’ll refresh the list.

1 Like

FYI … installed this on 3 of my dimmers and still notice the light flickering.

1 Like

Dang. I got to mow, but will upgrade afterwards. Any luck on downgrade @EricM_Inovelli?

Well there still appears to be some flicker, but I’ll have to confirm once it gets darker out. Like I’ve always said, either I didn’t notice it before (even though it might have flickered on 1.35) and my brain is just looking to find anything wrong. I haven’t noticed any flickers on any of my can lights though; only the bathroom A19 bulbs. I flashed two of my switches to check it out over the next day or two.

1 Like

@harjms @GavinCampbell Thanks for checking. I have already let the engineers know and they are looking into it.


@EricM_Inovelli -Honestly it’s not that bothersome to me. I’d try different bulbs, but it’d literally be the 4th set of replacements. I was try to capture it on camera, but it’s so faint of a flicker the camera didn’t pick it up. Also, it doesn’t always flicker. I noticed it every 4-5 mins for about 10-15 seconds then it would stay solid.

1 Like

Had a new issue last night I’ve never seen before. The lights in the room turned off on their own but the indicator bar was still saying that it was on. I had assumed my wife turned them off at first, as I was in the next room, but then I heard her ask Alexa to turn the room lights on and there was no response. I had to go on my dashboard and turn them off and back on.

I upgraded mine from 1.35 to 1.43 and now have the flickering, was perfect before. Flashed both target 0 and target 1 successfully. Dimmer is connected to 6 can lights, 8.5w LED, I think they’re GE brand (it’s like a retrofit module with the trim ring attached).

Just to update mine: This morning, I used the can light to get ready for work. It is a single can light on the dimmer; I would say every couple of minutes, I’d get a quick flicker, then it would be fine for a few more minutes. This seemed more noticeable this morning than my bathroom mirror lights (6 connected LED A19 bulbs). I’m hoping it’s not a specific bulb issue because I can’t replace my can lights…

Anyone try to update using Homeseer? When i try to load load the LZW31-SN_1.43.otz file on the zwave tab of the LZW310SN root device, i get the following:

​​​​​​​Firmware Update Status:
The button on the device may need to be pressed to start the update

Click the button to choose a DIFFERENT firmware file provided by the manufacturer, to be uploaded to the device.
To start the transfer, press the button on the unit, then press Start. The current file is: LZW31-SN_1.43.otz

Any thoughts on what sequence is it looking for here?

Status on my end, applied the update to the switch and it now says 1.43 Hooray!

Tried to push the .bin to target 1 and it’s stuck at packet #187/398 and has been for over an hour. Can I abort?

@kreene1987 - Yes. I would reattempt after aborting.

Did so and it worked this round. Thanks for the input. Now to figure out which switch is Node 13 :).

Been there, done that. Check out the link @EricM_Inovelli posted for me.

1 Like

I’ve updated an LZW30 with Homeseer, but not a 31. It did not work when the device was included with security. Homeseer would send an unrecognizable Z-Wave packet to the switch and the switch wouldn’t respond. I excluded and included without security and it updated just fine.