Firmware v1.44 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.43. It specifically addresses the bug with the Holtek MCU that caused some bulbs to flicker.

This firmware should be stable, but if there are any issues, please let us know.

Update: Firmware 1.44 has been replaced with 1.45 that has more bug fixes and enhancements. Info can be found here:

Hubitat users that are using @bcopeland’s Z-Wave Firmware Updater tool can use this link to update:


Updating now… will report back.

Edit: This one seems to have fixed my VERY low load flickering. Will keep you posted, but I couldn’t see a dang thing last night for over 2 hours of 1W load.

Updated a few of my lights. I’m still getting the flickering on 1.44.

I know I didn’t have this issue with the original firmware as its so obvious. It started with the original beta.

@GavinCampbell Can you make sure the posted bin file (from the KB article) is also flashed to target 1 in the PC Controller software? The target 1 bin file from v1.41-v.143 have the flashing bulb bug but it is supposed to be fixed in this latest bin file. Maybe flash it again just to make sure.

Will look into it tomorrow.

I have been using the firmware updater tool in hubitat this whole time. So it’s only been the one file that I have been flashing. But I also have a secondary controller that I can try flashing both targets with.

I will report back once complete.

Tried this out today on about 5 dimmers. Early verdict for us is it looks good so far.


Some good news.

Keep in mind I was doing this with the Hubitat firmware updater that only lets us update the otz file. We were not updating the LED bar MCU firmware and there were a few threads mentioning that this was not required.

I did another update with 1.44 and still had the flickering problem.

I was then able to add my z-stick to the network and then do an update of 1.44 again and it still had issues.

I then updated the LED bar MCU firmware and been sitting here for the last hour and it has not flickered at all.

So if my tests are correct, we do need to update both firmware’s and currently that is not possible with the Hubitat firmware updater tool (unless an update is required).

My usb stick arrived today so I should be able to try updating both otz and bin firmware files and report back. I’m also on hubitat and to date have only used the z-wave firmware updated which is limited to the otz firmware file. Will report back when I have tested.

Mine can light was holding steady last night and this morning without a flicker. Seems to be a good firmware distribution.

My Hue bulbs still do not work correctly. The switch just turns off with dim bulbs. But there seems to be no more flicker. Unfortunately the Hubitat hub still believes that the switch is powered on. So one has to cycle the power from the hub or pull the FASS to get the bulbs back on.

I’ve flashed both firmware files twice and excluded/included the dimmer in the network.

I haven’t noticed flicker last night or this morning with the 1.44 firmware. I updated both the otz and bin files with the PC controller. I haven’t tried keeping the lights dim for a long period to see if they turn off on their own yet. I did have that occur once with the 1.35 firmware which sent me down the firmware update path initially. I may try some dim settings tonight.

After updating to v1.38 .bin file, the flicker is gone. BUT the switch now buzzes with dimmed low (none of my Inovelli dimmers buzzed prior to v1.38 .bin) Anybody else notice this?

The dimming range for my LEDs is set to 40-80 (as below 40 I get some Bulb flicker or turn off and above 80 I don’t observe Brightness improvements). That said I don’t hear any dimmer buzzing. I can try to expand my operational range later and see if this changes. What level do you notice the buzzing at?

My Hue lights went into a continuous flashing state at a high dim level today. That flashing must be a Hue response. Had to turn off the dimmer for at least 30 seconds to get the lights to stop flashing.

I’ve been selectively updating firmware LZW31-SNs that had shutoff issue in a 3way with original fw and flickering with 1.41/43.
With 1.41 and 1.44 all earlier issues were resolved, yet I unexpectedly ran into a new issue in the 3way setup when changed a dumb 3way Leviton switch to a dumb 3way illuminated (lighted) switch Leviton 5613. New lighted switch is wired identically to the working non-lighted 3way dumb sw. I tested with 2 different lighted switches. My setup is described here. The issue including the lighted switch is consistently reproducible…

Issue: When 5613 is in OFF position (red glowing illumination is ON), turning ON Inovelli - relay clicks, light starts ramping up and in about 1 sec (at around 50%) relay clicks again and light bulbs shut off.
When 5613 is in OFF position (red glowing illumination is OFF), turning ON Inovelli - relay clicks, Inovelli blue level indicator goes to full but light bulbs remain OFF.

As I mentioned earlier, it’s easy to reproduce and I dread the response maybe “not supported”. I need illuminated switches in both locations. Anyone’s using a dumb illuminated switch in a 3 way setup WITH neutral?

Dreaded response: AFAIK, the use of an illuminated dumb switch with the Red dimmer is not supported. Innovelli should confirm, though.

  • Switch Type (3-Way, 4-Way): Dumb (Existing Switch)
  1. Please do not use a dimmer dumb switch or an illuminated dumb switch


Confirmed, you unfortunately cannot use an illuminated dumb switch :frowning:

Although not a cost perfect solution, if you need an illuminated switch on both ends, you could put another Inovelli dimmer switch where your dumb switch is and set the min brightness up higher so it appears to be illuminated.

This solution while costing more, comes with a bonus of also being able to set the color of your illumination, ability to send notifications to both switches, and use scene control on both the switches.


This happened to me right after updating to 1.44 but was resolved after pulling the air gap for a few seconds and making sure the dimmer was at 99 (or 100%). I don’t recall this happening with previous updates, so I’m not sure why it happened here, but I suspect I’ll unscrew my smart bulbs during things like this in the future just to make sure I don’t hurt them. :slight_smile: I haven’t seen this in regular use. Is that when yours did this?

On the bright side, I haven’t had the Hue bulbs or the dimmer spontaneously turn off at low loads like I have in the past (though it didn’t always happen then, either), so that’s good!