image not found img not found

Firmware v1.45 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.44. It has a couple changes but is mostly meant to correct incompatibilities with smart bulbs.

We had to remove the ability to use local config mode to edit the “Invert Switch” and “Default Z-Wave Level” parameters to make room for these changes. We think this is a rarely used feature and they can still be edited through the hub.

One bonus is that we were able to add the ability to change the LED to “white” with config parameter 13 set to 255.

This firmware should be stable, but if there are any issues, please let us know.

Hubitat users that are using @bcopeland’s Z-Wave Firmware Updater tool can use this link to update:

https://files.inovelli.com/firmware/LZW31-SN/Beta/LZW31-SN_1.45.otz

4 Likes

@bill.d @BertABCD1234 @kreene1987

Can you guys test the new .otz & .bin to see if compatibility with Hue bulbs has improved?

1 Like

WHAAAAT?!!?!?!?!

2 Likes

4 Likes

Sure! On it:

Say no more. :slight_smile: I’ve updated and, unlike last time, didn’t notice any problems immediately after the update (i.e., no immediate flickering even though the Hue bulbs were on, powered through the dimmer, for the duration of the upgrade). I’ll let you know if I see anything come up later!

@kreene1987 @BertABCD1234 Fingers crossed! This is actually a tough one to overcome because there is a balance between making the dimmer work well with smart bulbs and detecting proper dumb switch toggling.

First pass at setting as white through Alexa changed it to red??? Will test Webcore next. It’s shocking that ST can’t get me color control for these switches and Alexa can lol.

Edit: WebCore has the same behavior, red led bar.

White works on Hubitat (after adding white to driver)

3 Likes

This is great news. Been waiting on white since the beginning! Thanks for this update!!
Will be trying this out immediately.

Hrm, still nothing on ST. It always changes to red…

Yeah, @Nathan_Inovelli and I had this problem earlier – Nathan, we were on Hubitat though, right?

We were using hubitat. I’ll check it again.

1 Like

Confirmed latest DTH installed too… This is actually a bigger deal than I thought. Told my wife and she is like DO IT TO ALL OF THEM! Bummed it’s not working.

Works fine here. Believe me if I can do it, everyone else should too.

2 Likes

I couldn’t do it…

1 Like

working great on two dimmers so far, I’m on openhab, so all firmware updates for me are done through PC Controller.

I did notice sometimes OTA firmware updates don’t “take” for some reason. If the indicator is lit in red, you might want to try again, especially the *.bin file.

FYI, there are updated device handlers and drivers in our github (for the white LED). Also, the white LED requires the bin file to be flashed as well as the otz.

1 Like

Ok mine is resolved. I did have the updated driver and both firmware updates were applied correctly, BUT was trying to set via Alexa vs the switch settings. Once I selected the white in the switch settings it worked perfectly!

That said, Alexa still sees the switch as Red and when I change the color to white it still goes to Red from within the Alexa app.

Edit: I would also prefer if the changelog at the top indicated what/when changes were made to the driver. I updated it after scrolling through the changes, but still see only the 05-05 change to add setColor function at the top.