Firmware v1.43 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

@TechBill - It’s easy on Hubitat; no need to exclude to include on your Z Wave PC Controller. Just add the Z Wave to your Hubitat network and it will populate all the Nodes in your network. Find the correct node ID and flash away.

Cool … I’ll do that then.

I am going to download the PC Controller to my MacBook Pro and try updating it from there. I have Windows10 running under Parallel on it.

1 Like

Yes, I’ve seen this issue, but it appeared before the firmware update, and also with smart switches from other companies.

It’s common with many LED bulbs. As @harjms mentioned, usually solved by either adding an extra load (aeotech bypass) or changing to different branded LED lights


Looks like you are right. The bulb still glow for another 5 minutes after taking it out of the socket. It ones of those first generation led bulb so I will just go ahead and order me 5 newer led bulb and hope it will solve it. I just test it with one standard led lamp bulb and it did go out completely.

I ma guessing I need to get at least 5 watt per bulb to give it enough load to prevent this then? 5 x5 = 25 watts total?

another question … I updated the otz file … should I also update the bin as well too?

You can. I have a mix of all upgrades and a couple running 1.43 with original .bin file. The latter seems to work better as far as beta firmware c

Is this firmware (or the previous 1.41) supposed to fix a bug that causes power to turn off unexpectedly? I have a lighting circuit that has 12 Hue bulbs, and everything works fine until I set the bulbs to a dim setting (via a Hue scene). Then somewhere between a few minutes and an hour later, the power shuts off at the dimmer. The dimmer doesn’t realize it’s off (the LED bar indicates power is on). Resetting the dimmer via the air gap switch fixes it temporarily. Also, turning the dimmer off/on via HomeAssistant fixes it temporarily as well. This issue doesn’t occur if I use the lights at either full brightness or off. This is using neutral in a single pole configuration, local protection enabled. This has been an issue since the original firmware; neither of the beta releases have addressed it.

Please let me know if this issue is being tracked elsewhere. Thanks!

Not sure if it’s “tracked,” but I reported this issue on the original firmware. I’ve been testing the most recent two betas, and they don’t seem to have changed anything here, either.

EDIT: 1.44 seems good for me so far…though this issue didn’t always happen on the older versions, either. Still good!

Have you also been updating the Holtek MCU for your testing? I cannot replicate the issue since 1.41 but I have been updating both target 0 & target 1.

Yes, both updates applied each time.

I also just tried the workaround described here: [TIP] Gen 2 Dimmer Shutting Off - Possible Solution

It didn’t fix anything. I left my lights on in the dim scene, and they lost power after about 80 minutes.

At steady state, when all the Hue bulbs are off, power is reported as 11w. When all lights are on dim (my “movie” scene), power consumption is reported as 18.5w. After the dimmer cuts power, it reports 4.1w power utilization until I reset things. I don’t know where that 4.1w is going because none of the lights are responsive. As soon as I flip the dimmer off/on again, power returns to normal. The part I don’t understand is why the dimmer is fine when the Hue bulbs are “off” indefinitely, but as soon as I turn them “on” to a dim setting, it acts up. If it was only the low wattage bring a problem, you’d think it’d cut power even when the Hue bulbs are off. Let me know if there’s anything else you’d like me to try.

I tested last night with an A19 hue bulb dimmed to 10%. I let it sit for about 6 hours and it stayed on. I am using the otz and bin file for firmware 1.44 though. Can you see if it makes a difference for you?

I’m performing the 1.44 updates now, will let you know how it goes.

No luck. Lights stayed on for < 40min before power cut off.

No luck for me too. First time flicker, second time cut off. It may have taken slightly longer for the failures than previous firmware versions.

Updating now… will report back findings on my flickering issues in this comment once I have a night or two to test.

@kreene1987 Did you get a chance to test?

So far I have about 4 hours of consistent low-load lighting. No issues to report on 1.44 (this thread is 1.43).

1 Like

Neutral or Non-neutral: Neutral
Single Pole or 3-way: 3-way
If 3-way: aux switch or dumb switch: Dumb switch
Bulb types and specs: BR30 LED (6)
Smart home platform (i.e. SmartThings, Hubitat, etc.): Hubitat
Firmware version: v1.44

I’m going to try to downgrade to 1.35