Firmware v1.56 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

This is a small update that is meant to enhance the consistency of aux switches in 3-way mode. Especially when in a non-neutral configuration.

https://support.inovelli.com/portal/en/kb/articles/firmware-change-log-lzw31-sn-dimmer-switch-red-series

4 Likes

When you say “aux switches in a 3-way” are you referring only to the ‘smart’ aux switches (e.g. GE Enbrighten Add-On and similar) which are enabled via Parameter 22 (Switch Type) = “3-way Momentary”?

Or does this include some enhancement for the ‘dumb’ slave switches in “3-way Toggle” mode?

I’m asking because about 90% of my lighting is Inovelli Red Dimmers in a 3-way Toggle mode (dumb slave switches). When I updated to v1.55(beta) I started noticing the “turns on then quickly off” problem again. This was an old issue that was initially worked around by setting max level (param-6) to 80% but was fixed in one of the firmware updates along the way. But now it seems to have returned for me running v1.55. I’ll update to v1.56 and see if it makes any difference

The 3-way dumb switch mode, as far as I know, was not messed with. I will check though to make sure.

As far as you know, should the ‘turns on but quickly turns off’ issue be resolved? I remember earlier versions of firmware suffered from this and the workaround was to set the max level down to 80%. My memory is slipping and I may be wrong, but I thought it was fixed along the way. If that is true, can you refresh my memory which version fixed it?

I haven’t seen the issue in many months, but seems to have come back recently. I believe I started seeing it again with the 1.54 release or something close to that. I may try falling back to 1.52 to see if it goes away…

Hi,
I installed the 1.56 firmware and my bug with my slave switch (Homeseer) still be there.
It’s neutral wiring and my aux switch can turn off light but don’t turn on.

4 Likes

Is the min dimming level going to be changed so the dimmer can be forced to act like an on-off switch?

Firmware 1.54 added a new enum for SBM (param 52). There was a problem with on/off that was fixed in 1.55.
0 - Normal
1 - On / Off only mode
2 - Smart Bulb Mode.

Hi Eric,

Yesterday I updated from 1.52/1.43 and programmed 1.56/1.44.

Switch # 1 - basic single switch NON-NEUTRAL install, no associations, dimming behaviour is fine.

Switch # 2 - basic single switch NEUTRAL install, no associations, The switch has lost the ability to dim the output - if the switch is on at any dim level, the light is on at 100%. Went to driver, hit Configure for good measure, it is reporting the correct versions. Made sure setting were the same as switch #1. Saved Preferences. I could not get dimming to work. Reprogrammed Target 0 & 1 again (in that order - i don’t know if its correct) - same. Select NON-NEUTRAL install and hit Save Preferences and dimming functionality returns. I switched back to NEUTRAL and broke it again.

Switch # 3 - basic single switch NEUTRAL install - same as # 2

I also experienced this issue but have not seen it happen since upgrading. Ive only had it live for about 2 days though.

2 Likes

Did you try flipping the parameter 52 to 1 then back to 0? Sounds like SBM might have been engaged by the firmware update.

2 Likes

Thanks for the reply. it shows that the smart bulb mode is off and the switch still does control the bulbs on/off state. it just doesn’t control the dim level anymore.

oh, and i lied … switch # 3 is not in a 3-way setup … it’s in a two gang box an teh other switch is the one i have in a 3-way setup. i will edit my original post.

Can you toggle SBM to 1 and then back to 0 and try again?

1 Like

I just re-read @kreene1987 post again and you replied before i got back here.

Yup, that works !!

I set SBM now has three options … the ON/OFF is new since 1.52
I changed SMB to ON/OFF & saved (and tested - same behaviour)

Changed SBM back to DISABLED and it now dims.

Thanks guys.

1 Like

Haha glad you re-read! Sometimes firmware installs trip the parameter settings to something other than what was LAST reported, so it sees something different than it is. In order to re-align the hub to the switch you have to flip/flop the parameter between settings.

Glad you are sorted!

3 Likes

This is good advice and actually seems to be much more common lately with new and changing parameters in the recent firmware updates.

My new SOP with new firmware is to flip/flop all the parameters that are new or changed in the firmware update.

1 Like

I was using the following instructions,
How To: Update your Dimmer Switch Firmware | Hubitat, to update the target 1 firmware with the v1.44 Holtek MCU but it is failing.

  • firmwareUpdateProgress : FAILED: The device was unable to receive the requested firmware data

upgrading target 0 to 1.56 was good.

I even tried target 1 with the 1.41 version too and it failed.

@atchinson If you haven’t tried this yet, pull the air gap and reboot the hub then try again.

Had already tried that. Did not help.

If you are on a C7 hub have you tried using the built in firmware updater? I know people have issues with it but it has worked great for me.

1 Like