Firmware v2.30 (Beta) | LZW42 | RGBW Bulb

I haven’t seen anything about BR30 bulbs coming, but put me down for one when they do! Alternatively, I may just do a Cree retrofit kit and install a dimmer. Granted I would love a RGBW bulb.

We’ve been asking for these for a bit. They may eventually get here, but if they’re looking at 700 series chips for the RGBW bulbs it may be a bit.

Ugh, it looks like mine are already in the mail. Your fulfillment process is just too good, @Courtney_Inovelli :smile:

No not a big deal, I’ll just flash them in a test lamp, and leave them plugged in for a while if necessary for them to come back to life, before installing any of them.

1 Like

Zero issues with the update of my 15 using a UZB and Z-Wave PC Controller.

You can purchase the UZB here

lol! My bad! :wink:

1 Like

May I ask you to do a brief writeup of how you updated using the uzb and pc controller software

Yeah, this is one we’re waiting for the 700 Series chip to come out for. The manufacturer currently only produces the BR30 in ZigBee and cannot manufacture the bulb in Z-Wave due to the 500 Series chip not being compatible with California Title 24, so we have to wait for the 700 Series chip to be produced.

Good news is that it seems to be produced and released, however, from what I understand fro SiLabs, they are requesting the manufacturer to purchase 1M chips and I’m not sure there is the demand for this right now. We’re going to talk more about it with them tomorrow to see if other companies have interest as we are no where near the 1M mark for units.

More to come!

EDIT: What @harjms said lol

You can follow these steps here (but use these instructions to include/exclude):

The file used can be found here:

Hope that helps!


Thanks! And we need BR30 bulbs NOW!!!

I just followed Inovelli’s instructions

1 Like

@Courtney_Inovelli it’s no big deal. I’m halfway though flashing the 11 open-box bulbs that arrived this week, and the process is pretty painless so far.

Does the current firmware support the memory function of “Bulb turns OFF after power outage”?

The driver enum matches the instruction manual numbers and only supports “On” and “Last State”.

The z-wave certification lists the option for “Off” but the values are also different.

I am new at this and I did use the updater tool with Hubitat and I updated one of the LZW 42 bulbs the (multicolor bulb) And it did stated that it was at 100% but it was saying that it was flashing the bulb I waited for an hour and it continued To say flashing so I hit save after changing the driver back to the bulb driver. The light appears to be working do you have to wait till it states complete it or once it says 100% download it is the update completed. Thank you

@npk22 – let me look into this for you. I’ll PM the engineers. What hub are you using? We can also manually try this to see if it works while we wait for them to respond.

Yeah I did the same thing when I first started lol – when it gets to 100%, you can stop it there :slight_smile:

Thanks for looking into it for me. I am using a Hubitat for my hub. I had tested modifying the enum to include more values but those values did not change the behavior.

There should be 3 possible values:

Value Description
0 Previous State
1 On
2 Off

I use Home Assistant/OZW, but I am able to select all 3 values without issue.

Ok, cool and thanks @jtronicus for confirming.

@EricM_Inovelli – if this is the case (ie: On, Off, Last State), can you update the driver to add this functionality?

@npk22 – what you can do in the meantime to test this is install the, “Basic Z-Wave Tool” driver.

Then when you change your Device Type to, “Basic Z-Wave Tool”, fill in the following:

Parameter - 2
Size - 1
Value - 2

Can you see if that works?

Actually @Eric_Inovelli , I just found out that although I can set the value without issue and confirm that the value is saved, it doesnt actually seem to do anything. It doesnt matter if I choose Previous State, On, or Off, the bulb always returns to the previous state when power is restored.

All my bulbs are on 2.30, so I am not sure if this issue was introduced in the beta firmware, or if it was present before. Is the previous firmware version available somewhere so I can try downgrading to see if that resolves the issue. I didnt see it on the firmware page.

Hmmm… bummer – I can’t find the stock firmware in my emails at all. I’ll reach out to the manufacturer to see if we can grab it and/or confirm this is a possibility (OFF state).

This came up in a previous thread, and despite the certification noting support it seems to be lacking on the device side.