Firmware v2.30 (Beta) | LZW42 | RGBW Bulb

@EricM_Inovelli I have tried both include and exclude, it doesn’t respond at all. In fact, I just plugged it into one of my Z-Wave power outlets that can measure power draw, and it doesn’t seem to be drawing any power. I get 0.000 W when I turn the lamp on, compared to 9.403 W for a standard LED bulb. I’ll leave it on for a while just in case it decides to wake up.

I opened a support ticket on this last night as well (figuring this may be a warranty replacement).

hey, if you dont mind me asking… what driver do you currently use on your bulbs?.. just trying to get and idea on wich one has worked s out best for you. some say the built in driver on hubitat is good but for me its been a hit or miss thing… sometimes its fast sometimes it slows down my hub complately.

I use the built-in (I wrote them)… When the built-in on 2.2.2 hub version detects 2.30 it adjusts how it communicates with the bulb to take advantage of the improvements in 2.30

awesome thanks , just got 20 more bulbs when they went on sale and currently changing out my hue bulbs, just at wanted to get an idea on what you were having success w

ith :sunglasses:


@bcopeland … based on your comments, I suspect that you’ve successfully used your Hubitat updater to push this firmware? any idea what I could I be doing wrong getting this loaded? I’m using the latest version of the updater and had no problem loading an LZW36 with its new firmware … but despite many attempts (all of which seem to be successful), the bulbs never end up being updated.

I’ll add to this that process always gets to the “last packet sent, waiting for device” message (or something like that) … 30ish seconds later, the bulb flashes if it was on (or turns on if it wasn’t already) … and everything indicates that the upgrade succeeded despite the firmware still reporting 1.28.

What if you try the non-binary version of the z-wave updater to do the hex update (if you haven’t already tried it)?

I don’t have that one to try … I thought the new version replaced it for download. If someone points me to the other version, I’ll give it a shot.

does it say process completed when you try updating the firmware?

The final message is “Complete device is flashing…”. Then after a bit of time is when the bulb either blinks, or powers on.

Yep… Sorry… I should have posted something… There appears to be a bug in. the binary updater that affects .hex files that include bootloaders… I need to fix that:. OTZ / BIN and GBL files work fine:.

1 Like

if it says complete than it should be flashed. when yoy do a version check does it give you version 2.30

Is this the type of bug that is little more than a minor oversight?, or the type that takes major brain power to rectify?

If it’s the latter, would it be possible to repost the previous version of the updater (in addition to the current version) in the meantime?

I did manage to find the other version of the updater this morning, and the firmware updates worked. Given that both versions have the same name and and version number, it was a little challenging making sure I had the right version … but the old version does work fine.


What firmware version do the Unboxed Ilumins come with? What about the brand new ones?

I believe they all ship with the last ‘official’ version.

1 Like

The unboxed bulbs come with v2.28 at this point in time. If you ask nicely they may be able to update them for you.

1 Like

@kitt001 and @amdbuilder are correct, they come with 2.28 – also, yes, we can update them for you. Just make sure to put it in the notes when you purchase so @Courtney_Inovelli knows :slight_smile:


That sounds amazing. Thanks!

Well shoot I just got my 15 today and I am on 5 of 15 updating to 2.30…well I guess it keeps me out of trouble :grin:

Eric if the wife has her way (and she always does) I am going to need 45 BR30 bulbs…are they coming down the pipe?