Firmware v2.31 (Beta) | LZW42 | RGBW Bulb

Thanks all for confirming :slight_smile:

Can anyone who has a C7 confirm?

I just removed the bulb and paired it to a Z-Stick and PC Controller and it’s also reporting 2.28.

I’m going to upgrade this way and see if it works on Hubitat.

Edit: I managed to update to 2.31 and after a couple of tries, get it to pair with no security to the C7. I’m confident the cadence was the same each time during inclusion, but somehow in the third try it worked. I still am not sure why the update didn’t stick when using the updater on Hubitat.

Any chance the 2.28 firmware was uploaded by accident? I tried to check for the 2.28 to do a md5 comparison but it’s not on the ftp.

24b9a1129687aa4898c2489e77b026e1 LZW42_2.31.hex

The update was successful on your stick, or via Hubitat?

On the stick. I could not get it to update on Hubitat for some reason.

md5 hash of 2.28 is:
48e47330b5deb1dad87c68ecbfe99b5b

I have done the update on a C-7 and C-3 by using the old Firmware Updater driver. Make sure you do not use the “Binary” updater if you go this route because this is not a binary firmware file. I have not tried it with the built in update application.

Hit “Save Preferences” after switching back to the normal driver and it reported 2.31.

image

2 Likes

I tried to do the update on a C5, but it didn’t seem to take, despite using this to update to 2.28. I flashed again from a C7, and that stuck, and I just got a bulb to pair normally. It’s definitely a finicky process, and I wish there was some more visual indication (like the bulb turning cold white when it’s in no-security mode), but I’m so happy that I can start transitioning to my C7, now.

For us not as familiar with the terms, can you define S0 & S2?

S0 and S2 are different types of zwave security.

Security Description
Non-secure No encryption
S0 Less secure than S2. Uses about 3x more network traffic than either No Security or S2
S2 Current (preferred) security type. Pretty much better than S0 in every way

Generally, for devices such as switches/lights, Security is a nice-to-have but not critical feature. Since S0 uses so much network traffic and people run into so many issues with it, most people prefer to use either S2 or non-secure (and avoid S0). Since the LZW42 does not support S2, it is better to use non-secure.

Some hubs do not allow a user to choose which security level to use during inclusion, and will automatically choose the “best” level (S2 → S0 → non-secure). This firmware update allows a user to put the bulb itself in non-secure inclusion mode in order to avoid using S0.

3 Likes

Yep, I have done 11 bulbs with the PC Controller and they are reporting the updated firmware correctly. The Hubitat updater is honestly pretty bad.

1 Like

I gave up on my Hubitat C7. The bulbs, 3 of them, are all on 2.31 but I cannot get any of them to pair anyway but S0. Maybe a different firmware will come some day and I can try again.

That is so weird. I have tried multiple times and can get non secure pairing every time.

I imagine you have seen my demonstration video?

Good morning all, new forum member but I’ve had the red dimmers and these bulbs for a while. I’m working on updating all the switch firmware, and was trying to located the bulb firmware, but it is not on the website, does anyone have the files?

Thank you!

Actual firmware files can be found here:
https://files.inovelli.com/firmware/

Thank you! When I click the file I see the hex, do I have to save some speacial way?

Sorry, newish at this. I have the smarththings, using my zwave stick and the recommended program from the support files.

I’ve successfully done a few switches, but those files were otz and bin files.

Thanks again!

You should be able to right-click to save the file

Think you can also ctrl or alt click if I remember right too

Got it, don’t know what I was thinking. It saved as a .hex file. I haven’t tried the update the bulbs yet. I’m assuming this is the only file I need, not 2 like the dimmers?

Edit, just went back to the support page. I see now, sorry for the silly questions. Target 0 is the hex file.

Thanks again all!

2 Likes

I’ve updated the web server to force a download when a user clicks on one of the hex links now. If it doesn’t work for you that way immediately, it is probably because your browser has the file cached and is loading it from there.

1 Like

I have but it didn’t seem to want to pair to the C7 with no security regardless. Going to try to pair a secondary controller and see if I can get it to go that way.

1 Like

Actually I finally got it to work without the secondary controller. I was power cycling by twisting and untwisting but change to a place where I could flip a switch and that seemed to work pretty well. Just had to do one of the three twice. Thanks.

1 Like