Firmware v2.31 (Beta) | LZW42 | RGBW Bulb

This update is mostly for SmartThings users that have not been able to associate their switches with the LZW42 because SmartThings does not fall back to S0 if it fails S2 like it used to. This change adds the following feature:

  • Quickly turn the bulb on / off 3 times to put the bulb into NON-SECURE inclusion mode.

off-on-off-on-off-on

Note: Toggling 1 time still puts the bulb into S0 inclusion mode.

In SmartThings, when you include the switch or dimmer you need to skip the S2 QR code verification so that the device will include in non-secure mode.

3 Likes

I’m guessing this will also work with Hubitat C7 users? Should we expect any visual confirmation of secure vs non-secure pairing?

Personally, I would prefer secure pairing to be the three toggle and default to non-secure. Granted that’s being nitpicky, I will just be glad to have an option. :slight_smile:

1 Like

No visual indicator at this time, but yes, it will work with Hubitat.

@EricM_Inovelli Awesome. That will make things easier in ST. I did manage to pair a bulb unsecure over the weekend. I’ll try to do it again in a video. I initiated the normal pair process but after the double blink I quickly removed and then applied power.

1 Like

@EricM_Inovelli I just updated and tested the insecure pairing process with one of my bulbs. I was unable to get the insecure pairing to work with a C7 hub.

I did notice the bulb does “flicker” once when you turn it on if unpaired. This same behavior was noticed when attempting the insecure method. So it’s possible my timings are off, or something else. I attempted the process a few times with no success.

Any additional guidance you can offer would be appreciated.

Here is a video of my timing for reference: https://photos.app.goo.gl/s5oUyrwBsTMmTwcw7

Are you sure the bulb has been excluded? Turning it off and then on is still the way to put it into exclusion mode (3x off/on does not put it in exclusion mode, only non-secure inclusion mode).

I updated a bulb with Hubitat and it’s still reporting 2.28… I also updated the same bulb to 2.30 a few weeks ago and didn’t realize it was still indicating 2.28 until going to do this update. Is this normal??

After you switch the driver back you need to press configure then refresh to see the firmware version update, sometimes it takes a couple presses of configure.

Tried that a bunch of times. Also tried switching back to the firmware updater driver and tapping get version report. It always just shows 2.28. I don’t get it.

Ok I’m getting really frustrated here. I took a bulb, disconnected all other Zwave devices from power, excluded the bulb, included it, applied the firmware update. I did this two times. The version still reports as 2.28. I tried several times to do the unsecure inclusion anyway… I see the bulb blink twice but Hubitat never finds it. As soon as I put the bulb back in normal inclusion mode, the hub finds it immediately and includes it at S0 no problem.

If it’s any consolation, I’m experiencing the exact same issues.

I didn’t realize it until today when I saw this thread. I spent the last week or so updating the bulbs. I saw them blink to confirm they finished and just noticed they all still say 2.28. I have 10+ of them that all say the same thing.

Are you on C7?

Also, has anyone who’s flashed 2.31 (or 2.30) got it to report otherwise?

Yessir. Honestly the firmware version reporting is annoying but not a killer since it’s expected at this point. The killer is that I can’t get the unsecure pairing to work.

Yeah, I’m more curious now if it’s a reporting issue or if the firmware isn’t taking. I was waiting until this weekend to try the unsecured inclusion. I guess we’ll see!

Since this thread doesn’t appear to be hub specific, I do see the firmware version reporting correctly as 2.31 using ZWaveJS in HomeAssistant. I no longer have any bulbs on 2.30, but I can report prior to upgrading yesterday they reported correctly as 2.30.

I suspect the firmware is at least partially working…when I do the off/on*3 process I see the bulb blink twice, but then Hubitat refuses to see it. If I do off/on one more time (so it’s in “normal” inclusion mode) then Hubitat sees it right away and includes it at S0.

Hmmm… ok, I’ll play around with it this weekend too. Out of curiosity, did you follow @EricM_Inovelli’s cadence here: https://photos.app.goo.gl/s5oUyrwBsTMmTwcw7?

I haven’t had a chance to test, but I’ll follow up when I do.

I updated mine to 2.30 a while back on a C-3 and they report correctly.


I haven’t tried 2.31 as it sounds like it wouldn’t add anything over 2.30 for my hub.

Tried to best I could, and I assume it worked since it does behave differently when I do it (differently as in Hubitat acts like it isn’t there).

Using the 2.30 firmware I manged to get it to pair insecure a week ago with ST. I still owe @Eric_Inovelli a video. Start pairing and when it flashes immediately cycle the bulb off and back on. I only tried it once so I’m not sure how repeatable it is. I’ll try do get a video this weekend.

1 Like