LZW31-SN: Force-Add as NON SECURE?


Due to the fact I can’t add any of my Fibaro RGBW Controllers as secured to Smartthings, I would like to add the Red Series LZW31-SN dimmer as NON SECURED. The reason is due to I’d like to use the association tool and get these two to talk to each other, but the secure mismatch won’t allow that. Smartthings adds the LZW31-SN as Secured… but I need to somehow stop this.

Is this even possible?

So as an update:

I’ve tried to removed, then re-added the switch from outside in my backyard shed. I was hoping that distance would force the switch to communicate with the hub via one of my other devices via though it as a repeater. That didn’t work as the switch still paired as secured.

I need this pairing because my Fibaro RGBW Controller is not connected though any switch… only by WebCoRE to control it. I’m using the LZW31-SN more as a scene controller… powered, but no load, and sometimes there’s too much delay. Direct association should make it almost instant.


I have the same issue, trying to use direct association between reds series switch and Aeotec Dual Nano Switch. Is someone find a solution to force “non-secure” association (S0 is not working).


@Bry - I believe you just went through this for a switch? Any tips to force non-secure on ST? Move further out or ?

I didn’t have to do it, but from what I understand, the trick with ST is to not use the barcode and select “Scan Nearby” at the top right of the Add Device page. I believe that will pair it S0.

If that doesn’t get it, move the device away from the hub and try it that way again.

1 Like

Yep I run into this to associate my ilumin bulbs.

Pair via the “scan” function instead of selecting manufacturer inovelli. This should pair S0.

I’m wondering if something has changed with how SmartThings works now. I keep reading that canceling out of the barcode scanning will include devices at S0, but when I do it, I end up with: " * networkSecurityLevel: ZWAVE_S2_FAILED".

Am I misunderstanding something? I’m ultimately trying to find a way to get my red series dimmers to include into SmartThings with S0 to match my bulbs and setup an association. Does anyone have any insight?

Yep, that used to be the case but it has changed. Are you trying to associate with an Illumin bulb? You can force that to pair non-secure, so the intent is to allow it to pair with a ZWAVE_S2_FAILED dimmer.

An older workaround used to be to get the device as far away as possible from the hub, but I’m not sure if that’s a valid workaround any longer.

Thanks, Bry! I’ve tried this and am able to get both the switch and bulb to include showing Data: zw:L, which is what I thought I needed, but the association still doesn’t work.

I do have it working with an Inovelli bulb and Inovelli on/off switch that are both at S0 (paired with the old classic app), so that tells me that my association smartapp is working (association tool child device is also installed and both apps are up to date via github repository linking).

Do devices HAVE to have some security on them for association to work via SmartThings? Is there something else I could possibly be missing?

My understanding is no, they don’t have to have some, they just need to match. If you are seeing zw:L for both, they are both paired as insecure.

I haven’t done this personally so I can’t speak from experience. Tagging @harjms, although he is on Hubitat. Maybe someone else with SmartThings can comment.

If you haven’t see it, here is the guide to associating:


I just thought they had to match. So if Switch A was S0, Switch B or bulb had to be S0. No mix-match of security associations.

So, I found out that if I pair the switch and cancel out of the security scan, I get S2 Failed. And then it doesn’t even show the association group fields in the IDE. As far as I can tell, with the way that SmartThings currently works, it is not possible to do an association with a red dimmer and RGBW bulb from Inovelli in SmartThings. I reached out to SmartThings for confirmation/help, but they tell me this isn’t supported…

So…I just setup HomeAssistant on a Raspberry Pi for the first time last night and was able to pair these devices and do the desired association.

1 Like

Welcome. As you wade in feel free to tag me. I’m really glad you are testing it out. It really is a great and POWERFUL platform.

You won’t miss ST once you get set up. No one ever does… :D.