Having issue with z-wave association between dimmer and bulbs. Illumin becomes unresponsive until I turn relay on/off

So Ive posted about this issue before but it went away, and I wasnt sure what it was that I did to fix it. Ive now figured it out and am unsure what exactly the issue is.

I have a red series dimmer that controls two fixtures in my bathroom. Each fixture has 1 illumin RGB bulb. I have created a z wave association between the three (as outlined in this post). I then turned off the power relay, so that the switch provides power to the bulbs fulltime.

Most of the time, this set up works amazingly well. The lights turn on and off immediately, as well as dim. As you would expect.

But every two weeks or so, I will go to hit the switch and find the bulbs are completely unresponsive. The bulbs will also show up in my frontend, but are also un-responsive to commands via hass. There appears to be power to the switch, as the LED is on. Turning the power relay back to normal (config x 8) and then turning it back off (config x 8 again) fixes the issue immediately.

Any ideas?

Which firmware are you on? I seem to remember some “local protection” issues with the stock firmware that may have been addressed in one of the beta versions.

Im on whatever it shipped with (got it about 2 months ago), I didnt even know you could update the firmware!

They haven’t finalized the firmware update at this time, but you can read more about the beta version here: Firmware v1.43 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

It looks like there was some association and local protection changes in 1.41. I don’t use either, so I’m not sure if it would address the problem you are having.

A note on the firmware updating: since you are using HA, you have a separate zwave controller dongle, which means you can skip the whole section in the firmware updating instructions that requires you to “exclude” the device. Simply power down you HA instance, take the zwave stick, plug it into your computer, and the switch is already bound to the stick. You can continue the firmware upgrade from there, and once complete, add the stick back to you HA instance and power back up.

1 Like

Great recommendations from the community! At first I thought maybe there was a power outage that was causing the switch to return to an off state. There was a bug where if you had local protection enabled the dimmer wouldn’t return to the proper state after power is restored. That was fixed in 1.41+ It doesn’t sound like it though since the LED is on for the dimmer. We’ll get it figured out, but one little shortcut if the bulb is unresponsive you could pull the air gap tab out of the bottom of the dimmer and press it back in to reboot the bulb.

Make sure you have the latest firmware and the “state after power failure” set correctly though or you will have the issue with the above bug.

Def not a power failure. I didnt try it this time, but I think I might have tried the airgap last time and it didnt fix it, but im not 100% sure.

Updating to the beta firmware seems like more of a headache then I am up to deal with right now but maybe later this week.

in my case, whenever there’s a power cycle or a blackout, the bulb loses power and I have to turn off the switch via ST app (which is shown as being ON btw) and turn it on again. when I do that, the bulb turns on (it shouldn’t since I got it set to retain its last status.

my setup: on-off red series (set to turn local control off) / ilumin RGB / smartthings

1 Like

@frcastellanos A couple things here. There switch not returning to its proper state is a bug that was fixed in a firmware update. I’m sorry SmartThings doesn’t allow OTA firmware updates, but they have mentioned the feature to be released in Q3 or Q4 of this year. If you want to update right now there are ways to do it, but you might have to exclude the switch and include it back into SmartThings.

As for the bulb issue, which device handler are you using? I want to make sure the preferences are programmed correctly as this shouldn’t be happening. If you change the necessary parameter to "Save bulb state (ON or OFF) the bulb should return to the off state if the bulb was off when the power was cut.

hi eric. thanks for your response.

  1. the process for updating the firmware for Z-wave devices is done by using this dongle you connect to the PC, right?

  2. the device handler I use for this bulb is the same one that I’m using with other 5 bulbs and they all work as intended, it’s just this one that’s giving me this glitch. I even tried changing the last state setting to be back on, then turned the bulb on, then off… and then changed it to retain its last status. still it turns on when the power’s back.

I even tried switching places with another and both acted like they did before: the one that’s working fine remained off when I turned on the switch, and the one turning on, kept turning on when I turned on the switch.

I realize this may be far little too late, but knowing what we know now with S0 and some hubs, I really do think the issues you’re facing are from S0 and network flooding.

If you still have the bulbs (or anyone else who reads this that may have similar issues), I’d highly recommend upgrading to the beta firmware 2.31 where you can include the bulbs as, “non-secure” instead of the default of S0.