From Inclusion to Death in 15 minutes

Hello, I’m trying to get my new LZW31-SN up and running in HA. It’s my first z-wave device, so I’m not sure what I’m doing.

I set up the Z-Wave integration in HA (not the OpenZWave (beta)).
I followed the guide here: https://community.home-assistant.io/t/guide-for-installing-inovelli-devices-in-home-assistant-ozwave-v1-4/172043

I think I have successfully included the new switch, I see a light entity and a couple of sensors in HA, and it seems to work correctly for a minute (I can control the physical light although it seems slow and buggy) and then the status of “zwave.inovelli_lzw31_sn_dimmer_red_series” changes to “dead” and that’s it.

Does “dead” mean dead, like “fried” or “bricked”?

I’ve excluded, the switch, done a factory reset, re-included the switch several times with essentially the same results. Sometimes the inclusion fails completely but when it works, it works for a minute or two and then dies.

Can anyone point me in the right direction? I’d be grateful.

My log is available here: https://pastebin.com/4cB6dV7h

Hey @steve2982 – sorry about the frustration and while I can’t help with HA as I’m not too familiar, it shouldn’t be long before someone here more knowledgeable with that platform can help.

However, let’s figure out the dead/fried/bricked situation. Does the switch work manually (ie: walk up to the wall and press the button)? It sounds like it does from your description of being able to control it (albeit slow and buggy) but I just want to make sure.

How far away from the hub are you? If you hold down on the switch for 5 seconds and let go after it turns yellow, does the bar turn green or red?

Hang in there, we’ll get it figured out!

@Eric_Inovelli thanks for the reply:

Yes, it works manually. I’m about 45 feet away from the hub, as the crow flies.

If I hold down the config button and let go after it turns yellow, it just slow blinks yellow for about thirty seconds and then stops. But I think that’s configuration mode.

If I hold down the config button it turns green after about 5 seconds, if I let go while it’s green, it stays green for a second and then goes out.

Thanks again.

Ah crap – you’re right. My bad – it’s been a long day!

Ok, well this is good news – it means it’s in Z-Wave range, so you should be good here.

From everything you describe, it sounds like the switch is acting properly from a manual side, so my guess would be something from the HA side was maybe configured incorrectly.

@jtronicus, @doublepedaldylan, @EricM_Inovelli you guys have any ideas from an HA side?

Great, thanks. I’ll see if anyone else has any ideas. Have a good weekend.

If you are trying an “add node secure” can you just try “add node” and see if that makes a difference?

I have tried both. Been using “add node”. Thanks.

A couple things I noticed:

  1. According to your logs, OpenZwave was not able to load the config file for the dimmer. This should not cause the issues you are experiencing though (it is just an observation)
    2020-06-05 16:30:11.539 Info, Node003, Unable to find or load Config Param file /config/ozwave/config/inovelli/lzw31-sn.xml
  2. What you are describing looks very similar to an issue I experienced a while ago and posted about here. By chance, did you mess around with the Protection settings for this device in HA?
  3. Normally when a device is factory reset or excluded/re-included, it would be assigned a new NodeID (Old Node IDs dont get reused until all 254 node IDs have been used). Since your switch is using NodeID 3, this leads me to believe that either the device did not exclude properly, or it did not successfully factory reset. You didnt try using the “Replace Failed Node” option, did you?

“Dead” just means that the hub is not able to communicate with the device. It could be due to a number of things, such as RF interference, lost power, or potentially if the RF protection status somehow got set (see bullet #2 above). Basically, after a certain number of failed attempts, the hub will mark the node as dead. If a node gets marked as Dead OZW will stop trying to send commands to it. A dead node will be “revived” if the hub receives some sort of communication from the Node, as it did here in your log:

2020-06-05 16:38:41.692 Detail,
2020-06-05 16:38:41.692 Error, Node003, WARNING: node revived
2020-06-05 16:38:41.692 Info, Node003, Received Central Scene set from node 3: scene id=1 in 7680 seconds. Sending event notification.
2020-06-05 16:38:41.692 Warning, Node003, No ValueID created for Scene 1
2020-06-05 16:38:41.692 Detail, Node003, Notification: Notification - Node Alive

Openzwave was created by reverse-engineering the zwave protocol. Unfortunately, this means that it doesnt always handle things perfectly. One of the issues OZW has is with dealing with dead nodes (some additional details on it can be found here). Since you mentioned this is your first zwave device, it might be worthwhile to exclude the switch, factory reset it, factory reset your zwave stick, and start fresh.

Thanks for the response:

According to your logs, OpenZwave was not able to load the config file for the dimmer.

Well, the files are definitely there. Maybe the character encoding or whatever got screwed up when I downloaded the files. I copied them to my HA by downloading on my mac into the samba-share folder for my HA config. I’ll have to see if that’s the problem.

By chance, did you mess around with the Protection settings for this device in HA?

I’m pretty sure I didn’t do that.

Since your switch is using NodeID 3, this leads me to believe that either the device did not exclude properly, or it did not successfully factory reset. You didnt try using the “Replace Failed Node” option, did you?

Well, it did change from 002 to 003, but yeah, I did try “Replace Failed Node”. It… sounded like something that might help.

Well, regardless of how well OZW handles dead nodes, I’d like to figure out why it’s going dead in the first place.

Unfortunately, my wave stick is also my zigbee stick which is heavily used, so I’m not inclined to factory-reset that.

Thanks.