Help with logic of associations and scenes

This is more of an intended use-case with supporting questions…

I have a powder room where I just installed a Red-series Gen2 (on/off) switch, a 4-in-1 sensor and 3, Illumin RGB bulbs. All using the appropriate, and latest, Inovelli drivers - not Hubitats.

I thought I could turn off local control on the switch and using the association tool, set the association up in the motion detector to control the lights directly, but I believe I am missing something. I also wanted to use the scene control of the switch to change between warm and daylight white levels. That’s the use case of what I am trying to configure.

Here are the questions/ observations:

  1. Turn off local control of the parent, not child - confirmed that the switch does nothing - good.
  2. Install the Association Tool (both parts), setup new association using the 4-in-1 as the source, and selectiong the three bulbs.

2.a. Interestingly, the 4-in-1 does not appear if you select Motion Sensor, only if you select Sensor… by design?

  1. Set association to group to 2
    3.a. Set the “Send on to group 2” setting on 4N1 to yes.
  2. Woke up sensor, no changes pending, nothing happens when you walk into the room (other than the motion sensor LED flashes)

–Obviously doing something wrong already–

Should this not work like the way I envision it?

Do I need to set the association up between the switch and the bulbs, then the 4N1 and the switch? This does not make sense to me because if the switch is off for local control, what is the motion->switch association doing?

Beyond that, I was playing with the bulb colors in the individual bulbs and cannot figure out how to turn them back to white. I can select any other color but white is a bit elusive.

Also, once that is working, can the actual scenes be setup in Hubitat (button press on 1 for soft white), 2x for bright white, etc. then use the off button for dimming of each scene, or do I need to do that at the configuration switch of the switch?

A process flow would be great, but at least an overview (100’ view), of the preferred logic flow would help tremendously.

Hope this all makes sense, and thanks in advance!

@cfpsystems - What if you used Rule machine to setup something like this:

If Daytime and motion detected, turn on RGBW bulbs with daylight color; turn off 2 min after no motion
If Nighttime and motion detected, turn on RGBW bulbs with Bright White; turn off 2 min after no motion.

I wouldn’t use the association tool for what you’re trying to do, but doesn’t mean that is a wrong way to run it.

Buttons will need to be setup in Rule machine too if you want to run up (pushed) 1x turn on lights for soft white, up 2x for bright white, 3x for daylight etc…

If this doesn’t answer what you’re looking for, please ask your questions again. I may have read through it too quickly.

Thanks @harjms for the reply.

I guess in my mind I was thinking that the direct association would be faster response time, but are you saying that rule machine is just as fast?

The setup I am replacing was a Fibaro eye-ball that was using rule machine with some time settings in it to turn the light on. Problem was that you could get up to 15 seconds of dark before the light would kick on - then it would mostly turn off when expected.

I do like your if statement, and did not comprehend that I need to setup those multi-tap scenes in RM as well.

So, based on what I understand you to have understood :wink:

• I am still disabling the local control so that I can have the scenes work?
• I am setting up the control from the motion detector to the bulbs (not the switch)?
• The switch is just providing the power and scenes to the bulbs - nothing else is technically associated with it?
• How do I get my lights back to white? Looks like a dark room in there now.
• Is there a way to factory reset the bulbs back to how they shipped?


@cfpsystems - I don’t have any local controls disabled. I just use multi taps for certain things. E.g. double tap up tub light turns on stall shower light and both bathroom fans. Double down turns off all lights and fans in Master Bath. I believe scenes are still registered when local control is disabled. Not sure :man_shrugging:t2:

I use this rule to turn on porch lights when motion near the front door. We use it only during a period of time 12am - 6 am for when we take dogs out overnight. Probably takes 2steps before the lights come on so probably 2-3 seconds from entering FOV. I’m using aeotec tri sensor (installed before Inovelli motion came out).

Something like that but using if else statements should make it work how you describe. No association involved, just rule machine.

You can try to exclude bulbs from Hubitat and may reset to factory, or I believe turn on, off 6x will factory reset it.

For White I use the color temperature.


I am taking a step back in thinking that I am trying to configure too many moving parts at once. So, all I am trying to do now is to get the switch (using the LZW30-SN driver), to be a scene controller for the 3 Illumin RGB bulbs connected to it using @EricM_Inovelli article here: [HOW-TO] Hubitat: Setting Up "Scenes" in Rule Machine

Steps taken:

  1. Confirmed with 100% certainty that the bulbs work (on/ off) with local control.
  2. Created a RuleMachine rule
  3. Disabled local control to the switch (understood that this is needed so the bulbs have power at all times).
  4. Nothing happens with the button presses. Well, almost nothing. Holding down button 1-press caused the lights to dim (not as a group, but one at a time and now they won’t turn back on).

So this is where I am. I am about to do a repair on the network again to see if that helps. Once I can get this figured out then I can consider incorporating the motion detector.

Any help is greatly appreciated!

OK, in another post I was corrected by @EricM_Inovelli that in order for this to work, I need to use the association tool to associate the bulbs to the switch (scene controller).
I have done this and can now go back and try the rules again - I kept monky-ing with it and probably destroyed the logic.
Onward and upward!

So I did my button pushes differently. Here’s my bathroom one. Name is outdated since I added the bathroom fans.

1 Like

So you can use just the scenes to accomplish what you are trying to do and don’t have to use associations. Since you are working with a switch using scenes is probably just as good as associations. The real benefit with associations would be dimming from a dimmer (LZW31-SN). Since you already have it setup though, probably try to get it to work as is. Use the association for ON / OFF and scenes for the other features.

1 Like

Thanks @EricM_Inovelli.

I have gone back to a factory reset on everyting relating to this one room as I was no longer sure if I had any overlapping things taking place - figured it was best to start from scratch and get it right.

That said, what I want to accomplish is as follows (along with my guess as to how it should work?):

  1. I want all three smart bulbs to work together as one (it seemed to me that my first attempt yielded bulbs working no in sync, especially if dimmed)

1.b: Am I associating the switch to the bulbs and turning off local control?

  1. Ultimately, I want the 4N1 sensor to turn the lights on to a setting (see #3 below for scene #1 (1x press)), whenever someone walks into the bathroom (I have not tackled this yet because I don’t know if the 4N1 is supposed to turn on the switch (then off in x minutes unless it detects more motion then reset the counter), or is it supposed to talk directly to the bulbs and skip the switch (because it has local control turned off)?

  2. I would like one press to turn on soft white at 100%, 2x daylight at 100%, 3x something else like blue at 50%, and 1x held (down), would turn any of them off.

Based on your other post on the other thread, I should setup 8x button held down up and down for dim/ bright.

And if anyone just goes in and hits the switch (based on #3), the lights would just work sans motion sensor.

I hope this makes sense because the next two applications are very similar just with a dimmer and not a switch.

Also, if this room is better served by a dimmer, I can change it.
Thanks Eric!

I would say that if you want to dim up/down the bulbs in the traditional sense of holding down the buttons then you are better off using the Inovelli dimmer and doing direct association. In this case you wouldn’t setup button 6 & 8 to do any dimming.

Any automation control that you will be doing in Hubitat is going to be directed at the bulbs. Like the motion sensor should control the bulbs through Hubitat and not control the switch. The switch is going to stay on at all times and send commands to the hub (scene) and associated devices.

Since you want a single press to turn the bulbs soft white at 100% I would set that up as a scene in Hubitat and only setup Group 4 association between the dimmer and the bulbs.

So, in summary:

  • Use an LZW31-SN red series dimmer.
  • Set at 99% brightness & local control disabled.
  • Use the association tool to setup an association for group 4 from the dimmer to the three bulbs.
  • Use the Rule machine guide in the forums to setup scenes based on your desired effects.
    For example, “button 1 pressed” will set the 3 bulbs to soft white 100%
    “button 1 held” will turn off the 3 bulbs
  • Use Rule Machine to create a rule that when the motion sensor is active to turn the bulbs on soft white 100%. Set the rule to turn off the bulbs when motion is not active but delay the action by x minutes (how long you want them to stay on after motion stops). Set the action as cancel-able so that when motion is triggered again it will reset the timer.

Hi @EricM_Inovelli,

I believe I followed everything accordingly, and even dropped off the motion part of what I want to accomplish because I cannot get the lights to respond with any decency using the dimmer as a scene controller alone.

I set the Dimmer (replaced the switch), with the LZW31-SN, to local control off. I can see that the level is set to 99, so I figured that part was OK.

I did notice that Hubitat created a child device called the same thing but added (Disable Local Control), as a generic-type device. I toyed with changing this driver to be the user-defined Inovelli driver but this did not make a difference with lighting, so deleted and re-created it to “put it back”.

I created the association between the switch and the three bulbs as instructed. There is no issue of making this backward as the source is a radio button and not a checkmark, so I presume this is correct?

Last step was Rule Machine for scenes. I chose button device and setup as I did before (started with a clean copy), and thought I was home-free. Alas, that is not the case.

The bulbs have a mind of their own. They turn on whenever they want to. A single #1 pressed may have bulb #3, then #2, then #1 light up, all with a 3-5 second pause in between. A single #1 held will eventually get the lights to turn off, but again, at their own will and timeframe.

Sometimes they all light up, sometimes only one, sometimes two, and if left long enough, they eventually catch up to each other.

By the way, does each corresponding held need to be defined as an off, or will button #1 held, turn off any of the scenes?

The in-range display on the switch shows all green, I can talk to the switch as I changed the light bar to cyan, and the bulbs and the 4N1 all connected to Hubitat immediately when I went to add them; therefore, I do not believe it is a range thing.

Any other ideas as to what I should be looking at? I am pretty deep into Inovelli now and this is a scenario that I need to repeat multiple times once I figure it out.

Any help is greatly appreciated Eric. Thanks,

I removed buttons #6 and 8 from the button devices under rule machine

@EricM_Inovelli, Can you or someone please tell me:

  1. Is it best to disable local control from the switch (8x config button), or the Hubitat interface. The former does not create a child switch, the latter does.

  2. The child switch is of driver (generic), and Inovelli - OK to leave that way or should it be changed? This depends on #1

  3. When building the association, if the association is to the physical switch or the child switch, and is the LOGIC written to the physical or child?

  4. Above post pretty much sums everything up and it does not work.


  1. I think you are choosing to create a child device for enabling / disabling local control. The child device is so you can control the local protection from other Apps. I know it is kind of confusing. It doesn’t really matter which way you do it in Hubitat. Either one works.

  2. Doesn’t sound like you will be using the child device.

  3. The association should be created to the parent device (not the child).

Can you check everything with the items configured above. I wonder if local control wasn’t disabled during your testing. That could cause problems. Let me know. :slight_smile:

@EricM_Inovelli - Thanks for this. It did not appear to make any difference at all. To assure that I didn’t miss anything, I deleted everything to start again in hopes that something was not configuring properly.

I can say with 100% certainty, that if I manually control the three bulbs (on/ off), the respond instantly - this comes into play later.

The association is setup exactly like my screen shot from the other day - is this correct?

Rule Machine is setup exactly as the screenshot from the other day - good?

The switch: I mimicked your settings from the screen shot with no change. By the way, thank you for the clarification of the child devices - I agree, not what I was shooting for.

I then went to the switch, turned it on full brightness, and did the 8x config to make is a scene controller.

I then did a zwave repair, to make sure everything was accounted for - just in case - and it still does not work.

The button clicks are registering in the switch control panel just fine (and near instantly). The bulbs appear to have a mind of their own. They may work, they may not. the first and third may turn on white, the middle one blue. It is very frustrating. Independently, everything responds at break-neck speed so I presume that something is not properly configured, but what?

Should I create a group for the three lights so they all get the same commands at once?

Is there something wrong with how I defined the buttons or association?

I am out of ideas and really appreciate your continue help with this.

PS: Not sure if these bits from the switch help or not: