[HOW-TO] Hubitat: Setting Up "Scenes" in Rule Machine

@arcxk - just for confirmation, you’re using Inovelli’s driver correct?


Do you have logging on for the switch? We can look at real time logs to see if it’s receiving all 6 buttons pressed, just to see if it’s not missing something.

Yes, I am getting both “Button 6 pushed” and “Button 6 held” events in the logs

Weird…especially if it’s working on the other switches. So 6 button is actually a hold button for 3 secs correct? The fact that the logs are seeing it, points me more into the Rule Machine issue than a switch issue if it’s seeing the logs…

That seems to be the case. I created a new automation for that switch and button 6 pushed event functions normally, guess I’m recreating all the others. Thanks for the help!

edit: update, copying my current rule also presents the same issue in the copied rule. Definitely a rule machine issue.

@arcxk - Somewhat easy fix… At least you ruled it down to a RM issue.

Hi everyone. Totally newbie to home automation stuff. I bought one of the holiday packs and i wish i had about 5 more! Anyways I have all the switches and bulbs hooked up and working great. I was going to setup some scenes using the multi-tap features of the red series switch but I noticed in the device commands section of hubitat for the switches i dont see the “press down x1, press up x1,…” commands.

Do these need to be their to setup the multitap scene control in rule machine? Ive loaded the most recent driver for the lzw-31-sn switch and the child dimmer driver as well.

Thanks for the help! Cant wait for my other switches and bulbs to get here.

You should check out Button Controller and/or Button Devices for scene control.

1 Like

Got it, worked great. Now I just need my 10 pack of dimmers to show up!


I believe button 6 and button 8 are reversed in this description (at least, for LZW30-SN)… Button 6 is released while button 8 is held, cmd.keyattributes is 1 for released and 2 for held. Maybe the issue is with the latest driver though.

@EricM_Inovelli just wanted to confirm that buttons 6 and 8 are switched in your HE driver. Held up should be button 6 pushed for the on/off but it’s currently button 8 pushed (for physical control).

A digital held up is actually button 6 pushed so digital is correct while physical is wrong.

I haven’t checked the dimmer so not sure if it has the same issue.


Yes, you are correct. They were listed incorrectly in the post. I have just updated it.

Only issue is in the driver, a digital “up” held is actually button 6… So the physical “up” held and digital “up” held would result in different button events

def holdUp() {
sendEvent(buttonEvent(6, “pushed”))

def holdDown() {
sendEvent(buttonEvent(6, “held”))

@EricM_Inovelli please see the post above

I haven’t been keeping up on those custom methods since they are commented out and not very many use them. Any way you can submit a PR for them?


Late to the party here, but did you ever figure out what was causing your delay when doing a scene? Im in the same boat you are/were except I am using Home Assistant. See thread: Frustration level 100! Scene commanding 5 red dimmers can take over 20+ seconds to complete

I’ve tried to rule out everything. The only things I havent ruled out yet are the dimmers themselves, as they are currently the only Z wave light switches I have. But as of Saturday, I will have a couple {gasp} non-inovelli switches that I will be testing the scene on (sorry Inovelli, but I have to rule out the switches) ((I really really REALLY hope its not the switches themselves as I have spent over 1k on 30 switches in the past 2 months))

Hi, is the advice here still current with RM 5.1? I have Red Dimmers, and am using the Inovelli Driver in Hubitat (and have hit Save Preferences a ton of times). In RM, I don’t see the “prefill all” option, and I don’t see “Button Device” in the trigger dropdown. Choosing “Button” in the trigger dropdown seems to work, but I have to specify the button number and the action (Pressed or Held, I ignore doubleTap and Released). Again, I can get scenes to work, but not the way it’s specified in the first post here. What am I doing wrong?

EDIT: updated some of the “Device Button” terminology above, for accuracy

No, Rule 5.0 removed “Button Device” and the functionality has been substantially replaced with a revamped Button Controller app. That’s where I’d recommend starting nowadays, but the flow is still pretty similar.

1 Like

@budmannxx you could try Button Controller from the app page.