Hubitat- Binding 2 Blue Switches

Trying to bind 2 blues in hubitat. I’ve imported the binding Ap and have been fine doing smart light to switch.

Now I’m on two switches and Im not sure what I’m missing. I’ve checked the endpoint on both which is “01”.

One switch is dead to power unless the other is on. If the other is on then the slave can turn the lights on and off and dim as usual, but it’s not updating on the primary.

I’m clearly missing something, help!

1 Like

To start, it sounds like you’re not wired correctly on the second switch. When you bind two switches, the secondary switch should have a constant hot and neutral so that the switch is powered full-time. Your statement about one switch being dead part of the time suggests that you have not wired that secondary switch properly.

3 Likes

I switched the load and line in every possible combination on both switches. I’m failing somewhere. The second switch won’t operate until the first is on.

And even when both are on. I would think the binding would still be in place. But neither switch is communicating with the other.

Firstly, don’t arbitrarily start trying wires in different combinations. You can damage the switches, and frankly, it’s a dangerous practice. Line and Load should be identified using a meter. If you are that unfamiliar that you can’t identify which conductor is your line, you should probably call an electrician.

I don’t think you understood what I posted earlier. You said that you moved Line and Load around on BOTH switches. Only one of them should have the load, and the other should ONLY have a hot and a neutral.

You posted that you don’t understand why you couldn’t get binding going when both switches were powered. If you have extra conductors attached to a switch, that is going to affect it, more than likely.

When you are using two smart switches, they should be wired in one of the two following configurations. Note how there are no conductors attached to the Traveler and Load terminals of the secondary switch.

Once you get the wiring correct then someone here can help you with the binding. But at the present, everything you’ve described suggests incorrect wiring.

3 Likes

Got it. I’ve pulled them off. I’m going to put the multimeter to everything to get it sorted. Thank you for your help.

The other thing I noticed is this has the travelers capped. I had those lined into the switch. Any reason to cap them over putting them into the traveler screw ?

2 Likes

Everyone likes knowing they were right. You were 100% correct. My frustrations lead me to the screwing around with wires recklessly which is a stupid thing to do.

Anyway. I wanted to thank you for your help and insight.

Now to the binding lets see if i can get that resolved now its wired correctly.

Glad you got it going!

I’m not your binding guy.

@harjms or @hydro311 or someone?

I haven’t bound two switches together, but as I understand it, the key thing is to bind both ways - bind switch A to B, and then bind B to A.

You cap the travelers since the 3 way is performed via RF vice traveler leg. Do not wire the traveler to each other. Cap it.

1 Like

Not sure if you made it past this, but as others have mentioned, traveller wires are NOT used in a dual smart 3-way. The switches communicate wirelessly. So you are basically using the second blue as a wireless powered remote, that only needs LINE and NEUTRAL installed. Hopefully that clarifies. You should NOT install traveller in this arrangement. Cap both ends.

2 Likes

Others are correct. You bind A>B and B>A, so they talk to each other. Not sure if Hubitat exposes EP’s or not, but EP1 is the receiver and EP2 is the remote/controller endpoint, so you want to bind EP2 to EP1 each way.

So I bound in both directions. I followed the same instructions as binding to a smart bulb where i went into the device info and got the endpoint two digit number.

Issue being both switches have an endpoint of 01 in the device info.

I have set the binding up in both directions. And tried the following endpoint setups

S=switch and 01 or 02 being the endpoint

(S1)01>(s2)01 + reverse bind (s2)01>(s1)01
(S1)01>(s2)01 + reverse bind(s2)01>(s1)02
(S1)01>(s2)02 + reverse bind(s2)01>(s1)02
(S1)01>(s2)02 + reverse bind (s2)01>(s1)01

No dice, they’re still not communicating.

Any help or insight on this step welcome!

Hang tight, I’m actually writing these instructions right now – In the trenches with you my friend.

Edit: Ok, got it to work in the office, I’ll give the quick instructions.

Switch A - Inovelli #1
Switch B - Inovelli #2
Bulb 1 - Hue

Binding #1 = Switch A (EP02) > Switch B (EP01)
Binding #2 = Switch B (EP02) > Switch A (EP01)
Binding #3 = Switch A (EP02) > Bulb 1 (EP0B)
Binding #4 = Switch B (EP02) > Bulb 1 (EP0B)

What you might need to do is delete all the bindings, remove the switches and start over with fresh bindings.

Sometimes there’s “ghost” bindings that are still there if they were done wrong by accident and it can screw things up.

If you don’t want to remove your switches, then if you remember what you tried, do it again, but this time select, “Unbind”:

Thanks Eric! I’ll give it a go tonight and let you know. Really appreciate it.

Ok So an update.

I don’t have the hue Bulbs in my kitchen yet (not all the cans, i have some single pole series of 4 cans which i’ve had great success binding).

I couldn’t get the multi-switch to pair. I pulled the switches off and reset and then started from the beginning. I ran your sequence but it fought me, but here is where I ended up with the two communicating perfectly and mirroring dim, on/off etc…

Binding #1 = Switch A (EP02) > Switch B (EP01)
Binding #2 = Switch B (EP02) > Switch A (EP01)

So the endpoints stayed the same in both scenarios, the primary and slave were the only swap between the two bindings.

Once I get the cans in (next week), I’ll get it all added in and I’ll update you on how it all works.

This community is amazing, thank you to everyone for the advice and help.

Shoot, you’re right, glad you figured it out bc I made a typo!

Nice job :slight_smile:

Edit: I’ve edited my post in case someone else reads it.

Ok New issue.

So the switches are paired and going great. I’ve then used the binding method for 8 hue cans in my kitchen.

Issues I’m currently facing. One Hue can just won’t bind for some reason. I’ve reset the can, reset the switches, redone the bindings. Even changed out with a new can. It’ll respond from the Hubitat app, but not the switches.

Secondly (besides the one problem child noted above), the other 7 cans don’t all respond to the switch. Sometimes they’ll all come on. Sometimes 5. Sometimes a different 6. If I click on another couple times I can usually get the missing ones to turn on or off, depending which way I’m trying to get it all to go.

Any thoughts on the inconsistency?

I think this may be a Zigbee network issue or a switch firmware issue. I have 3 Blue series switches bonded to each other w/group binding. Sometimes 1 switch does not report correct dim level or correct light on/off status. Randomly works, randomly doesn’t. It does seem that it’s probably a switch firmware problem or a Zigbee network problem. The rest of my network is working fine so I’d probably start looking into switch firmware, but I could be wrong.

1 Like

So an update to binding 8 bulbs to two blues. One hue I just can’t get to bind. I’ve even put a newer can in that slot and it is fighting. I reset the blues and readded everything. Who knows. I’ll get it eventually.

The bigger issue is inconsistency after binding. I’ll add a youtube link here to show what I’m talking about. The can directly above my head is the one that won’t cooperate. The one over the kitchen sink is on a separate switch and should/does remain off through the video.

This is just one of several videos. but the bulbs that choose to function, set incorrect brightness, or fail to turn off without multiple commands is inconsistent as I believe they’ve all had turns. Sometimes it’s just one, sometimes it’s 4.


I may have missed it in the comments, but what firmware version are you running on your switch?