Ilumin bulb association with red series dimmer

Supposedly we can associate the dimmer and bulb locally. I have smartthings and have both paired with the hub, but how do I associate them with each other?

You’ll need the association tool. It can be found here.

I should have asked what hub you are using.

Also create association group 2 and 4 the same, with the switch as the main item and the bulbs as the controlled items. I actually setup this up earlier today myself. Let me know if you need more detailed directions I’m happy to help.

SmartThings (that was in my OP)

Yikes. Well I’m out. Goodnight everyone!

Hmm, when I add smartapps/z-waveat/zwave-association-tool.src/zwave-association-tool.groovy, I get an error:

Updated 0 and created 0 SmartApps, 0 published (1 skipped due to errors)

If I try to add smartapps/z-waveat/zwave-association.src/zwave-association.groovy, I get this error:

Oh No! Something Went Wrong!
Error 500: Internal Server Error
URI /ide/app/doRepoUpdates
Reference Id 45c82c97-e71c-4973-bb9c-bb2fe28cc86c
Date Sat Dec 28 02:59:08 UTC 2019

If I try adding both, I get the same error as the second one. Any idea what might be going on trying to add the smartapps?

Hmm, looks like I could add it from here?

paging @EricM_Inovelli

Thanks. Yeah, I was able to add the smartapps from erocm123 repository, but I only had errors when trying to add an association. Instead, I went ahead and removed all traces of the erocm123 repository from my SmartThings device types and smartapps, just in case it was conflicting. But after doing that, I still get the errors when trying to install the smartapps.

I grabbed both apps from Nathan’s link earlier. https://github.com/InovelliUSA/SmartThingsInovelli/tree/master/smartapps/z-waveat. Possibly a copy paste error, easy to do on GitHub. Try clicking “Raw” in the upper left corner and copying from there for each file. You definitely need both apps, I think the order you add them matters. Only one needs published but I can’t remember which so I did both.

I was able to add them directly from code, but not from the github repo. Not sure why.

I was able to create the association group, but it doesn’t seem to have done anything.

When I look in the UI for the association app it created, here’s what I see:

Room Ceiling Light Association Group 1

SmartApp: Z-Wave Association Owner: user_uuid:033da883-337b-c494-7cc1-853149e3f677

Name Type Value
dCapability enum Switch
dSwitch capability.switch Room Lamp
groupNumber enum 1
overrideLabel bool false
sCapability enum Switch
sSwitch capability.switch Room Ceiling Light

previousNodes [41]

The Room Ceiling Light (sSwitch) device driver is:

  • Inovelli Dimmer NZW31 w/Scene

The Room Lamp (dSwitch) device driver is:

  • Inovelli Bulb Multi-Color

Should this work with the NZW31? Or do I need to use the LZW31?

Not sure if this will work for the NZW31 as I’m using with the LZW31. It looks like you assigned the association to group 1. You will need to create the association twice, assign it to group 2 the first time and group 4 the second time. You will also have to delete the association for group 1 as I think I read it creates conflicts

1 was the only option when I created it.

I found this in the device driver for the NZW31:

  • 2018-02-26: Added support for Z-Wave Association Tool SmartApp. Associations require firmware 1.02+.

But my device shows:

firmware: 1.01

IIUC, I think only zigbee devices will update firmware OTA on smartthings, not z-wave. And I don’t have a z-stick to update myself. I think I’ll probably have to swap that switch out then with a LZW31.

Well that’s a bummer. The first LZW31 association has worked with the bulbs for the first 24 hours. Although I tried to duplicate it in another room last night and that has not worked smoothly. I’m still trouble shooting it.

My zwave association errors out from GitHub but installs with copy/paste from raw code but then when I go to add an association it gives me another error:

Any thoughts? I will start with the logs but is there a DTH I am missing?

There are two smart apps, you added both right?

I had not, thanks for the pointer! Works perfectly now (minus being able to install from GitHub repo).

Can someone explain to me what Association Groups are specifically? I see that 1 is for lifeline on z-wave plus battery devices, but I don’t understand 2 through 4, are these just slots for me to use on a per-driver basis or is this something like 2 is on/off and 4 is dim status???

TIA, learning as I go and have 12 more switches in boxes ready to install!

Awesome, glad to hear it works. I did the same thing and got the same error myself. Others have mentioned not being able to install from the repo and I’m wondering if that is because Inovelli is using a private repo and as such have certain permissions locked.

Don’t quote me on this but I thought I read association 2 is for on/off state and association 4 is for dimming level. I too would love to know the defined association meanings for each group.

2 Likes

I’d be curious as well. I’m on Hubitat and I’ve tried 2 and 4 from a red dimmer with a load to ilumin bulbs. The bulbs will turn off when turning off the dimmer, but they won’t turn on. I can push and hold up and down and the bulbs will step dim up and down. But I can’t get the bulbs to turn on when pressing up on the dimmer.

Any thoughts/suggestions?

I’m trying to setup the association as well on SmartThings and not having much luck yet. I had installed the LZW31-SN a couple of weeks back, and that went smoothly. I originally had it paired with 3 Sengled RGBW bulbs in a ceiling fan but didn’t like the fact that I couldn’t actually dim the bulbs from the dimmer. I returned those and picked up the Ilumin RGBW bulbs. Those paired easily (except for one, that’s a separate issue) and I installed the device handler. The dimmer is setup with Local Control disabled.
I installed both of the Zwave Association smart apps, and wound up publishing both since the directions weren’t clear on that. When creating the association for Group 4, I got a message that said “Child device creation failed. Make sure the device handler for ‘Switch Level Child Device’ is installed.” The association ended up being created but not functioning properly. The bulbs occasionally turn on/off quickly, but most times there’s a few second delay for the first to turn on, then another 2-3 seconds for the second bulb, and 2-3 more seconds for the third bulb. Holding down from the switch to dim works sometimes but with a huge delay of 5-7 seconds. Holding up to increase the brightness doesn’t work at all. I was thrilled when I first found out about the Red Series dimmers and Illumin bulbs working through the zwave association, but actual results have fallen short so far. Hoping it’s something simple.

Anyone know what that error is about referring to the switch level child device? I would try uninstalling the smart apps, device handlers and devices to try again if any one can offer some guidance on the correct sequence.
Thank you!