Inovelli Blue 2-1 switch losing triggers in HA when zigbee is rebooted

Hello Team,
Setting up the Blue switches is pretty easy - I ensure that I press the button combinations (such as “double up”) so that the trigger is an option in HA automations.

When Zigbee is rebooted in HA, these triggers are gone and unrecognized/undefined in HA automations. The only way I konw of to get them back, is to removed the Blue from HA’s Z2M, and re-add the device. This is not a great long term option and takes time.

Has anyone run across this? If so, what do you do to help eliminate this extra work?

Thanks in advance,


I don’t use Z2M personally so can’t speak too much to it, but I’d recommend either using rohan’s blueprint or manually specifying the triggers should work as shown here.

1 Like

Thanks for the heads up chack, I played around with a few blueprint automatons,… .this might work. Thanks for your reply.

1 Like

I was having this issue for many of my devices using Z2M. I was running the official MQTT addon repository and after a little research, looks like MQTT was the culprit, at least for me. I came across this reddit post for others having issues with buttons. I switched to EMQX based on that discussion and I haven’t had an issue since. Wasn’t very difficult to switch over, took about 30 minutes. I wasn’t familiar with EMQX, but leveraged a Mostly Chris tutorial and it went smoothly. I also like the built in GUI that can help with problem solving and gives more control over the broker.

Thank you for sharing. I will definitely look at this.

I’m having an issue with this as well. This is what my automation looks like now…

use this URL as your blueprint source. This blueprint has solved many of these issues…

1 Like

I just tried the blueprint and the config button didn’t do anything!

Hmmm. This blueprint allowed me to control lights, etc. when a automation trigger would not display the Inovelli Blue action in HA such as “single up” ,etc.

I am curious about this… such as, what is causing the Inovelli to lose these triggers? 1) Z2M 2) HA 3) Inovelli FW, 4) a combination of things?

Why I ask is that in the last 6-8 months, Zigbee has not gotten better for me. Besides working around this issue, I have to restart the Z2M bridge after HA core updates, etc. Thoughts?

That’s interesting, I’ve encountered the same problem whereas previously I did not have this issue (rebooting TubeZB to see devices). Also no longer picking up button presses on some of my devices. I may try out EMQX and see if its the mqtt broker