[zigbee2mqtt] Blue Series 2-1 missing action sensor in Home-Assistant

I finally received and installed my blue series over the weekend and things are running smoothly. It is now time to configure some automations based on taps.

However, I am missing the the tap actions (down_single, etc) in Home-Assistant from zigbee2mqtt. I see the topic and value under zigbee2mqtt in MQTT but there seems to be missing the required home-assistant discovery topic to have it displayed in Home-Assistant.

I already opened an issue here but I am wondering if I am the only one with this issue.

1 Like

Are you talking about these? They work fine for me with Z2M ( bathroom fan switch is a blue 2-1). If I remember correctly, I had to send them once from the switch before they showed up in HA.

Yes, I assume it’s what it would look like in HA. I do have the information in z2m :
but it just does not make it to Home-Assistant.

1 Like

I also do not have the action entity. There’s a blueprint out there that requires it. This is something commonly seen on Ikea buttons, and from what I gather from the blueprint thread there are some that are getting this with the 2-1 as well.

That said, as mentioned above, just select device as trigger and the actions show up under the triggers section. Add one for every scene you want to trigger, edit the ID, then under actions use Choose and “triggered by” and put your action. It’s just as easy as a blueprint.

1 Like

Interesting! I did not know it was available as a device trigger, I was under the impression I needed the action sensor for this.

I might end up creating a new blueprint for this way of doing things. Thanks!


If you do make sure and share because Inovelli is throwing these on their own GH for use by others!


I’m having the same issue. No actions show in the trigger section for the blue switch. I get nothing in events when I push the config button either, Tried reconfigure, resetting. This is on two different switches. Button delay is set to 300ms

Have you tried going in and setting up an automation like above? Do you see any triggers there in the drop down after selecting the device as the trigger for the automation?

1 Like

No button based actions show. It’s just a bunch of mode change which aren’t very helpful. I’m running 2.08 firmware on the switches. Home assistant is on the latest version. Using Zigbeetomqtt.

Interesting. There is another thread on here somewhere where someone else had this issue. It was something with Z2M not sending the events. They ended up running through all of the possible actions. Single click up, double click up, triple click up, etc… After cycling through them all they appeared in HA. Bit of a pain but should only take a couple minutes to do. Maybe give that one a try?

When I first started working with the blues I was using Node Red. I installed the zigbee2mqtt pallet, connected to the z2m server and ran that into a debug node. Everything z2m was sending out got dumped into that debug node. This would let you check if z2m is sending it and HA is just not picking it up.

I followed that thread as well. No luck with that sequence. If i look at the debug logs it doesn’t even show the config button being pressed.

Did you eend up figuring it out? I’m having the same issue.

Also running into this problem as of this week. The actions showed up yesterday for some reason, but now they’re gone again. Curious if anyone has any other ideas. I’ve tried restarting things, checking for updates, a reset, etc. to no avail.

Make sure that your tap delay is set to a delay that you are comfortable with making. If it is set to zero the multi taps won’t work.

I don’t run Z2M in my setup but have dev’ed against it and If you are looking for an action entity, I think you have to turn on legacy_triggers for Z2M for it to discover the action sensor. See here: Home Assistant integration | Zigbee2MQTT

You can try running my blueprint and see if that works. It doesn’t depend on the device actions.

Thanks, @rohan, that blueprint did the trick! Exactly what I needed.

1 Like

A post was split to a new topic: LZW31-SN Multi Tap Not Working