Inovelli Dimmer Red Series LZW31-SN - Smartthings - Scene not working - up and down button not working

Hi all, yesterday I installed my first Inovelli Dimmer Red Series LZW31-SN. first, I don’t have any programming capacity. Also, I’m located in Canada, Quebec, so my smartthings app is in french.

On the app, I can select the up button or down button to trigger some automation. however, it doesn’t trigger. Also, when I go on the device history on the smartthings page, I can only see the switch history but I don’t have any history event if I pressed up-down several times…It’s like if nothing was sent when up or down button is pressed… I also tried to set the “smart Bulb mode” to smart mulb… Which actually seems to desable the switch to avoid any unwanted OFF state I guess…


Note that I don’t have the pressed and Held feature that are shown in the documentation… Maybe it’s translation…

Accessed from “list Events” seen on previous image

Up Button details

Event log from of the Up Button detail page.

What am I missing?



@Bry -ST hub, you’re up.

@EricM_Inovelli - I feel like this is similar to that ticket we got that you solved. If you see this before I get to a computer to look it up, can you help?

Edit: @Matracer - I think this is the thread that solved the ticket. Does this help at all?

1 Like

@Eric_Inovelli Yep, this is the same issue as in the thread you are thinking of. The OP in that thread marked it as solved, but we never did comprehend the behavior.

The issue seems to stem from the menus produced by Smartthings that the OP (or OPs in this case) look different from what SmartThings should be producing. Buttons for SmartThings are only exposed to button managers; they aren’t exposed to Routines. It is strange to see them as in the menu @Matracer posted with button choices, in which I’m guessing is the Routine wizard.

I spoke with @EricM_Inovelli regarding this. He agreed the menus did not look correct. It is possible that this is a result of the beta Edge drivers having been loaded, or as a result of the user having enrolled in a SmartThings beta program.

@Matracer Have you loaded at any point the Inovelli beta edge drivers or are you in a SmartThings beta program?

If you are creating a Routine with SmartThings, this is what the menu SHOULD look like. Note that buttons aren’t exposed:


@Matracer I would try using a button manager such as the one native to SmartThings or the ABC one. Don’t try to set the scene from a Routine.

@Eric_Inovelli Yes! that’s it! Thanks a lot!

Now I guess that my problem is the bulb themselve… they are Globe Wifi and they seem to have a hard time getting it right… I trigger green color for two lights and 1 ou of 2 times one of the two bulbs does switch… but this is not related to the switch!

Thanks again, great product and support!

1 Like


I haven’t set up any edge anything… I don’t really know anything about it haha. I found the right “button” or trigger in the smartlighting smartapp.

Yo uare refering to the native button manager. How to I get to this?


There used to be a button manager built into ST but I can’t find it. I presently use the ABC Manager.

I corrected my post above. You can also use SmartLighting, which you’ve found. I would try to set the scene triggers there. This article discusses it further:


Yeah, that’s what I found out! thanks!

as mentioned up here, I recently installed Globe Electric recessed slim RGBW light in my basement. They are wifi. My goal in installing Inovelli Gen 2 Red Series Dimmer is to trigger light color. It works, but 1 out of 2 times, one of the two lights doesn’t change color. I set it so two light should change color at the same time, but only one follows… (or it blinks and go back to the original color)

Is there any possible fix or it is only related to bad Globe Electric management on their side? do you have any clues on that? I would prefer to use Zigbee or Z-wave light that directly integrate to ST but haven’t found any…

@Eric_Inovelli Do you intend to get out on the market RGBW slim recessed light?



So we have to pinpoint where that’s coming from. I am guessing that you have a scene that changes the colors of the 2 bulbs? What happens if you run the scene independent from the Inovelli? Go to the Automations tab. In the Scenes section, press the arrow on the right side of the scene button. That will run the scene manually. Do you get the inconsistent behavior running it that way?

EDIT: It occurred to me that you might be setting the color from SmartLighting. If that’s the case, is it consistent that every 2nd time the same bulb doesn’t work? If that’s the case, make sure you don’t have “toggle on & off” turned on in the action for that bulb. If the issue is consistently every 2nd time for the same device, that’s usually the culprit.

1 Like

@bry, I was using smart lighting app and was creating the complete automation directly into this app. I tryed as you kind of suggested, through a scene and it now works just fine!

Thanks again for your great help!!

EDIT: ON & OFF Toggle was turned off…

1 Like

Great question – at this time, unfortunately not unless we get some sort of massive investment :slight_smile: