Inovelli Red Switch (LZW31-SN) not triggering automations in SmartThings

My switch has been installed and is working manually with a single tap, as well as in Google Home automations (for turning on and off). In SmartThings I have updated the drivers properly and have been able to update some of the settings (like the dimmer min in order to keep the LED lights this switch controls from flickering).

When I setup my first SmartThings automation for a double up tap (simply to turn the lights to 100% as well as turn on another set of lights) it doesn’t ever trigger. I’ve removed the automation and added it again, I’ve also tried setting it to start from a double down tap the configuration button and even just a single up press, but none of them seem to start an automation.

I created a new automation that is started from a different light and that worked fine, so I know SmartThings automations are working. It has to be something with this particular switch.

Any help would be great! Here’s the settings screen from the switch:

Can you post your “automation”? There aren’t automations per se any more as what used to be called an automation is now a routine. But you might be using automation in the general sense, and perhaps using SmartLighting, which would be the proper way of working with a button event?

One thing to try. Your parameter 51 is set to “1”, which is correct. But it may have been populated because you turned the paddle delay off and then back on. There has to be a paddle delay or button events won’t work. So your setting is correct, but maybe try turning off the delay and saving. And then turn it back on. Just in case something didn’t get translated to the back end regarding the delay, preventing the button event from getting transmitted.

I tried toggling the delay as you said but unfortunately it didn’t fix it. Agreed on the automations. It is a routine. Here it is:

Sort of what I expected, but let me explain.

When you are presented with the IF option you are being presented with Button options, which is, um, new. When I select IF options, I don’t get a button option:


So the question is why do you have the button selection options; you’re not the first. Eric, EricM and I have discussed this, and the suspicion it that you may have loaded the beta Edge drivers or participated in the ST beta program. The other question is why is one of these working and the other not. Is the other routine you mentioned identical?

If you can post a screenshot of the IF options, that might help. Someone else here had the same issue and IIRC, @EricM_Inovelli was able to suggest something that worked. I haven’t loaded Edge, so I don’t have those button options, which makes it tough for me to suggest something here.

One alternative would be to set this up using SmartLighting. I know that Groovy and SmartLighting is going away at some point, but it may at least get you going for now if someone can’t figure out the button thing.

Here are the of options for when I press the + button

And here’s what it looks like when I press the row under if.

There are no routines that work with this switch. It’s a different switch that I was able to get a routine to kick off with. Also, I’m using the new SmartThings app where I login with a samsung account. I mention it as my screenshots and layout seems to be different than the one you sent a screenshot of.

Is there another driver that I should try installing?

I’m not honestly sure where that different menu is coming from. Did you load the Edge drivers?

Not sure. How do I tell?
Here’s a screenshot of the driver:

Thanks. You may not be using the correct driver, but let’s check. You might have inadvertently posted a screenshot of the wrong driver even though the switch is using the correct one. Your device is a LZW30-SN switch, but the driver you posted a screenshot of is for a LZW31-SN dimmer.

In the IDE, open the page for your switch and then select “Edit” at the bottom. Screenshot that page.

Also, in the IDE, look in the My Device Handlers section. Do you have a device handler named " InovelliUSA : Inovelli Switch Red Series LZW30-SN" installed?

Ah sorry, I must have mistyped the product code in the title (I’ve updated it). This is a LZW31-SN dimmer (not on/off switch). So the LZW31-SN device handler is the only one I have installed, and I just verified that it’s the driver that the switch is setup with.

NP. Let’s step through building the routine as your menus are different than mine. So after the “Select devices” page and you select the switch, post a screenshot of that menu. It’s going to be slightly different than the one I posted above.

That’s when I see this screen:

If you scroll down, do you see something like “Inovelli Dimmer Red Series”? Can you post the rest of the menu?

This is from SmartLighting, but the concept is the same:

No nothing like that. This is the bottom.

Unfortunately, the only thing I can suggest is that you try doing this through SmartLighting instead of a routine. I suspect that those menus have come about as a result of loading the Edge drivers, but I can’t say for sure as I have not loaded them to my hubs.

Inovelli is aware of this issue so hopefully they’ll post something to shed light on this issue.


An EDGE driver is in use if the “Driver” option appears under the menu. On your device, click the 3 dots menu in the top right corner, check if the Driver option exists. If not there, you are using a standard Groovy (or built in form of one) DTH. If there, you’re using a new EDGE driver.

1 Like

Guess it’s not an EDGE driver then.

Now what?

Did you try SmartLighting???

I’m unable to find any app called smartlighting on the iOS store. Can you link to it?

SmartLighting is not an IOS app, it’s a ST app. Go to the Automations tab and scroll down to the SmartApps section (its the one on the bottom). See if it’s already installed. If it’s not, you’ll just have to add it.


I’m not sure why, but I don’t have a smart apps section. Doesn’t seem like there is anyway to add one either.