Lots of troubles with Red Dimmers

Hi Folks,

Super frustrated, and not really sure where to start.

I have 3 Red dimmers that are giving me nothing but trouble. When I send on/off commands via Hubitat, most of the time nothing happens, sometimes they respond like 30 seconds later. I’m running them as scene controllers only for a Haiku fan - trying to use 2 of them as a virtual 3-way for the light and one for the fan. But even when I just focus on controlling one at a time, the commands just aren’t being received or acted on (not sure which) reliably.

Now I’ve tried excluding them and can’t get them to exclude. So I forced removal and factory reset and now can’t get them to include.

Are you on a C-7 model Hubitat? (If you’re not sure and you bought it recently, the answer is probably “yes.” If you got prompted to enter the S2 DSK during pairing, the answer is definitely “yes.” But you can check in Settings > Hub Details or the bottom of the hub to be sure.)

If so, one thing that might help is shutting down the hub (from Settings), removing power after it shuts down (red LED on the front), then waiting about 30 seconds before plugging it back in. This will force the Z-Wave radio to restart and is one trick some users have had to do with stubborn devices, which can sometimes be the result of the radio getting hosed in a way that only this can help with (until Silicon Labs or whoever figures out what might be going on with the SDK Hubitat is using).

Additionally, despite the fact that you tried a reset, you might want to try an exclusion before inclusion just to be extra-sure. Z-Wave devices won’t pair if they already think they’re included, and a reset should also take care of that, but this can’t hurt. It is also good to try after any failed inclusion attempt.

Beyond that, the problems you are describing are odd, but it’s hard to say what the cause is. Do you have a strong Z-Wave mesh (with multiple other repeating devices)? Is the hub far away (repeaters should help with this and if the device can’t pair in place it probably won’t work in place either, but it may be helpful for troubleshooting)?

Finally, if you haven’t updated to Hubitat firmware 2.2.4 and are on a C-7, I’d try that, as there are multiple improvements over 2.2.3 for Z-Wave. (On a C-5 and earlier hub, nothing should have changed there.)

1 Like

I can’t speak to potential C-7 issues, so I’ll defer to BertABCD1234 on that. You can see your hub model by going to “Settings” -> “Hub Details”.

The issues you describe sound like a weak Z-Wave mesh. Is this a new Z-Wave setup? If so, Z-Wave repeaters may help. The article at https://community.hubitat.com/t/how-to-build-your-z-wave-mesh/1822 may be helpful here.

Yes, C-7 hub.

Not a new Z-wave setup, but is a mix of non-Plus and Plus devices. Slowly replacing the non-plus switches with the Red Dimmers.

In case you’re not aware, firmware 1.48 specifically fixes a C-7 issue. I know you said you’re having problems adding them back. Not sure if that’s can’t add them at all or can’t add the S-2.

Thanks. All of mine are on 1.48 already.

I got them added back after a few tries, but responsiveness is still hit or miss. Seems like one of them is worse than the others, but it’s kind of unpredictable.

I’m not on Hubitat, but I presume you can run your scene from the app or the interface. What happens when you run the scene from there? Do you get the same lack of responsiveness? Just a suggestion to help narrow the issue by taking the switch out of the equation.

Also, looking back at your original post, you stated that you are using the switches as scene controllers only, so I’m assuming nothing wired to the switch. But you’re sending on/off commands to the switch. Shouldn’t you just be issuing the scene command directly?

Maybe it’s something with Hubitat, but that seems strange to me. To my thinking if you have a scene you want to run, you should address it directly, not via a switch that just happens to be a scene controller. It’s like your adding a hop to the switch then a hop back to the controller when the controller should just run the scene and leave the switch out of it.

Of course, if you want to run the scene from the switch, that’s another matter. But that’s not the issue you described in your original post.

I’m a recent migrant from ST to Hubitat C7 and my experience was a bit like yours. What I found to be my problem was non-plus Leviton devices (plug-in dimmers). I replaced them with the plus versions (Leviton) and my terrible lag and unresponsivness went away. That was on HE version 2.2.3. I have since upgraded my C7 to and everything is lightning fast. IMHO the C7 does not like a mix of plus and non-plus devices, at least not on 2.2.3. If you haven’t yet, I would reccomend upgrading to 2.2.4, and make sure polling is turned on for your existing non-plus devices.

1 Like

Make sure to check out the Route column on the Z-Wave details tab. In fact, the new firmware has a nice RTT (round trip time) value in milliseconds under the Stats column too. You may have a bad actor in your mesh that all of your switches are routing through.

I may be using the term “scene controller” inappropriately in my original post. You are correct that I don’t have anything wired to the switch, aside from line in and neutral to provide power. What I’m trying to do is have the switches emulate the behavior of the dimmer as if they were physically controlling the lights and fan, but by sending/receiving commands to the Haiku fan/light.

But regardless of all of that, I’m just trying to get the dimmers to respond to ANY command reliably, so I’ve been testing that response time by sending an on/off directly through the device listing in the Hubitat UI.

The one dimmer that’s giving me the most trouble does seem to be taking the long way around, routing through 4 or 5 different devices upstairs and down…anything I can do about that?

I had the Z-Wave Poller app installed but hadn’t set it up yet for my old devices - just did. Will see if that improves things.

To give you an example of what I’m talking about, the switch at the top never gives me issues, but the switch in the bottom does occasionally. The biggest difference is the number of hops between the hub and the switch.

You should probably set up associations, so that these switches will talk directly to each other when pressed. Here is a thread about setting that up. It may solve your problems.

So I setup the Poller and now none of my Zwave switches are responding to commands throughout the house

Turned it back off and still nothing. Any ideas?

Edit: I exluded and re-added one of the non-plus Zwave switches that wasn’t responding and now everything is working again…for now

Welp, that was fun while it lasted. They (the Red Dimmers) seem to work great just long enough to make me think I’ve solved it, and then they just flat out stop responding to remote commands.

  1. How many Z-Wave devices do you have total?
  2. What’s the size of your house?
  3. Can you look at the main log and see if there are repeating entries?

I migrated from ST to HE recently on the C7 hub and ran into similar issues. One advantage I had was the ability to move my HE hub closer to the devices during the inclusion and exclusion process due to my portable Google mesh. Out of my 81 smart devices, 11 of them are Inolvelli. My seven red units gave me trouble. What worked for me was making sure the drivers were correct (Use Hubitat Package Manager)and then remapped the Z-wave to improve the communications once all the z-wave devices were included. Please note: The red series with the most up to date C7 hub will not update my Inovelli’s red series firmware. I had no issues with Inovelli red series using ST.

Can you tell me more about how you do this using HE?

Remap = repair. I go to HE than the three dots>zwave wave details> repair zwave. I’m not aware of a way to force the mapping. Zwave Repair will look for the best way to improve mesh communication…