LZ31-SN No-Neutral SmartBulb with Bypass Fail

Any tips on how to change remote-only parameters from Home Assistant?

I’ll have to defer to @kreene1987, @jtronicus or a couple others for this one!

The process varies depending on which zwave integration you are using.

Do you know which one you re using?

  • Zwave (depreciated)
  • OpenZwave (Beta)
  • ZwaveJS

The Universe, she speaks to us: seconds after posting this I went back to my HASS client and found the 2021.4 update waiting - an update that includes (wait for it…) parameter config surfaced right in the device UI. Seriously sweet.

Now, I just need to find a few parameter definitions - I’ve been battling a ‘Hue bulb turns back on after down-press on switch’ with a new LZW31-SN; relay’s disabled, automation configured to fire on/off/dim up/down for appropriate lights (same config w/o dim for the for my LZW30-SN switches = A+). This is my first Red Dimmer install, no neutral and using an AEOTEC bypass. I just enabled Smart Bulb mode and will report back after testing.

Oh - @jtronicus - using the native Z-Wave JS integration for exactly this reason - hopped from OZW and flirted with JS2MQTT (that add-on’s badass), but figure a) JS is the go-forward for HASS, and b) that should = a tighter native experience (like parameter config via device menus etc.).

1 Like

Well, this Red Dimmer / No-Neutral install has bested me for a second day straight - unique experience. Hoping the Royal You can point me in the right direction.

Setup:

  • LZW31-SN connected to Hue white LED, single-pole
  • Aeotec bypass installed above the light (in can)
  • Hub = Home Assistant OS (dedicated Intel NUC)
  • ZWave = Aeotec Gen5 USB stick
  • Switch config: Initially disabled relay at switch (8x / red flash), later enabled Smart Bulb mode, AC Power Type = No Neutral, Switch Type = Single Pole

Target Experience:

  • LZW31-SN provides constant power to Hue bulb, sends scene data to hub, hub automates light response based on button press sequence.

Current Experience:

  • LZW31-SN and Hue light powers up after power restore, switch pairs fine with hub, automations work until hue bulb receives ‘turn-off’ - then switch begins red/blue/green LED cycle indicating insufficient voltage (I think), won’t reconnect to hub.

Troubleshooting:

  • Tried different (3) LZW31-SN switches (installed one in different location w/Neutral = all good)
  • Installed different (2) Aeotec bypasses
  • edit Tried with 3 different bulbs = Hue White, Hue Color (last gen), and a random 1100 lumen straight LED bulb (no old-school incandescent bulbs around here) - wondering if a single-pole LED just doesn’t pass enough juice even with the bypass??
  • Random config combinations - disable local control, disable ZWave hub association, etc.

Hoping I’m missing the magic config combination - I can’t find a reference that describes the exact config for my setup, and there are many settings I don’t understand (Z-Wave ramp rate, default Z-Wave level, Z-Wave association behavior, etc.). Any guidance much appreciated.

edit2: I notice when the switch initially powers on, the LED grows to ~60 percentish and sticks. Load and Line appear to be wired correctly, but the switch doesn’t look like it’s getting the juice it expects. Maybe a wiring mismatch?

Playing with parameters, I found disabling ‘Smart Bulb Mode’ while keeping the relay disabled at the switch keeps the switch connected to hub, but I still can’t turn off the light - call ‘light_off’, light dims to 0, switch panics red/green/blue and powers back to 100%, bulb flashes a few times on its way to 100%. @Eric_Inovelli @jtronicus @kreene1987 have you seen this behavior before? Maybe firmware issue?

I have not, but I’m not as familiar with HA, so I’ll defer to @kreene1987, @jtronicus and @EricM_Inovelli

Does your switch power on (does the indicator led turn on) if the bulb is completely removed?

I believe it went through the red/blue/green cycle, but honestly can’t remember - moved it to a different area w/neutral and put the old analog switch in for now. After more searching, it looks like this is a known issue with Red Dimmers + non-neutral / smart bulb installs. Will consider trying again if I can find a working solution = specific / detailed configuration settings, firmware update, etc.

fwiw, I’m very happy with these switches overall, but this experience with the 31 has left a bit of a bad taste: marketed as ‘works without neutral’ (didn’t), old chatter in forums pointing to this exact issue with bypass + smart bulbs (should be called out clearly), and configuration details scattered / incomplete / platform specific (based on what I’ve found).

That said, it looks to me like Inovelli has built an incredibly flexible switch that should work for ‘every home automation’ environment - I ‘get’ it’s impossible to create documentation for every platform, setup, use-case, and experience level. But a single source of truth describing each configuration setting and its impact on the system would be super helpful - if there’s one out there I totally missed it, just point me in the right direction.

Sorry about the frustration. This is a firmware issue that our engineers believe they have figured out. Which firmware version are you using?