LZW30-SN - Activate the light on button-press. Not button-release

On a regular light switch, the light turns on/off when I press down on the toggle switch… not when I release it. I have a Leviton smart switch which behaves in this way and makes the switch feel more responsive. I’d love it if my On/Off Red could work in this way.

Obviously this wouldn’t work with scenes, but neither does disabling the 700ms delay. Perhaps just disabling the 700ms delay could also cause it to behave this way.

1 Like

These buttons have to be on the release because they allow you to do custom actions with multiple presses (e.g.: My dining room light defaults to 70% brightness, but will go to 100% brightness if I double-tap up). There is a setting in the firmware to turn off the 700ms delay that is necessary for that to work. Try turning that off, and see if you like that better.

How does one change this setting? I agree with OP, this would be a nice option (assuming one is willing to forego the multi tap gestures)

You need to make sure your switch is running at least Firmware version 1.19: https://support.inovelli.com/portal/en/kb/articles/firmware-v1-19-beta-lzw30-switch-black-series-gen-2

Then use your hub to set parameter 51 to 0 (or 1 if you want to re-enable the 700ms delay+gestures).

Disabling the 700ms delay already disables multi-tap and hold gestures so there’s no conflict there. I personally don’t have a use for the gesture features. I got the Red instead of the Black because I wanted the LED and power consumption features. If I ever do want to control some extra thing for some reason, there’s always the config button.

I only mentioned LZW30-SN (On/Off) in the title because that’s what I have right now. But if this request does get some attention from Inovelli, I hope they also make the same changes available to the Dimmer version. I’m not a big fan of the relay clunk in the on/off switch so I’m tempted to get a dimmer and set it up as just an on/off.

If you disable to 700ms delay it is almost instant and appears to be an old school switch. It Hubitat you can do this by changing the parameter 51 or by setting “Disable Physical On/Off Delay” to Yes.

This is a new setting that I just found recently so I think it is only a few weeks old.

To be clear, I already had the 700ms delay disabled. The suggestion/wishlist item for this thread is a different thing.