LZW30-SN OTA Update with ZwaveJS2MQTT

I see a lot of threads about updating LZW31-SN firmware with ZwaveJS2MQTT (which I completed 1.47->1.48 without trouble) but I haven’t seen anything about updating an LZW30-SN. I’m trying to update from 1.9 to 1.17 and I keep getting timeout or no ack errors. This log is after:

  • Restarting Zwave2MQTT container
  • Air gapping for 10 seconds
  • Re-interviewing
  • Trying the update on target 0.

2021-05-18 12:42:12.674 INFO ZWAVE: Calling api beginFirmwareUpdate with args: [
55,
‘Switch_AdvancedOnOff_ZWAVE_20200426_V1_17.otz’,
<Buffer 3a 30 32 30 30 30 30 30 34 30 30 30 30 46 41 0d 0a 3a 31 30 30 30 30 30 30 30 38 30 30 30 30 31 37 45 46 30 35 30 42 31 31 43 31 35 41 31 35 31 39 30 … 275792 more bytes>,
0,
[length]: 4
]
2021-05-18 12:42:42.404 INFO ZWAVE: Node 55 is now dead
2021-05-18 12:42:42.411 INFO ZWAVE: Failed to send the command after 3 attempts (Status NoAck) beginFirmwareUpdate {
success: false,
message: ‘Failed to send the command after 3 attempts (Status NoAck)’
}

So I factory reset the switch, re-included it, and tried again. Still no good.

2021-05-18 13:07:19.523 INFO ZWAVE: Calling api beginFirmwareUpdate with args: [
107,
‘Switch_AdvancedOnOff_ZWAVE_20200426_V1_17.otz’,
<Buffer 3a 30 32 30 30 30 30 30 34 30 30 30 30 46 41 0d 0a 3a 31 30 30 30 30 30 30 30 38 30 30 30 30 31 37 45 46 30 35 30 42 31 31 43 31 35 41 31 35 31 39 30 … 275792 more bytes>,
0,
[length]: 4
]
2021-05-18 13:08:20.271 INFO ZWAVE: Received no matching command within the provided timeout! beginFirmwareUpdate {
success: false,
message: ‘Received no matching command within the provided timeout!’
}

This switch otherwise behaves correctly. I’m reluctant to try any of my other red switches as my home automation journey has been eroding good will with the wife and I don’t want to push it. I was hoping I’m just missing something.

I don’t have solution for you, but rather a question… why 1.17? The latest stable is 1.20 and the latest beta is 1.22. I think all of my switches have 1.22 otherwise I’d try upgrading one.
https://files.inovelli.com/firmware/LZW30-SN/

1 Like

Because sometimes there are problems jumping too far with firmware updates and 1.17 was the next consecutive file I could find. And since the update to 1.19 failed, I just started plugging away at 1.17.

And secondly, because google brought me here: https://support.inovelli.com/portal/en/kb/inovelli/downloads/firmware

Thank you. I had no idea this existed. Bookmarking this page now.

One other thing to try is an exclude, factory reset, include, then update

Edit: Factory reset by holding config button 30 sec. LED will turn red.

This is an even better place to find all the software versions, they’re all organized by device here.

https://files.inovelli.com/firmware/

Great link, @stu1811 !

1 Like

@horriblenoises I’ve had the same experience - updating LZW31-SN through zwavejs2mqtt worked fine, but updating LZW30 (black series on/off) failed and knocked the node offline. Haven’t debugged much beyond that, but happened for 3 of 3 devices I attempted. Had to pull the air gap to reset them and bring them back online (still running the old/original firmware of course).

1 Like

Thanks for the verification. It’s odd that updating works for one red series and not the other but at least I have a bit of peace of mind / hope that maybe it’ll be fixed in the future.

I’m having the same issue. I have 3 LZW30-SN Red switches. The first one I was able to update from 1.21 to 1.22 without issue. The second one (also on 1.21) did not work. I tried a handful of times but the node would just go offline and I would have to airgap it to bring it back. I then updated zwavejs2mqtt to the very latest version (4.3.0) and tried again. No luck. I then tried my 3rd switch (1.20) and it didn’t work either but did not go offline (same error as the OP after the factory reset).
The reason I am trying to update my switches to the latest (1.22) firmware is that I still have an issue in a 4 way set up (with 2 dumb switches) where occasionally when attempting to turn off the lights by pressing the bottom paddle of the LZW30-SN switch, the lights will go off but then right back on. This does not happen when using the dumb switches and seems pretty random.

Update:
I was able to get 5 out of my 8 LZW30-SN switches updated. I cannot find a rhyme or reason why the 3 refuse to ack the update request.
One failed on the first attempt and succeeded on the second (after restarting zwavejs). Also not sure why.

I haven’t bricked any switches where a simple toggle of the air gap switch (any maybe a ping from zwavejs) doesn’t fix it so I can recommend throwing caution to the wind.

@horriblenoises Any idea what the trick was? I have a few I need to update

Unfortunately I don’t. I have a suspicion that the 3 that I couldn’t update were the first batch that I bought and they’re just too old or something. I’ve moved switches all around the house as my staggered orders came in so I’ve lost track of what is what.
I’m now of the opinion that if it doesn’t work, it doesn’t work and trying doesn’t do any harm but… that’s more of a feeling than any concrete reason I can point to. Good luck.

1 Like

I’m also having this same issue. All of my red series dimmers updated fine, but only some of my red series on/off switches will update. I’m getting the same error and the switch goes offline until I pull the air gap.

Same here… I have three red series on/off switches stuck on firmware 1.21. Do i need them upgraded to 1.22? No… but it worries me a bit that I can’t get there, and that attempting to upgrade firmware causes them to fail and require airgapping.