LZW31 Dimming Issue

So I got a whole bunch of LZW31 none scene dimmers. I installed one to test it out. All seems good except the dimming. The new dimmer replaced the old Inovelli dimmer which worked prefecture fine. I just replaced it to test out the new dimmer. Here is what I noticed compared to the old dimmer.

  1. The new dimmer does not seem to dim to the highest level. Compared to the old dimmer the new one seems darker at it’s highest dim level.

  2. The new dimmer has a very strange flicker effect when dimming up and down. I tried adjusting the min and max dim speed, but it’s not as smooth as the old dimmer. The old dimmer had very smooth and consistent dim up and down… the lights smoothly turned on and smoothly turned off. No flickering effect.

  3. I am using Home Assistant v0.101, which apparently still uses OZW 1.4. As far as I read the Inovelli switches and dimmers are integrated into OZW 1.6. How can I fully integrate new switches and dimmers until HA is fully compliant with OZW 1.6?

Any help is greatly appropriated. Thanks in advanced.

1 Like
  1. See here for HA integration. I completed this last week, and everything seems to be working.

Thanks! I actually found that after I posted the thread.

For numbers 1 and 2. Is it just me who is experiencing the dimming issue? Did I get a bad batch?

I just put up another switch. I tired dimming it up and down. Not only did it flicker during the dimming, but it actually jump a few dimming levels. It was dimming up to about 40% than it jump to about 70%. I can’t wrap my head around it.

1 Like

I am not coming from other dimmers so I have no basis for comparison, but I did notice similar effects. I actually can only make use of 37% - 85%. Anything less is off, and anything more is full (or what I think is full because I didn’t have a dimmer there before). So I set those limits in the software, but I get some strange affections. If I dim from 20% to 10% it does not do it smoothly. It makes four large steps down to 10%. Also, if I set it to 95% I get a flicker. I don’t think I get the flicker at 90% or 100%. Odd behavior for sure, but I only installed my first dimmer yesterday.


Ok. So it’s not only me. Can some one at Inovelli please chime in on this. Is this a known issue?

I’ve noticed this issue as well. When dimming it kind of steps quickly rather than a gradual change, especially when it’s dimmer. It’s not noticeable towards full brightness.

I am curious if it’s the settings that need to be adjusted or it’s something with the firmware. If it’s the settings than what do we adjust?

I notice the same thing- most of my dimmers have a minimum of 25% or more and no higher than 85%. I understand Led bulbs are all different and this plays a factor but figured I’d mention this as another datatpoint.

I also experience the stepping on all dimmers.

Anyone tried to play around with the settings?

Hey guys, can you throw up a video of some sort so we can take a look?

Also, it would be helpful to understand the load you guys are using (ie: LED/CFL, Single-Pole/3-Way, Neutral/Non-Neutral, etc)?

I haven’t seen this specific issue, but would like to try to replicate it.

In my particular situation I was testing it on a 3 way neutral with 10w per light with 4 LED lights. I also tested it with a single pole non-nutral with 10w per light with 4 LED lights.

I’ve got similar issue. I have 4x13 watt dimmable led bulbs in a bathroom fixture (with Neutral wire). When dimming ‘up’ it seems there is no light until it slams into the 50% range in which it then reaches 100% very quick. Almost like an S-Curve. It takes a long time with nothing, then halfway-ish, then continues to brighten to 100 very quickly. Dimming ‘down’ I can control it at the lower levels easier.

Also, semi-related note is I cannot get the device to configure with Vera Plus. It complains about security keys and failed to configure. I have unpaired from Vera, factory reset device (red lights) and then repaired with the vera unit within inches and same issue.

Exact error code from the notification banner in Vera:
Z-Wave device 409 ERROR: Failed to setup security. Please exclude this device from your system, and then include again…Z-Wave device 409 ERROR: Failed to setup security. Please exclude this device from your system, and then include again.

Ah ok – I’ve seen this before too. It really depends on the bulb, but I’m not entirely sure as to why it does this (ie: the engineering reason behind this – I do have a note out to the manufacturer to have them better explain it).

What I did to, “fix” this is set a minimum dim setting (ie: 20% or wherever you notice the bulb turns on) and that makes it the lowest it will go (and it will start there when turning it on). Fix is in quotes as I realize you don’t get the very low dim settings that you likely want, but at least it won’t take some time for the bulbs to turn on.

I realize this is not the best answer, but as you can imagine, there’s 1000’s of bulbs out there and we tried to test as many as we could, but we couldn’t test them all, so the point of this thread: Dimmer Switches | LZW31 / LZW31-SN Compatible Bulbs Mega-Thread is to start to list out the ones that work and don’t work so that we can have an optimized experience for everyone.

@datzent83 @dan1282 @exo – and anyone else – can you list out your bulbs (ie: name-brand, SKU # if possible, etc) so that I can purchase them and test them out?

Thanks guys, and sorry for the frustration. I can say that I’ve definitely seen this before when we initially tested the switches out and when we swapped out the bulbs, it worked as intended.

Attached are the dimmable LED lights that I use.

The reason why I don’t think it’s the lights is because by my old Inovelli dimmer performs perfectly. I don’t have these issues with it. When I replace it with the new one I experience these issues right away.

If you can’t find these anywhere I am more than happy to ship a few to you.

My lights are Electric Zone. EZ-A615-BA-2700K-A6. I tested with an incandescent bulb and found that towards the lower end I can still notice it step quickly rather than have a smooth dim at the default dim rate. I will test a faster dim rate to see if it’ll make the transition less noticeable.

I can try that - I’d be more inclined to replace the bulbs with ones that work if that’s the case. But based on other comments, folks seem to have bulbs that worked with previous versions but not this newest lzw31 device.

Also, I am REALLY wanting to leverage this feature but can’t find the instructions on how to set it up:

Default Local Dim Level
Have your switch come onto a max default level based on the time of day. For example, if you don’t want to blind yourself at 2am when you’re going to the bathroom or sneaking a cookie, you can have your dimmer only turn onto 10% when you manually press it between the hours of 10pm and 8am.

Yeah… Unfortunately, the Gen 2’s are made by a different manufacturer and our relationship with the old one is not good, so I’m not entirely sure what the overall difference is, but I’m definitely looking into it.

@EricM_Inovelli should be adding this into the device handler for ST shortly - I let him speak towards the timeline :slight_smile:

What if I’m on the Vera platform? (VeraPlus on current firmware)

I’ve also just tried setting up the minimum dim level, using the at-device method as explained in the example on the instructions. I followed the procedure exactly, receiving confirmation blinks along the way (2 yellow for the configuration setting and then the 8 purple - setting to >8% - and then confirmation of green then yellow and blue blinks to confirm everything. But then when dimming down from either the Vera UI or the local device, able to dim down to 1% still. Possible I’ve got a lemon? Really trying to make this all work out here. :-/