LZW31-SN dumb switch help

I am replacing a dumb dimmer 3 way to a smart dimmer and dumb switch 3-way.

I installed the inovelli LZW31-sn dimmer and it works as expected with the three way switch set up to load and load (real) connected.

If the dumb switch is set to load (real) and traveler connected, no light.

In other words, I can’t have the inovelli dimmer send any current via the traveler.

I changed parameter 22 to 1 (multiswitch Dumb) but no change in behavior.

In other threads referencing parameter 12 and 13, they seem to be speaking about LZW31 and not LZW31-SN. Not sure if there are any other differences. I can’t seem to find a product information page or manual downloads for the SN variety.

Thank you for any help offered,


Hey Devan,

Can you shoot some pics for us? It’s hard to diagnose what’s happening without taking a look under the hood.

They’re both the same, sorry for the confusion. It should be in the manual that came with the switch, correct?

Sorry for all the troubles you’re having today!

The manual that came with the switch has 22 parameters. The one from the website has 17.

The Wiring insert told me to use the config button and click 13 times. I was unable to complete this procedure. I was never able to get to the 1 slow and 3 fast blinks. Most I got was 10 blinks.

Can I just send a z wave parameter?

@devanb -Here is where I changed my settings on hubitat.

Wish I had hubitat.

I’m using homeseer so I need to know parameter number, Value (decimal) and Value Size (1, 2, or 4 bytes)

Easier to do it from the config button. The taps are listed in the extra brochure.

Edit: Here is the parameter chart for reference:

Parameter 21 and 22 is what’s needed to be configured – but it sounds like you’ve done that.

I think I completed the wiring insert steps. 1 long yellow, 3 quick yellows, up tap, purple, hold config, green yellow, cyan.

Still doesn’t work.

If the dumb switch is in the on position, the dimmer works as intended, if the dumb switch is off, I cannot turn it on from the smart dimmer.

@Eric_Inovelli -Sounds familiar. Mine was doing the same thing until I made the config change.

I’m a bit confused. The wiring insert asks me to tap the button 13 times. I’m assuming that is so I can modify parameter 13.

The table included in the manual mentions changing parameter 22.

Which should I do?

Yeah, I definitely think it’s something with the configuration – maybe it’s not sticking properly, I’m not sure.

@devanb – is there a way for you to change it via HomeSeer with the parameter chart above?

Parameter = 21
Hexadecimal = 0x015
Decimal = 21
Bytes = 1
Value = 1

Parameter = 22
Hexadecimal = 0x016
Decimal = 22
Bytes = 1
Value = 1

Maybe this will work?

Yeah, sorry – we couldn’t add all the parameters to the switch, so we had to pick and choose.

In a nutshell, Parameter 22 = 13 Taps on the Config Button

I excluded the switch, factory reset the switch, added the switch back to homeseer as a unsecure node.

I queried the default values for parameters 21 and 22.

21 default value was 0 (no neutral)
22 default value was 1.

I changed 21 to 1.
I changed 22 to 1 just in case.

It works now.

I think I wasn’t changing parameter 21 because it lists that 1 is the default value in the manual.

That wasn’t my experience.

Thank you everyone!

Crazy times lol. I guess what this shows me is there is still a ton of room for a better user experience so I’ll try to brainstorm a few ways to improve.

As you were going through it, was there anything you could think of to make this easier on future installations for people?

Anyway, glad you were able to get it up and running!

  1. Make one central web page listing all products and associated documentation and manuals.
  2. Make sure the documentation is accurate.
  3. If errors are found, update the online documentation immediately or add a separate known issues addendum.
  4. The printed materials are very good but printed so small that most people over 40 will need to rely on a PDF they can zoom.
  5. Make sure the PDF’s are small so they can be loaded quickly onto a phone over cellular if installing at a clients residence (no wifi).

Thank you for asking.



I noticed this too – the wiring insert refers to 12 and 13 taps for what should be parameters 21 and 22 per the parameter table (and OpenZWave files).

I had the same issue with mine. Configuring from the switch didn’t work. I had to use Hubitat to set Neutral yes/no and 3-way type. It seems it may not default to Yes Neutral like the documents indicate.

I set up a new switch and I now see that it appears to not be saving the setting for 3-way when adjusted from the switch itself. I tried setting it to either kind of 3-way and it failed to update after saving the setting

Can you change or query z wave parameters directly using Hubitat?

Yes. Changing parameters from the hub does correctly change the mode. Just doesn’t want to take when done from the switch.