LZW31-SN flashing madly

I have a LZW31-SN that I use for the garage running a bunch of LED lights. Wired in as 3-way with a dumb switch. I’m using Home Assistant and Node-RED to do different scenes. I just updated from the old ZWave to Z-Wave JS, which went a little funny but things seem like they’re working now.

However, tapping “on” once is causing the garage lights to flash on and off very quickly (like 4-5 times per second). I don’t think it’s the Node-RED flow doing it. I think the switch might be misconfigured. But I can’t see what might be doing this.

Here’s the Node-RED flow… one top button press sends a brightness of 255, then 3 minutes later sends a brightness of 0.

Any ideas?

Thanks! :slight_smile:

I assume everything worked fine with the old integration? Verify parameter 22 is set to 1 (dumb switch) and parameters 21 is 1 for neutral and 0 for non neutral.

Is the dimmer neutral or non neutral? What’s the load in watts and the type of bulb(s)?

All else fails stop the node red addon to rule out that.

Hello @stu1811! Yes, everything worked fine before. I think 22 is 1 and 21 is 1 (it’s has a neutral). Usually runs just a few watts (less than 5?). LED bulbs… various brands… unchanged.

Same flickering happens when powering on via Home Assistant UI/Lovelace card.

Attaching image of all the configs in case I’ve messed something up.

Screen Shot 2021-11-22 at 6.35.26 PM

Anyone have any ideas? This is pretty terrible… see for yourself!

I have an identical switch in the living room which migrated just fine and is working as expected. One difference: this crazy one is a 3-way (dumb) and the living room is a single switch.

I did see this post (LZW31-SN: Very bad flickering after updating to 1.47 (otz and bin)) but I didn’t update any firmware.

This is interesting, though (I think). I just tried turning “Smart Bulb Mode” (parameter 52) ON (it was and has been off) and now when I turn the light on it only flashes once quickly and then turns off, AND in Home Assistant the UI switch turns off, too!

I’ve disabled all the Node-RED flows, so I don’t think that’s a part of the problem.

Here’s what it looks like in the logs when I turn on (getting the quick flash and then going off):

2021-11-24T04:36:07.625Z SERIAL » 0x010f001303086c0181042601ffff25a7a5                                (17 bytes)
2021-11-24T04:36:07.630Z DRIVER » [Node 003] [REQ] [SendData]
                                  │ transmit options: 0x25
                                  │ callback id:      167
                                  └─[SupervisionCCGet]
                                    │ session id:      1
                                    │ request updates: true
                                    └─[MultilevelSwitchCCSet]
                                        target value: 255
                                        duration:     default
2021-11-24T04:36:07.639Z SERIAL « [ACK]                                                                   (0x06)
2021-11-24T04:36:07.644Z SERIAL « 0x0104011301e8                                                       (6 bytes)
2021-11-24T04:36:07.647Z SERIAL » [ACK]                                                                   (0x06)
2021-11-24T04:36:07.650Z DRIVER « [RES] [SendData]
                                    was sent: true
2021-11-24T04:36:07.663Z SERIAL « 0x01050013a7004e                                                     (7 bytes)
2021-11-24T04:36:07.666Z SERIAL » [ACK]                                                                   (0x06)
2021-11-24T04:36:07.668Z DRIVER « [REQ] [SendData]
                                    callback id:     167
                                    transmit status: OK
2021-11-24T04:36:07.688Z SERIAL « 0x010b00040003056c0201ff0066                                        (13 bytes)
2021-11-24T04:36:07.692Z SERIAL » [ACK]                                                                   (0x06)
2021-11-24T04:36:07.696Z DRIVER « [Node 003] [REQ] [ApplicationCommand]
                                  └─[SupervisionCCReport]
                                      session id:          1
                                      more updates follow: false
                                      status:              Success
                                      duration:            0s
2021-11-24T04:36:07.853Z SERIAL « 0x01090004000303260363b4                                            (11 bytes)
2021-11-24T04:36:07.858Z CNTRLR   [Node 003] [~] [Multilevel Switch] currentValue: 0 => 99          [Endpoint 0]
2021-11-24T04:36:07.861Z CNTRLR   [Node 003] Scheduled poll canceled because value was updated
2021-11-24T04:36:07.864Z SERIAL » [ACK]                                                                   (0x06)
2021-11-24T04:36:07.868Z DRIVER « [Node 003] [REQ] [ApplicationCommand]
                                  └─[MultilevelSwitchCCReport]
                                      current value: 99
2021-11-24T04:36:10.122Z SERIAL « 0x0114000400030e3202216400000defffff00000def97                      (22 bytes)
2021-11-24T04:36:10.127Z CNTRLR   [Node 003] [~] [Meter] value[65537]: 3.567 => 3.567               [Endpoint 0]
2021-11-24T04:36:10.132Z SERIAL » [ACK]                                                                   (0x06)
2021-11-24T04:36:10.137Z DRIVER « [Node 003] [REQ] [ApplicationCommand]
                                  └─[MeterCCReport]
                                      type:        Electric
                                      scale:       kWh
                                      rate type:   Consumed
                                      value:       3.567
                                      prev. value: 3.567

Try setting max dim level (param 6) to 85

I think I’d try to isolate the problem. Either something went sideways with the switch as a result of the firmware upgrade or something went sideways as a result of the firmware upgrade AND its interaction with HA.

I’d remove the switch from HA and factory reset it. Reset the neutral type and switch type parameters and test. If it continues to act the same way, I’d probably re-flash. If it works fine, then the issue is with the HA interaction so you can then look further in that direction.

@Bry sorry to have muddied things… in my case I have not flashed firmware at all. Only did the changeover to Z-Wave JS on HA.

I will try removing it from HA, though.

No worries. I misunderstood that. But the concept is the same. You want to see if the switch is acting up independently or if the hub is factoring into the issue. It’s just a simple way to let you know in which direction to look.

I’ve removed the switch entirely from HA and it’s still acting funny… not identical, but funny.

I am able to turn it on and off normally about 60% of the time, and when I turn it on, it is not flickering madly anymore. So that’s nice.

But the rest of the time, when I try to turn it on, it immediately turns off and the LED (sometimes) flashes red, green, blue… about .5 second each.

Any recommended next things I can try?

The red, green, blue is the switch rebooting. Hard to tell what is causing it at this point. Since the switch was working fine and all you did was make some changes within HA, I am wondering if maybe some changes were made to the switch to cause it to reboot, although it’s hard to imagine what those might be. While a failed switch is a possibility, it is not likely that the failure occurred just as you made some changes within HA, so I am not thinking that is it.

At this point, I would factory reset the switch. If your line and load is in the same box, wire it as a two-way first to see how the switch behaves. If your line and load are in different boxes it’s a little tougher but you can try that as well. The default settings should be neutral, two-way. If you have to, set the three-way settings via the switch as opposed to adding back to HA at this point.

1 Like