LZW31-SN Routines Not Working with New Device Handler

I was having an issue returning the LED to the default blue state and was informed I needed the updated device handler to set it back to “Blue.” I had no problem applying the updated device handler and getting the LED back to blue. However, routines are not working with this new device handler. The routines work just fine if I set the “Type” back to the standard “Inovelli Dimmer” in the smartthings API. Is there something I’m doing wrong with the new device handler and setting up routines (e.g. Down Button Pressed 2 Times > Turn off different lights)?

It sounds like you had existing routines, switched handlers and now the existing routines aren’t working? Not sure, but it makes me wonder if switching handlers broke the existing routines.

Go back into the IDE (what you’re referring to as the API, I think), open the device page and make sure you are using the “Inovelli Dimmer Red Series LZW31-SN” handler (“Type” field). Then remove the routine. Stop the app and reopen. Put the routine back and test.

If that is still not working, post screenshots of the routine.

BTW, how exactly are you using Routines for button presses? AFAIK button presses aren’t exposed to ST Routines. I have to use either a button manager or an automation within Smart Lighting, so I’m not sure how a routine would work in the first place, unless that capability worked with the incorrect handler you were using. :thinking:

I did have existing routines but I deleted them and re-added them. I also excluded the switch and re-added it thinking that the device handler would work better if I had it in the IDE prior to adding the device. Neither of these things made any difference. Like I said before, when I set the “Type” back to “Inovelli Dimmer,” all of the routines work. What’s interesting is that when I went back in to the IDE to verify my changes, I see that the device type is actually listed as the new device handler “Inovelli Dimmer Red Series LZW31-SN” so the change I made only seemed to affect the routine’s ability to run. Anyway, it seems to be working now (although sometimes with a very slow response time or not at all). Not sure if that’s a z-wave issue or a smartthings issue or what. I do see the history of the button presses where I wasn’t before so the hub is recognizing the input. Seems as though it’s not always triggering the routine or scene properly, though.

I can’t say for sure, but since button presses through routines aren’t a thing (like, they’re not supposed to be there, at least with the Inovelli DH), they may not be working well.

Try replicating one of your routines using a button manager like ABC or using Smart Lighting. Use the proper Inovelli DH. See if that works any better. (Delete the routine so there is not conflict.)

I know those two things will ultimately deprecate when Groovy goes away, but it’s Inovelli’s intention to expose the buttons in the Edge drivers, eventually.

I don’t know what a button manager is or how to get it installed on smartthings. I’m not able to get the Z-Wave Association Tool to show up in my SmartApps on the smartthings app, so I fear I’m pretty far out of my league here. I’ll search for some tutorials on the subject. I’ve attached a screenshot of what my app looks like when i add a routine using the Red Dimmer Switch. Buttons right there to choose from.

Ok, so disregard trying to load a button app and you definitely don’t need the Zwave Association tool.

Can you post a screenshot or 2 of the process you are going through resulting in the screenshot you already posted? I can’t tell from just that screenshot how you got there. Want to make sure we are not thinking two different things for the same terminology.

Not sure if this will work, but here’s a screen recording of how I got there.

Random question as I was working through this one with @Bry offline.

Do you happen to have the Edge Drivers installed?

Reason I’m asking is bc I have the normal Device Handlers installed (ie: not Edge Drivers) and I’m not seeing the button presses like you are.

Ok, thanks. I was able to view it just fine.

The problem is after you select the pendant lights, you get this screen with the button options:


The problem is you should not be seeing that. It should look more like:

So the question is where is that coming from but it’s not correct?

1 - Are you using the proper Inovelli DH?

2 - Have you ever loaded the very beta Edge drivers?

I believe I’m using the correct DTH:

I don’t know what the “very beta Edge drivers” are, so I don’t think I’ve loaded them. This is the first time I’ve loaded a device handler, so maybe I screwed up, but I followed the directions on the Inovelli site.

My routine options look nothing like what you or Eric have, so something isn’t right.

That all looks correct to me. If you don’t know what the Edge drivers are, then that isn’t the issue. Those are under development for a transition down the road. They’re not ready for prime time, which is why I asked.

The only difference between your dimmer and mine is that you are on a newer firmware. (I’m on 1.47, you are on 1.57.) Not sure about Eric. I wouldn’t think that would make a difference, but who knows. @EricM_Inovelli may have some insight.

In the meantime, you could try using a button manager instead of a routine. The buttons are properly exposed there, although given what you are presently experiencing, it’s hard to say if it will work properly. Worth a shot though.

Can you manually set the LED color by changing the color of the dimmer light? Just wondering if it’s functional at all. Also can you post the ST Live Logging while trying to perform this automation?

Yeah, I did do the Smart Lighting Routines, but they are super buggy (as are regular routines I suppose). They will turn on the wrong lights or not turn on lights at all or take 20 seconds for the lights to turn on or turn some of the lights on and not others. That could be a smartthings issue, but seems wonky that a simple if>then statement isn’t executed correctly and efficiently.

So looks like i have an error when I set up the routine using the Smart Lighting app. Below is a capture of the Live Logging when I set up the routine:

I’d start there on the ST community forums or perhaps @EricM_Inovelli can translate that. That’s got to be the issue!

I can manually change the LED color in the settings of the device. No issue there.

1 Like

Agree with @kreene1987 . I’d wait to see what EricM says, then maybe head over to the ST community.

You definitely have a lot of weirdness there. I’ve been using both SmartLighting and the various iterations of routines/automations and they all work with very infrequent hiccups.

Have you done a Zwave repair? Not sure that will help but it can’t hurt to do some mesh maintenance.

I’d also consider excluding a switch and factory resetting it. Then add it back. See if anything changes.

Nothing quite like an, “Ambiguous Method Overloading” error, am I right @EricM_Inovelli?


Just a heads up, Eric’s out until tomorrow (Friday) so we’ll have to wait until then bc I have no idea what that means!

Sorry ST has been giving you some issues, I promise once you get the hang of it, your experience will be much better :slight_smile:

EUREKA!! I think… When I get to “Select Trigger>Button” it asks me “Which Button” and in there, there is the device button (e.g. Pendant Down Button) which I was selecting. This was not correct. I need to just select the device (and not the device button). So selecting “Pendant Lights” would then take me to the “Button Number” where I would use the “Button Mapping” to select the correct trigger. So, now everything seems to be working and I’ve been able to get the automations to run correctly without issue. Appreciate all the help here…don’t think I could’ve gotten it without all the input.


Nice! Glad you got it figured out.