LZW36 - Lights won't dim

I just recently purchased and installed a LZW36 hooked up a Hampton Bay Adonia (AG971) Everything is working great except for the fact that the lights won’t dim. I was wondering if it’s the bulbs however I’ve confirmed that they are dimmable (Philips 40W dimmable B12 base LED) and even tried swapping them out with other bulbs that I know dim OK.
I’ve tried dimming from both the local switch as well as SmartThings. The light doesn’t change at all, does dim, doesn’t buzz doesn’t shut off even if the dimmer is set all the way to 0. It’s as if the dimmer setting is being complete ignored.
I’m quite certain that it’s all wired correctly as the fan control works correctly and it able to adjust the speed of the fan.
I was wonder if it was something in the fan ‘switching’ mechanism that was interfering however I would expect that when the dimmer goes to 0 the lights should shutoff. Nothing.
Has anyone else come across this?

Settings changes
-Using VDS smartapp
-Dimming speed set to 0
-Disable physical on/off delay set to yes
-Light Notification 1 configured
-Create “Light LED” child device set to true

All other settings at their default -No changes to Ramp Rate/Min/Max light levels.

I don’t have a 36 so just guessing here. Does the light turn on and off OK, just not dim? If it neither turns off nor dims, make sure you don’t have local control (sometimes called local protection) disabled.

Yes lights turn on/off OK. Just don’t dim

Not sure there is a smart bulb mode on the 36. If there is, make sure it’s not enabled. Also check your minimum brightness setting.

EDIT: LZW36s don’t have a SBM.

non-smart bulbs. Just standard dimmable LED in E12 socket (x3)
Min Light Level @ 1 (Default)
Max Light Level @ 99 (Default)

You can disregard that suggestion. I was referring to a setting on the dimmer, but I’ve since confirmed the LZW36 doesn’t have that. Only the LZW31’s do.

Hey @j2johnson – can you share with me your IDE settings?

I just need the first section of the article (so I can see the parameters).

Key Parameter settings:

Name Type Value
debugEnable boolean
disableDebugLogging number
disableInfoLogging number
enableDefaultLocalChild boolean
enableDefaultZWaveChild boolean
enableLED1Child boolean true
enableLED1OffChild boolean
enableLED2Child boolean
enableLED2OffChild boolean
group2e1 string
group4e1 string
group5e1 string
group7e1 string
infoEnable boolean
parameter1 number 0
parameter10 number
parameter11 number
parameter12 number
parameter13 number
parameter14 number
parameter15 number
parameter16 number
parameter17 number
parameter18 enum
parameter19 enum
parameter2 number
parameter20 enum
parameter21 enum
parameter22 enum
parameter23 enum 0
parameter24-201a enum 1
parameter24-201b enum 10
parameter24-201c enum 255
parameter24-201d enum 4
parameter24-202a enum
parameter24-202b enum
parameter24-202c enum
parameter24-202d enum
parameter24-203a enum
parameter24-203b enum
parameter24-203c enum
parameter24-203d enum
parameter24-204a enum
parameter24-204b enum
parameter24-204c enum
parameter24-204d enum
parameter24-205a enum
parameter24-205b enum
parameter24-205c enum
parameter24-205d enum
parameter25-251a enum
parameter25-251b enum
parameter25-251c enum
parameter25-251d enum
parameter25-252a enum
parameter25-252b enum
parameter25-252c enum
parameter25-252d enum
parameter25-253a enum
parameter25-253b enum
parameter25-253c enum
parameter25-253d enum
parameter25-254a enum
parameter25-254b enum
parameter25-254c enum
parameter25-254d enum
parameter25-255a enum
parameter25-255b enum
parameter25-255c enum
parameter25-255d enum
parameter26 enum
parameter27 enum
parameter28 number
parameter29 number
parameter3 number
parameter30 number
parameter31 enum
parameter4 number
parameter5 number
parameter51 enum 0
parameter6 number
parameter7 number
parameter8 number
useVDS boolean true

Looking at what you posted. I don’t think the switch included properly. It should have paired S2, but yours did not. Also, possibly a result of not pairing properly, the Raw Description is all 0’s. I don’t have a 36, but that doesn’t seem correct. That being said, I don’t know if a bad pairing would cause the inability to dim via the switch.

While you’re waiting for @Eric_Inovelli to comment, you might want to consider excluding and re-adding the switch to see if pairing it properly solves your issue. You should be pairing it by scanning the barcode.

I definitely see why this is happening, thanks so much for posting the parameters. In this case, Parameter 1 is set to 0, which would mean that it’s mimicking an On/Off switch when you press it on.

Since Parameters 2-4 are set to copy Parameter 1 (unless they’re changed), this is why your switch isn’t dimming.

So, try setting Parameter 1 (dimming speed) to 3, which is the default and you should be able to have dimming back.

Yes, this is also an issue – nice catch @Bry! @j2johnson, you’ll likely want to remove/re-add this switch so that you don’t see all 0’s next to the raw data points.

Followed the instructions fully and it wouldn’t pair using S2. Smartthings app said it wasn’t able to pair visa S2 so was defaulting down to S0. Had the same problem when trying to pair a red dimmer switch I had purchased at the same time.
Running Smartthings hub v2 Rev E firmware 000.036.00005
Running Smartthings app 1.6.64-490

Something is wrong if you tried 2 separate devices and neither pair S2.

I’m on Android and my ST app is Not sure if the versions vary if you’re on an iPhone.

Not sure which instructions you’re following. Are you attempting to pair by scanning the QR code?

Thanks Eric. However I had to set Parameter 1 to 0 as the light was taking 4 seconds (default) to turn off and on while not dimming up or down so it seemed like nothing was happening when using the switch. I just set Parameter 1 back to default and confirmed that is indeed the case. Light takes for seconds to turn on after pressing the switch (no dimming up) and 4 seconds to turn off (no dimming down).
In terms of the device handlers I’ve linked directly with the GitHub Repo rather than copying and pasting into a separated local device handler. Any issues with doing that?

Yes. Tried scanning the QR code and after about a minutes the Smartthings app said S2 pairing had failed.

Did you exclude it from SmartThings? You can’t just delete the device from ST, you have to do a ZWave exclusion.

Also, did you check the Zwave signal strength?

What you could do then is set Parameter 1 to 0 again and then set Parameter 3 (ramp rate) to 3. This will allow the switch to come on fast (ramp rate) but allow you to still dim if you’d like.

In addition, what may help speed is setting a minimum dim level. How I normally do this is set the switch to maybe 15% and see if the bulb turns on. If so, try 10%, if not, try 20%, etc. Once you find that percentage where the bulb just barely comes on, set the minimum dim level to that % number.

Lastly, if you have the ability fo acquire a Z-Stick and want to update the firmware, beta version 1.36 gives you the ability to remove the 700ms delay for a more instant on.

Did an exclude and re-pair. S2 worked successfully this time. No change to the issue.
I had performed the strength check at time of installation which was green. Performed it again, still green.

1 Like

Hi Eric,

I’m struggling to see how this could be a ‘settings’ issue. When I use the rocker buttons beside the light button I can ‘dim’ down all the way and light doesn’t change a single bit. Same behavior when controller remotely from Smartthings. To me this would imply that the issue is with the canopy module itself (not dimming) or somehow the fan itself it blocking the dimming. But I’m not sure how that would be possible. Lowering power from the line level to fan should result in the lights dimming… which really gets me wondering about the canopy module.
I understand your suggestion around the ramp rate but that wasn’t the motivation for setting Parameter 1 to 0. The motivation is because the light actually isn’t dimming. I can watch the LED bar beside the light button decreasing as it’s ramping down but the light isn’t dimming. The light doesn’t actually change at all until it’s completed it dim down ramp rate and then goes from fully on to fully off.