LZW42 Bulbs Slow to Respond and Slows Thing Down in SmartThings

I have 11 LZW42 bulbs and individually they work great! I use SmartThings, have the latest Device Handler from Inovelli, and have repaired my ZWave network.

I’d like to change the color of all them at once. However, it never seems to work consistently. I’ve tired a scene approach and it’s spotty which ones update. I’ve also tried creating a script in WebCore and again, never fully works. I’ve noticed that once I update the color of a few bulbs, the whole network seems to get bogged down and future commands tend to be very slow (for ANY device) sometimes. Anyone got any tips/tricks/solutions?


lmk if you find a fix, i also have the same prob ive got about 20 bulbs… turning them on and off works great and controlling one bulb at a time works as well but when i try to controll multiple bulbs my whole systems just gets overwelmed… (currently on HUBITAT) They would change color once then to change to the next color or accept otger comands it take minutes if it even does it at all… a ive gotten as a response is to update the drivers ect wich i already have…

Bumping that thread up, as I’m experiencing the exact same issues.

Do you have any non-plus Z-wave devices on your network? These can degrade your network performance - think using a fire hose (plus) vs garden hose (non-plus) for communication.

It can take time to change a lot of devices at once regardless, but having a strong mesh will reduce that time.

Yes I do have a mix of plus and non plus devices, but the bulbs are connected directly to the switch as the hub is quite close. For clarity if you send several colors commands it may takes minutes for the light to react…

The mix of devices is likely causing your problems, as your mesh ultimately performs as well as the weakest devices.

Just because the bulbs are physically close to the hub, doesn’t mean the hub is communicating directly to the bulbs. It’s ultimately up to the devices to determine what items are close to what, and those determinations are used when sending commands.

I’m guessing you are referring to direct association? This connection is only used when physically interacting with the switch, and is limited to turning the bulbs on/off. If you are using a dimmer switch you can dim the bulbs as well. Anything else still relies on your hub and mesh.

I’ve got five bulbs directly associated to a dimmer for example. They turn on/off and dim beautifully, but if I want to change the color there can be a small delay for some of the bulbs (<1 seconds). That’s because the color change command comes from the hub - not the switch itself.

I know this isn’t likely the answer you want to hear, but I do hope it helps some. If you remove the non-plus devices from your network, and repair your mesh a few times it will likely resolve the performance issues you are seeing.

1 Like

Truly appreciate your feedback!

In my previous post, I meant to say that the bulbs are connected directly to the hub (not the switch), as shown in IDE - devices. In other words, it doesn’t appear that the bulbs communicate through any other devices. When I said it is slow, I’m not talking about few seconds, I’m talking up to 30s for some of the bulbs.

Bumping this one up and tagging @Eric_Inovelli and @EricM_Inovelli

What would you like to know?

@Eric_Inovelli as the OP indicated, controlling multiple bulbs, either via ST scenes or WebCore, is slow. In my case, I have 4 bulbs, and built simple scenes and WebCore pistons to change level and color temperature/color. When running them, it take a minimum of 5s but up to 10s for all bulbs to adjust. Is that the expected behavior? if not what troubleshooting steps are you recommending? Thanks!

FYI, I upgraded the firmware (Firmware v2.30 (Beta) | LZW42 | RGBW Bulb) and performance has greatly improved. Still doesn’t work 100%, but if I run a scene twice I can get all the bulbs to successfully change colors.

1 Like

Thanks for the feedback. I’ll definitely consider upgrading to the latest firmware. What firmware were you running before the upgrade? I believe I’m currently in 2.28.

Can’t check now because I upgraded them all, but yes, that sounds about right.