Multitiap not working in Smartthings

I successfully installed my first Red Series Dimmer earlier this week, installed the device handler successfully, and created a couple of Smart Lighting Apps in SmartThings. This switch behaves as expected. I have since installed two additional switches and assigned the device handler. Both switches work for local control and are connected to SmartThings. I can turn them on/off through SmartThings, disable local control, etc. However, neither of them will perform a multi-tap function. I have included some screenshots. The Master switch is the one that works properly while Pendants and Theater do not. I have highlighted some differences between the installations. I am not sure why these differences have occurred as I did everything the same. Also, any trick to getting a secure connection?

Thanks in advance!

Not completely sure this is causing the failure of the multi-taps, but a couple of things that should be fixed nonetheless:

  • The Master switch is routing through two unknown devices before it gets to your hub. I’m surprised you have Zwave control of that switch. These are likely ghost devices and should be removed. Run a Zwave repair on the hub and remove them. Then run another repair to clean up the routing.
  • You should be adding the devices by scanning the barcode. Add device, Scan QR code. It does not appear the devices have joined properly. If they are joined propeerly via the QR code, then you should see ZWAVE_S2_AUTHENTICATED.

Hey @gbwhitson – Bry is definitely onto something. I’d follow his advice first and then also you’ll need to unpair and repair at the very least the Pendants and Theater switches as they all have the following Raw Description:


When it all shows 0’s, it means it wasn’t paired properly. Could the ghost devices interfering as @Bry mentioned.

Sorry for all the issues!

1 Like

I have run the repair and it does not have any ghost devices listed. It failed to update the route on the Theater and Master switches and there is not any info for the Pendant switch.

The Master switch now has a new route with another unknown device though.

I know the Pendant and Theater switches were added by scanning the QR code. I open SmartThings, add device by brand, choose Inovelli, press the config button on the switch 3 times, it connects, then ask to scan the QR code.

Thanks for your help! None of this seems like it is difficult but it doesn’t seem to want to do what it should.

Go into the IDE and look for whatever has Device Network ID 18. If it doesn’t look like it belongs there, delete it.

You are going to have to remove and re-add your devices. Please try the steps that I suggested. That’s not what you are doing.

Once you have added a device, look at the raw description. It should look like this for a LZW31-SN:

If mfr, prod and model are all zeroes, then the device has not added properly.

Make sure that you have removed the devices before re-adding.

I do not have a device with a Device Network ID 18. Here you can see all of my devices and that I have removed all 3 switches. I also did a factory reset on each switch after removal.

To re-add the Master switch I’m selecting the “+” in the top right corner in the SmartThings app, choosing “add device”, choosing “Scan QR code”, then scanning the QR code. I then get this screen which I choose “Start”.

Which brings me to this screen:

After a couple of minutes I get this screen.

After hitting “Start” I have tried both pressing the config button 3 times and not pressing it 3 times and the result is the same. I hit the “Get Help” link on this screen and confirmed the green light on the SmartThings hub is flashing green when trying to connect. The hub is only 10 feet from the switch so that shouldn’t be an issue. I rebooted the hub from the IDE too. I also did a detect z-wave signal on the switch by holding the config button for 5 seconds and the light stays green. After this I attempted to add the switch again. It did add this time like this:

Had to make two posts as I could only add 5 images to a post

I applied the device handler and now have this.

Still not giving me ZWAVE_S2_AUTHENTICATED and still all 0’s for raw description. I really appreciate the help and hope I did everything as you suggested.

Hmmm, you did everything in the proper order and I agree it still didn’t add correctly.

When you got the “get your device ready” screen and pressed config 3x, did you see an indication on the LED? From memory I can’t remember what the color is that should flash, but you should see something acknowledging the 3x press.

If it doesn’t look like you are receiving an acknowledgement, try pressing 3x more quickly. You can also do it more than once just to “make sure”.

Let’s try this. Remove a switch again and factory reset it (config long press 20 sec plus).

Then do a Zwave general exclusion. From the app, open the card for your hub. If you go to the Devices page, it will be in the “no room assigned” room, probably. Select the 3 dot menu top right and then Z-Wave utilities. Then select Z-Wave exclusion. Once you do that do a 3x press on the config buttion.

I can’t remember if the app will tell you the device was excluded. You can also do it from the IDE by selecting the hub, View Utilites, Z-wave exclude. Feel free to do it multiple times until you are convinced it has been excluded.

Then try to add it again just as you described above.

Another thought. Make sure you are scanning the proper QR code. Since you’ve been working with three switches, I suppose it’s possible to get them mixed up. To remove any doubt, use the QR code on the front of the switch you are adding.

Yes the lights pulse blue then eventually turn red. When I try to pair I always press config 3x, let it fail, then press config 3x again. I also do the whole process a second time.

Is there a certain process I should be following to remove the switch? I have been deleting it from the IDE and then doing a factory reset.

I have attempted this previously and it has also failed which is why I have been deleting from the IDE. Once I hear back on the removal process I will try this again.

I don’t think this is the case as I opened the switches one at a time and labeled the QR code inside. However, I will remove the faceplate next time just to eliminate another variable.

That’s fine, particularly followed up by a factory reset and then a general exclusion.

When you say the factory exclusion failed, does that mean it just didn’t find anything to exclude? I think I would try it by not deleting the switch in the IDE and just doing the general exclusion first. That way it has to find the device and exclude it via a general exclusion. But TBH, the way you have been doing it should be fine.

The red part is the switch recognizing that it didn’t add properly.

What version hub are you running?

Also, can you please post a wider screenshot showing all rows and columns of your IDE? Thx. And then post another screenshot of the switch you just added if it looks like it failed (when you do it again scanning the barcode on the switch).

I did the exclusion from the IDE and the switch successfully excluded. The light on the switch turned green and it is now gone from the IDE. The switch successfully factory reset. Held down config for 25 seconds until light turned red, released config, and got 3 red flashes.

Added the switch back selecting the “+” in the top right corner in the SmartThings app, choosing “add device”, choosing “Scan QR code”, then scanning the QR code on the switch, then selecting "Start” on the next screen. I hit the config button 3x on the switch and it pulses blue. It failed the first two attempts but the light turned green and it connected the third attempt. However, I got this screen:

From the IDE I have this for the switch. I had not applied the device handler yet in this screenshot. I also do not have an of those ghost devices listed as you can see below.

My device list from the IDE:

I am using the newest Aeotec Hub (V3) with firmware 000.039.00006 and z-wave protocol 6.04. The IDE says Z-wave state is functional

My best guess is that those ghost devices are wreaking havoc on your Zwave. I know you said you ran a network repair before, but it is clear that there are at least 3 ghost devices on your network, 02, 32 and 0E. Previously you also had 18. I would remove all of those from your network (guide above … you have to create them as fakes and then delete them via the IDE).

If you look at the routing for the switch you just added, after trying to route through ghost devices it’s trying to go back through itself, which I have never seen.

I don’t think you’re going to have any success until you get your Zwave cleaned up.

Another thing I noticed … Did you install the proper Inovelli Device Handler? Your dimmer is typed as a Z-Wave metering dimmer and is running locally. It should be typed as a Inovelli Dimmer Red Series LZW31-SN and execution should be in the cloud. This shouldn’t prevent the switch from installing properly but I’d still have the proper DH in place first.

I added the ghost devices. In the previous IDE screenshot I had not changed the switch type to the DH yet. I believe it should do it automatically but I have had to do it manually every time. The screenshot below shows the ghost devices and how the switch shows up after I change to the DH.

Here’s a pic of my Device Handlers:

I was able to delete ghost devices 02 and 32 from the ST app. However, when i try to delete OE I get this error every time.

Try it from the IDE, preferably from an incognito session.

I was able to delete 0E from the IDE in incognito mode. I went ahead and excluded the switch again and ran a z-wave repair.

Here is my events log from all of that. You can see the last two fails to exclude 0E, where I successfully excluded the switch (10) and then the z-wave repair. For some reason there is no record of me deleting 0E from the IDE.

and my device list after all deletes and the repair:

Should I attempt to add the switch again at this point? Thanks again for your help!

Yep, try it again. Factory reset it first. Then do the general exclusion (run general exclude and hit 3x on the config button). Use whichever (IDE or app) shows you the excluded device count . . can’t remember which it is.) Then add using the QR code on the front of the switch.

After several attempts it finally connected. However, I am still getting this error:

It still wont connect securely but this is the first time that it has automatically applied the DH. Here is the device list:

It is also still routing through the 0E ghost device which I was having trouble excluding.

I assume at this point I need to figure out how to get rid of 0E?