New Hubitat C-7 and inclusion problems

There are reports on the Hubitat forum from early recipients of their new C-7 hub that there are Z-Wave inclusion problems with certain Inovelli dimmers and possibly switches:

@bcopeland was able to reproduce it, so hopefully there will be a permanent fix instead of his workaround at the above link.

If you have a working Hubitat setup and a new C-7 on order, you may want to give this a week or so to shake out before opening the C-7 box…

1 Like

Nice, thanks for posting – we’ve been getting tickets on this issue, so I will direct them to this link!


Mine should be shipping this week, so hopefully I can test; however, I planned to migrate from C5 to C7 so…it may not have an issue?

That same thread has a comment about the Inovelli created drivers not supporting S2, now that the latest hub support S2. I haven’t tested it, but did want to call that out in the event that the drivers also will need to be updated to facilitate them joining with S2 (once this other bug is also resolved).

1 Like

This is not a solution … But a temporary work around.

Include with all security keys unchecked

When it gets stuck on initializing…

  1. go to settings -> shutdown
  2. After your hub’s red light comes on power cycle the hub
  3. Log back in and go to settings -> z-wave and then click on discover on the node with no description. Then hit the config button 3 times on the switch

I’m not sure why it seems to be picking on inovelli but we are working on it.


Hey that’s my thread! :slight_smile:

FYI, I was finally able to get them all to pair. Was tedious, but thankfully I was able to get them all added.

1 Like

@EricM_Inovelli - Any updates about driver supporting S2? Or am I misinterpreting it? I’ve excluded/factory reset all my Inovellis and am trying to add them as S2 to the new C7 hub. It’s not asking for the authentication (well it asked once on the first one, but I didn’t have my card so I had to cancel it).
Edit: this may be a hub issue? @bcopeland - I’m just trying to understand the issue and am more than happy to wait for a fix, but just wanted to understand what is causing the issue. I’ve read the community page and it gets a little off track. It seems some people want S2 support, and others don’t. What I’d want is to include the switches in S2, but if I have to go S0 route, is there an easy way to upgrade to S2 without re-including. It’s a pain to setup include and set up the rules again.

This can only be done during inclusion based on my reading. I tend to create virtual “clone” devices and target all the rules to that, work on my device, and then restore them when done. That can be easier than rebuilding everything.


If you want to move between different security “levels” in Hubitat (or any Z-Wave controller), you’ll have to re-pair. The next hub firmware version, 2.2.3, will introduce some changes that make it easy for developers to work with devices that are paired with S0 or any S2 level, and a quick look at Inovelli’s driver suggests that it would be pretty easy for them to adapt to this (just a modification of their commands(Command cmd) method that they already wrote for a similar purpose), though it’s possible there is more to their code than I understand. It’s possible for a driver author to do this somewhat manually even with the current hub firmware, but I’d wait until the platform methods are available in the next release personally.

In the meantime, Hubitat has built-in drivers for most Inovelli devices now, and those drivers work fine with S2. Alternatively, with Inovelli’s drivers, the devices could be included without S2 or S0 by unchecking all options during pairing (actually, S0 probably would work, but there are lots of reasons I wouldn’t use it here). If a device isn’t including properly (as opposed to just not fully functioning afterwards), e.g., it gets stuck on “initializing,” then that is unrelated to the driver, and the steps Hubitat staff outlined (as Bryan did above but you can also read on the Hubitat forums) to help may work around it until they are able to identify a fix.

In my testing, the current-gen Inovellis always asked for a key when pairing. If yours eventually stopped, I’m not sure why, but it seems unlikely to be related to the device since they should always request S2 if they support it (and there is no separate pairing procedure, like pressing the buttons differently, for S2 vs. no security like I’ve seen on most S0 devices). :thinking:

1 Like

Going to try to get the S2 drivers out today. The built in drivers currently work though right?

@EricM_Inovelli - Yes the integrated S2 drivers are working; it’s been a pain and I have only been able to get about 13 switches included since I have to restart/shutdown the hub every one to two inclusions. Quite ridiculous to be honest. I’ll continue to work on a few everyday until I can get them all included. It wasn’t just stopping on Inovelli. I have a few Jasco switch outlets that it would hang up on too during inclusion that required a reset.

Joining them using S2? or still NO security settings? I’ve been waiting to start my migration to my new C-7 until after this is fixed…

Also @EricM_Inovelli, slightly off-topic. I thought I read somewhere that Inovelli 1st/2nd gen switches are capable of beaming? Is that still the case? Thinking about adding a few locks/deadbolts…

@harjms Sorry about that man! We don’t have any problems with inclusion / S2 inclusion on SmartThings, Ring, or PC Controller (the hubs that have S2 that we can test) so I don’t think it is a device problem. If there anything that we find out that we can do though we will help where we can.

@Ma2J Yes, they are capable of beaming.

1 Like

Hmmm…so most of them were joined with all the boxes “unchecked”. I attempted on a few with only S0 unchecked, but S2 unauth and auth checked. However, I think I ended up excluding that those and going via unchecked on all boxes. The security key was then presented by Hubitat with all the blocks filled in. It selected the S2 drivers automatically. Is there another way to see if it included with S2?

@EricM_Inovelli - Yea I think it’s a C7 Hub issue that this point. If it doesn’t include it all the way, the Z-Wave stops responding to any issued commands until a reboot. For example, I tried including a switch, but it got stuck at initializing. I continued on and tried to control a few of the devices while I was waiting for the device to do something. I couldn’t trigger any switches on or off until I rebooted the hub. My C5 hub never had this issue during inclusion.

I have my C7 Hub at home, but I have put it on the bench until the inclusion topics are addressed. Also want the Inovelli S2 drives too so lets see who wins…

1 Like

Yes, under the “Device Details” section on the device page, look at the “Data” row in the table. If it’s securely joined in some fashion, you’ll see “zwaveSecurePairingComplete: true”. If that is there, you may also see an entry for “S2” with one of a few different values. The fact that is is there does not mean it’s S2; if you see “S2: 128”, it paired with S0. If you see a different value, it is paired with some level of S2, though I don’t know off the top of my head what corresponds with what (I see 129 for a device I know is S2 Unauthenticated and 131 for a device, a Red switch, I know is S2 Authenticated; I think the exact value depends on which particular combination of grants you selected).

Note that the above applies to a C-7; the C-5, of course, does not have S2, but I also don’t remember if or what you’d see for the “S2” device data for an S0 device (my guess is the above or nothing, just “zwaveSecurePairingComplete”) , and I can’t check since all secure devices are on my C-7 at the moment. :slight_smile:

1 Like

Looks to be a mix just quickly looking at a few of the devices. Thanks for informing me where to look. I’ll look at repairing the devices that didn’t make the cut, but Hubitat gonna need to fix the inclusion issue.

Eagerly waiting on the S2 drivers :smiley:

I have put 10 LZW31-SN and 3 LZW30-SN on the C7 and I have never gotten any of them to pair with S2. When S2 options are selected in SmartStart, they don’t even show up as attempting to join in the logs.

I have left the S0 option checked a few times for testing and it claimed to work, but none of my S2 Z-Wave devices on the C7 advertise zwaveSecurePairingComplete.

It is my belief that the inclusion bug (or the workaround) in the C7 prevents the switches from secure inclusion.