New Params from 1.47 firmware not shown

Hi, I’m new to zwave and Home Assistant. I recently installed three Inovelli Red dimmers in my new house. I can query the nodes from HA and determine the firmware is 1.47. I noticed in the release notes that 1.47 includes two new params, 51 and 52. However, I don’t see them in the HA zwave configuration tool. Why is that? Hoping to increase my knowledge here. Thanks.

Right, so I’m wondering why those parameters are not exposed in the HA control panel where I set params. Is this an HA configuration issue or am I missing something here?

Do you have the latest driver?

Thanks for the reply. I went ahead and updated that XML file. Didn’t seem to make any difference when I rebooted. Unfortunately, now I’m dealing with zwave issues. Some of the switches frequently report as dead. I’ve already reset the controller stick once in Windows and re-set it back up. But then when I rebooted HA, 2 of them died again and after trying all efforts to fix them, I think I’m stuck having to wipe the controller again and start over if a factory reset doesn’t work.

A little dismayed at how fragile this zwave implementation in HA seems to be for me. Was expecting something more reliable than Wifi. It doesn’t seem to be a range issue as all the devices always report they are in range, and a working switch is in the same gang box as a problematic one.

How big is your network and what devices? I switched to the OZWave implementation and it’s worked exactly as expected with the switches. All the parameters show up. No messing with config files. It seems daunting to use and they are calling it a beta but it’s already way ahead of the outdated build-in implementation in many ways.

I just started with 3 Inovelli Red’s. I have about 2400 sqf. Hub is upstairs running on a Nortek combo stick. Switches are downstairs. I’ve had problems with all of them going dead at least sometimes, but the most problematic one is actually on the same gang as another one.

As an update, I spent 1 hour before bed last night trying to revive all of the nodes after rebooting HA. I was unable to revive that last one. I went to bed, and 7 hours later when I checked, it was still dead, but when I hit ‘test node’ it immediately came alive pretty much instantaneously.

So, I guess there is a learning curve to zwave and how fickle or sensitive it can be. I didn’t realize that by placing it in my HA along with the rest of my server, I’d be introducing so much instability to the zwave network from going up and down. May have to rethink things and toss the hub in a old NUC I have lying around instead of in my docker server. Unfortunate.

Also would consider upgrading to the beta OZW because I think it runs in another container and would be prone to no restarts when I restart HA. But halfway through setting up MQTT, I stopped, and figured the wiser course of action would be to use the native integration and not try to be cutting edge. Maybe I was wrong and I should pursue that again.

I have 2 more Red switches coming thanks to some switch loops I discovered in my house that require a no-neutral installation, so maybe that will make the network more stable. Other than that, I don’t have any immediate plans to install anymore zwave devices. I built my setup to just pick the best device for the job among wifi, zigbee, and zwave. I’ve had no issues with any of my wifi devices; I have an Eero Pro setup.

The devices have a test to check the signal strength. Hold the config button for 5-10 seconds. LED will flash red or green. Did you try that test?

Still, use the OZW beta. It works better for zwave and HA works better without the old zwave integration running in it. Post if you have any questions and I’ll try to help.

Are you using the HA Core docker container?

Thanks @PJF. I do run HA from a Docker container alongside other Dockers on a server with a combo Zigbee/Zwave stick. I realized somewhat after the fact that the OS image version of HA has clear advantages with regard to the addon store and installations like this. I do have a NUC lying around that I could use in an emergency, but I’m right now challenging myself to see if I can make it work with just the docker container.

The light will typically flash green showing that it is in range. Right now, all 3 switches are alive and well, but I fear that if I were to tinker with HA, which is a constant need, given that I just started with it, and most functionality requires a restart, then I will have 1-3 dead nodes on my hands again, with no recourse other than to wait several hours and hope it fixes.

Given that, I will look into starting fresh with the OZW beta since you have vouched for it as being better for my use case. I’ll give it a go this weekend and see if I can find a guide. I know it involves setting up 2 more dockers, which I’m comfortable with.

1 Like

I started with it on a Pi and moved it to unRAID and just don’t miss the supervisor or store at all. To me, it just added complexity that made it harder to work with. Using my unRAID server works way better for me. To me, I can access the HA volume way easier.

The HA Store stuff available via the supervisor seems to be mostly Docker containers you can run on your server without needing the supervisor to install. I’m running some of the stuff that is available there just the same - Node Red, ESPhome, MQTT, Hass Configurator etc.

Doing some reading, it seems the supervisor version of OZWD and MQTT are limited in the setup compared to running them as their own containers. I don’t know about anyone else but it seems better on unRAID to me.

Run the OZWD and use the separate OZW Daemon Admin tool on your PC to control it. It works better than the all-in-one container with the admin tool included in the container.

1 Like

Ooh I’m glad you posted this as I have Linux VM as my server and all-in-one right now. I didn’t realize all of the docker packages could be run concurrently and connected. Seems like a “better” solution.

I wonder if I have come too far and would need to start from scratch again or whether a backup/restore could work from Linux VM to docker…

Have not had a chance yet to experiment with the 1.6 OZW beta. But good news is that after adding 3 more Inovelli’s for a total of 5, my zwave network seems to have become exponentially more resilient and I have not had a dead node since and after multiple HA reboots.

5 really is the magic number it seems. I had a few issues until I met that same exact number.

FYI, I was able to resolve the original question in my post. Didn’t realize how OZW and HA worked before. I had to add those parameters directly to the xml for the active switches while HA was shut down and now they appear in the interface to be edited.

Now if only I could figure out how to disable local relay in HA. I read a post saying that this value is exposed in “Node Protection” section but unfortunately my values aren’t what was expected. These are the values for Node Protection:

Still using the built-in Zwave.

The OZW beta has the proper parameters for that too. I saw that post yesterday and checked to see.

Not to kick you again, but everything is just there and all works without jumping through any hoops.

Didn’t realize this was impacted by the OZW version. Will tinker around this weekend with setting up an MQTT docker to give it a shot.

Yes even though 1.6 isn’t FULLY integrated into HA UI yet, it does seem to be more “current” and able to “Just Work™” way more smoothly than 1.4.

@chadbaum How did you get existing devices to show the new config parameters. I am still having the issue where even though I replaced the xml file with the new one, the parameters are not showing up in the Node Config Options. I am not sure if it is because of browser cache or zwave not picking up the new file somehow. What xml file did you edit for existing devices to get the new parameters?

Also - Even though I updated my switches to 1.48, it still shows up in Node Information still shows at 1.35. That could just be a different issue with home assistant only setting that value when the node is discovered.

where the heck do you see the parameters in the ozw beta? I recently switched to the beta but cant figure out where to get the parameters.

I was working the switch over this afternoon also. I can see the parameters but I can’t figure out how to set them. I went to Configuration -> Integrations -> OpenZwave (Beta) Configure Button -> Nodes “At the top Row” -> Select your Node. At the top, select Config and that shows all the config parameters.

Now, let me know if anyone figures out how to set these. Not sure if I am going to revert back to native zwave or not.