Office Setup Help - 1 red dimmer, 2 ilumin RGB bulbs ceiling, 1 ilumin RGB bulb lamp

Hello,

Getting closer to what I am looking for in initial setup but am lost what to do next.

Setup - 1 red dimmer directly connected to two ilumin RGB Bulbs and then one more rgb bulb as a remote lamp.

Basic Goals-
(1) Dimmer controls the on/off functionality of the bulb and dimming functionality of the bulbs
(2) double click push/held controls the on/off functionality of the lamp
(3) “Hey google set the office dimmer to blue” turns the two ceiling bulbs to blue

image
Dimmer options - ramp rate is also set to 0


Dimming speed is set to 0 for all bulbs

image

(1) using the switch it does turn the lights on and off, but I have no dimming functionality so not sure what I did wrong/what I still need to do to get the light dimming synced with the dimmer


(2) This rule worked really well before I switched my bulbs from dumb bulbs to the smart ilumin bulbs. The commands still work, but now the time to execution is ridiculously slow (like 10 seconds until on executes) is there another setting on the dimmer I need to change?

(3) Is there anyway I can get the dimmer and the two bulbs to be considered 1 device when pushed over to google home, do I need to create a group? I want to have one device name that I can tell google to set the brightness or color to and will impact my dimmer switch and the two ceiling rgb bulbs all in one

Thanks for the help!

I’m not a Hubitat guy, but I noticed a couple things I think you need to tweak to get started.

Did you disable local control on the dimmer? You didn’t post that setting. Smart bulbs need to be powered 100% of the time, so you need to insure that you are not turning the bulbs on and off by the wired connection of the switch. I suspect that the switch is physically turning the power to the bulbs on and off, which is incorrect. It’s not dimming because you turned on smart bulb mode (which is correct), which insures that 100% power is always provided to the bulb.

So disable local control on the switch so that you never cut power to the bulbs. Same thing for the lamp, turn it on and do not turn it off by the switch on the lamp.

Now that the bulbs are powered at full power 100% of the time and can’t physically lose power, you program the on/off and dimming via direct association for the bulbs and some sort of scene for the lamp. This is where the Hubitat users can help.

(Topic 1 reply) Ok I disabled local control now, button 1 does not work anymore which I think is by design. I could update my rule to turn on an off the ceiling light, but shouldn’t the association also take care of that for me? I feel like the association is not working at all and not sure why that is.

My lamp is plugged into an outlet that is always on so I am good on that one.

Correct. When you disable local control you are disabling using the switch to turn the power to the light on and off. So that is expected.

So yes, now the associations should take over and they are not working correctly. A Hubitat user will have to help you with that.

@Eric_Inovelli any help with this one? Reading from this other thread Red Series dimmer not dimming Ilumin bulbs my issue is probably dealing with the security levels. Just wondering if there is any knowledge base articles explaining exactly what security levels we should set stuff to and how to change it after the product is in Hubitat? When excluding and reincluding my bulbs I cannot get the prompt to show again.

Then hopefully after getting the association to work I am thinking maybe my questions for (2) or (3) will resolve themselves or become clear how to resolve.

p.s. I hope the meeting went well!

The security associations have to match. So if the bulbs include as S0, then the switch must be S0 in order to control the bulbs. If the bulbs included as none, be sure the switch was included with none. The bulbs don’t prompt for security. The easiest thing I managed to ensure the bulbs included at none level was to pair it far away from the hub because it’ll default to none if it can’t link securely to the hub. (If that makes sense)

For 3) You can create a group with just the bulbs are in (bulbs 1, 2, 3 etc…) in Hubitat then link that to be controlled via Google Home. For instance, if lamp A had 3 bulbs, I could create a Group with those three bulbs added and call it Living Room lamp. Then I would just expose it to Alexa (I run Alexa, no Google) and tell Alexa to turn on Living Room lamp. It turns on all three bulbs.

Thanks for your reply I will provide screenshots I have seen others post but not really sure what I am looking for just so you know what states I am at current and can help get me to where I need to be.

Red Dimmer


Also I thought I did the firmware update but it still says 1.47 so not sure I did that correct or if that even matters?
image

Bulb 1

Bulb 2

Have no clue what i did different for the last bulb since the other bulb has the S2 line so I assume it is S2??? This whole security topic is one I haven’t found a knowledge base article to explain to me what to do.

And sorry not sure what you mean by far away from the hub, my office (2nd floor) is probably the farthest away from the hub (basement) as can be already

(3) glad to know I was on the right path with groups!

Inovelli bulb will only support S0, not S2. Go to Z wave details and look at the devices listed. Easier to see.

Found “Z Wave Details” under left ribbon “settings”. What do I need to do next? My dimmer is at none so do I need to get Office Bulb 1 to None? and if so how do I do this?

Maybe dumb question, but is having security of none a concern??

For my setup I eventually got it to work by having the bulbs and dimmer all set to S0 for security. For the dimmer I had to exclude and reinclude it, ensuring at the security prompt I deselected the S2 options and left the S0 option checked. It was a very variable process, sometimes the security screen would show, sometimes it wouldn’t, but with a combination of hub reboots and such in between attempts it eventually let me get to that point.

Ok so I just need to keep trying then since I tried once and it didn’t show. You said I should get everything to S0. So for me that means I need to get my Office dimmer and Office Bulb 2 to S0 correct?

@Eric_Inovelli @EricM_Inovelli can we get the habitat instruction manuals to notify others to uncheck the S2 options so others don’t have to go through this game of chance excluding and reincluding to get associations to work. I didn’t even see that prompt mentioned at all and hubitat says don’t change so I just clicked continue.

Maybe if you live near black hats. Originally I thought I’d care about it, but I’m less caring about it since I mostly have lights on z wave.

It’s really up to you.

To close the loop on this topic if you want to pair an ilumin bulb with an inovelli switch using z-wave associations you must ensure that all devices are at “S0” security level. When including the device on hubitat and presented the following screen, uncheck all “security 2” options so the only checked box should be “security 0”. Then for switches you must ensure the first five digits of the code presented on another screen match that of the code provided to you in the box (or on the switch itself on the sticker on the bottom front, for me the correct five digits were prefilled.

image

1 Like

Thanks for this. I have added a note to the top of the Hubitat association page. Hope you don’t mind that I used your image.

Actually I grabbed it from a different post haha.

Is it possible to add S2 support to the bulbs via a firmware update?

I will admit this may be completely false but I will repeat what I have seen from other post on here, the bulbs do not have the correct chip hardware in them for S2 and the manufacturer does not have enough demand nationwide for the current chip to even consider spending the resources to start production on a newer chip, 700 I believe.

The current bulbs are using the 500 series chips, which at least for the switches do support S2. My understanding is S2 support was optional under the 500 series, but is required for the 700 series chips.

I’m assuming the “bulb” specific 500 series version supports S2, and it simply wasn’t added to the firmware.

I know we aren’t getting a 700 series version of the bulbs, as the Z-Wave chip purchase requirements are crazy (Like 1 million chips). That said we can always hope for firmware updates to current bulbs to add functionality.

Here’s a nice comparison table of the Z-Wave Series - https://aeotec.com/z-wave-home-automation/z-wave-700-series.html

https://www.digikey.com/en/products/detail/ZGM130S037HGN2/336-ZGM130S037HGN2-ND/10642892?utm_campaign=buynow&utm_medium=aggregator&curr=usd&utm_source=octopart

Just over $6/chip for 1000 chips. May be an option with bulk quantities from distributors.

Maybe a limited run of bulbs?

1 Like