OTA Update Target 1 Failure

I’ve been struggling with getting Target: 1 Firmware upgrades working. It either stalls out after a few seconds and never finishes (the blue blinking light quits too), or I get the following error.

I’ve tried directly connecting to the switch via Z-Wave PC Controller, and I’ve tried upgrading through Smartthings as a secondary Controller. Both have the same outcome.

Any ideas on what I’m missing?

A couple things to try using the PC Controller Standalone. I haven’t had luck with the ST blended approach:

  • Make the computer is close to the dimmer
  • Patch from a local copy (you’re mapped, maybe?)
  • Try changing the fragment size. It may be a function of the file size. See this post:

Did you have any issues flashing Target 0? What usb stick are you using?

Target 0 flashed without issue (Twice, as I did the 1.57 & the 1.61) Updated a few Red Series On/Off with no problem as well. Just seems to be related to target 1.

I’m running the Nortek HUSBZB-1 Z-Wave/Zigbee combo dongle.

If i change the chunk size to 20, like that post, it runs 150-200 of the 700ish packets, then just stops, and the switch stops flashing and it’ll just hang forever.

I might try flashing Home Assistant onto a spare Raspberry Pi and setup Z-Wave JS to do this update this evening…

That was a good idea, just tried downloading a fresh copy locally, same issue.

Once target 0 updates, it takes about 30 seconds to get rebooted. Make sure you are waiting (sounds like you are).

Pull the air gap, click then “get info” button and ensure it reports, then try target 1.

Very strange, sorry it’s not cooperating. I used the same USB stick and the pc controller software a couple months ago to update the otz and bin files for all 20+ of my red summer switches and didn’t have any issues on my end. I’m sure you don’t want to exclude and then re-include the switch but I suppose that is a last resort…

Heh… Well I think I got it. After a little percussive maintenance I seem to have solved the issue :smirk:

Loaded up with no problems afterwards.

Sometimes you really do need a bigger hammer.

Thanks for all the ideas!

1 Like

Besides the hammer, what got it working?

Honestly, after trying everything from Un-joining it, factory resets, directly connecting from the computer to the switch (not on the same Z-wave mesh as SmartThings), tried upgrarding through Zwave JS in HA… I took the dimmer out the wall, slammed it against the counter about 4x. Hooked the power back up. Joined it to the SmartThings network (S2), and tried one last time, and it uploaded no problem. I’m giving all the credit to percussive maintenance.

However, I do notice on the other Dimmer Switches (that I didn’t beat up), the “Minimum Level” is not working in 1.57 & 1.61. So that sucks, but livable.

1 Like