Red Series Dimmer flickering intermittently

I have 3 lights in our house that flicker. It’s very intermittent. For example the light could be at 70% dimness for 5 minutes and stable then suddenly a small hiccup and it flickers once, then good for another few minutes.

I tried upgrading to firmware 1.61 and didn’t resolve the issue so downgraded back to 1.57 firmware. If anything it seems worse on the 1.61 firmware. I also tried adjusting the max dimness to lower settings like 75% or 80% and the issue persists. I also installed an aeotec bypass and didn’t seem to help.

I don’t think it’s the electrical as this room was just re-wired by electrical company.

The bulbs are Philips dimmable 2700k LED. https://www.homedepot.ca/en/home/categories/lighting-and-ceiling-fans/light-bulbs/f/soft-white-2700-k-2900-k-/9v4-2kw6

Another 3 bulb fixture has these ecosmart bulbs: https://www.homedepot.ca/en/home/categories/lighting-and-ceiling-fans/light-bulbs/f/soft-white-2700-k-2900-k-/9v4-2kw6

I’ve been thinking of trying a different set of bulbs but it seems like a waste as these are brand new bulbs and the bulb compatibility list doesn’t seem to list any bulbs that are sold in my area in Canada.

Just wondering if anyone has any troubleshooting tips.

I’ve ran into the same issue, intermittently. Someone suggested disabling power reporting, as it seems like the issue might be correlated with when the switch is sending power/energy reports. I’d be curious to know if that resolves your issue.

Do you happen to know what configuration item to change to disable the power reporting? I don’t mind trying it just not sure how to disable it.

Set all three to 0.

Parameter 18 - Active Power Reports

To adjust the threshold at which a power report is sent based on a change in Wattage on your Red Series 2-1 Switch, you would select Parameter 18 within your hub and then input a range of 0-32767, where zero disables the reports and each interval equals 0.1 Watt.

Parameter 19 - Periodic Power & Energy Reports

To adjust the time period at which consecutive power or energy reports are sent on your Red Series 2-1 Switch, you would select Parameter 19 within your hub and then input a range of 0-32767, where zero disables the reports and each interval equals 1 second.

Parameter 20 - Active Energy Reports

To adjust the threshold at which an energy report is sent based on a change in kilowatt hours on your Red Series 2-1 Switch, you would select Parameter 20 within your hub and then input a range of 0-32767, where zero disables the reports and each interval equals 0.01 kilowatt hours (kWh).

1 Like

Thanks. I’ve disabled the 3 power reporting parameters on all 20 switches in the house. Will report back after a week if it made a difference or not.

Setting all 3 parameters to 0 for energy reporting seems to have stopped the intermittent flickering.

1 Like

Unfortunately the flicker persists.

I have a similar problem. Dimmer is a few years old now in normal use. It was never a problem until updating to 1.57. It’s more than just one switch, but not all of them - it’s hard to say? It appears to be related to very specific dimness levels as OP reported. For me it’s like 37/38.

I’ve been fiddling with my min/max settings (since due to the light load) they are non-defaults. I figured that adjusting min/max would change the math for when I tell HomeAssistant/HomeKit set it to “30%” - That math checks. The switch will land on a different real value. But I’ve yet to find settings that don’t flicker for some normal use case.

I’ve set all of those params to 0 and will see what happens.

@wes.render have you found any fixes?