image not found img not found

Red Series Dimmer Switch in 3-Way Config - Slow Update of Dummy Switch State

First, setup:
I am using an Inovelli Red Series dimmer switch in a 3-way configuration (actually 4-way, but I don’t think that changes anything here). The red series dimmer is installed in the box with the line wire. I also have the neutral wire connected. I am able to turn the lights on and off from the dimmer switch, and both of the dumb switches. I am using ten of these lights: https://www.homedepot.com/p/Halo-RL-5-in-and-6-in-3500K-White-Integrated-LED-Recessed-Ceiling-Light-Trim-at-90-CRI-Bright-White-RL560WH6935R/204333823

Problem:
When I turn on or off one of the dumb switches, the Inovelli Red Series dimmer changes state to match the dumb switch, but it takes almost a second to do so. This really isn’t an issue, except that if I turn on and off the dumb switch too fast (within a second or less), the Inovelli dimmer doesn’t keep pace at keeping the dumb switch’s state. Then when I turn the switch on (waiting over a second after the last toggle), the light will turn on for a split second, then Inovelli will change state to match the dumb switch, and then it will turn off the light (even though I wanted it on). This is true whether I turn off then on fast, or on then off fast.

I know this is a confusing description so please ask if it’s not making sense. The bottom line is that the Inovelli dimmer is slow at matching the dumb switches state, and can lose sync if the dumb switch is toggled too fast. What’s weird is I saw a video from @EricM_Inovelli somewhere in this forum (I can’t find it now of course), that shows when he changes the dumb switch state, the Inovelli switch changes state to match almost instantaneously. Therefore, I think I may have an issues somewhere in my setup.

Anyone know what’s going on?

What hub are you using, and have you set the parameters (21 & 22 I think) for three way and neutral?

I’m using Home Assistant, and yes I have set the config parameters to three way toggle and neutral. Like I said, the Inovelli and the dumb switches are all able to turn on and off the lights just fine. The problem is how slow the Inovelli changes state to match the dumb switch when toggled.

Ahhh so the ramp rate needs to be adjusted. With dumb switches, the Inovelli immediately reacts as opposed to the switch. This is documented. Aux switches will follow similar speed to Inovelli. I’m not sure where it’s changed on HA, but Hubitat parameter 1 and 2?


@harjms Dimming Speed or Ramp Rate? You described Ramp Rate but posted pics of Dimming Speed.

Ramp Rate is parameters 3 & 4.

@Bry Tomato Tomahto. I believe dimming speed is the correct word choice. I have my parameters 3 and 4 as default 101 to follow the parameters.

@harjms thank you for the response. Unfortunately setting both the ramp rate and the dimmer rate (parameters 1-4) to 0 had no effect on this issue. Are there any other suggestions?

I wish I was more familiar with HA. Can you confirm that the parameters were pushed to the device?

Yes confirmed on Home Assistant and by turning the switch on and off both at the switch and through HA.

One thing I could suggest is setting the minimum light percentage. Most of my LEDs won’t illuminate until it reaches about 37%, so I set the minimum load rate to 40% to ensure it turns on. So, when I power up the bulbs, it starts from 40% vs. 0% to turn on. It may help speed up the light.

@harjms the dimmer minimum is set to 44% (which is where the light first turns on).

The problem is that the dimmer switch is slow at matching the dumb switch’s state. The light turn on time is not an issue.

I think I’m tracking now. You’re basically saying that when you use the dumb switches, the Inovelli Smart Switch isn’t displaying the correct state immediately and it takes a little longer to “catch up” the the actual state. Also, when turning on the dumb switch on then off almost immediately, it causes an incorrect state.

I have a video of me replicating the issue with the dumb switch turning on and then off immediately. I’ll see if I can find it and link it. Maybe you can see if that’s the same issue. I resolved my issue by replacing dumb switches with the Aux switch.

If you watch this video that @Eric_Inovelli posted in another thread, it looks like his Inovelli switch updates the dumb switch’s state almost instantaneously:

My Inovelli switch is taking 0.5s - 1s to update. This video is proof that I have something wrong in my setup, and it’s not an inherent problem with the switch. Maybe @Eric_Inovelli can chime in?

Hey sorry, I remember reading through this and meant to respond. Thanks for tagging me.

Question for ya – do you have this switch paired securely? There’s another thread that has something similar (I think) to what you’re experiencing with Home Assistant:

I know his is an On/Off switch, but maybe it’s happening to dimmers too.

Also, I’m guessing there’s no way for you to swap out the bulb as it looks to be in the ceiling. Sometimes the bulbs can cause this issue as they’re different technologies (ie: MOSFET vs Triac, Leading vs Trailing, etc) and if you toggle things too fast, the MCU can’t keep up with the different technologies. I’m sure @rpulivella can explain this better!

EDIT: One other thing that may be helpful is if you could share a video if the above doesn’t resolve it. I’d like to see what’s going on :slight_smile:

@Eric_Inovelli thanks for inviting me to this thread. I do have two thoughts on this though one is not lighting technology specific.

@AlreadySleepy what is the state/quality of your ZWave mesh? When is the last time you did a ZWave Repair and rebooted HA? Do you have any programming, associations, logic, etc. that could be interfering with default operation of the dimmer? I am asking to eliminate variables and unknowns.

As @Eric_Inovelli Eric mentions there could be something to the drivers within those recessed fixtures that is contributing to this. Can you post a video demonstrating the problem? This is hard to perceive simply from a description alone.

Lastly since these are retrofit recessed fixtures would it be possible for you to temporarily replace these with some simple incandescent or halogen bulbs? Any other LED (or dare I say CFL) light source will not be an effective test. You would have to test performance with the simplest of known loads which still is an incandescent/halogen bulb. If it works as expected then we would be able to confirm that it is the light source that is causing the delay and not something else (potentially more complicated to fix).

Good luck and let us know!