Red Series Dimming Speed Z-Wave


I’m having trouble getting my Red Series Dimmers to dim via Z-Wave commands. They either turn immediately all of the way on or immediately all of the way off. No dimming happens. I can however set level percentages through Z-Wave, but I can’t actively dim via Z-Wave commands. I can also however dim directly at the switch itself.

I went into the dimmers device page on my Hubitat (C-5) and tried to change the dimming parameters, but nothing seems to fix the problem.

I recently tried to set up a button to dim the lights and discovered the problem. I’ve always just set the lights through percentage levels via Z-Wave or directly at the switch itself.

Maybe there is a setting I am missing?

Any ideas?

1 Like

What is the firmware version? Verify parameter 52 (Smart bulb mode) is 0. If it’s already 0 change it to 1 and then back to 0.

That sounds as if it’s working correctly. How are you trying to accomplish the dimming? If it’s something like you expect to hold a separate button and have it dim or brighten while it’s held, then that would take a rule or automation that would vary the output while the button is held.

The current firmware is 1.35

I’m not seeing a parameter 52 (smart bulb mode)
Maybe I just am not looking in the right place. I’m on a hubitat.
Here is the list of the State Variables for one of the dimmers.

State Variables

  • parameter2value : 3
  • parameter5value : 34
  • parameter21value : 1
  • actualAssociation4 : []
  • actualAssociation3 : []
  • parameter10value : 55
  • parameter8value : 0
  • oldLabel : Studio Dimmer
  • parameter19value : 3600
  • parameter13value : 170
  • rfProtectionState : 0
  • parameter22value : 0
  • lastRan : 1672975751625
  • parameter3value : 0
  • parameter9value : 55
  • parameter6value : 99
  • parameter17value : 3
  • localProtectionState : 0
  • parameter14value : 10
  • parameter11value : 100
  • associationGroups : 4
  • parameter7value : 0
  • parameter15value : 3
  • parameter4value : 3
  • parameter18value : 10
  • needfwUpdate : false
  • defaultG3 : []
  • actualAssociation2 : []
  • parameter1value : 3
  • defaultG2 : []
  • actualAssociation1 : [01]
  • defaultG1 : [01]
  • parameter20value : 10


I was trying to set up a pico remote to dim the dimmer. Once I set the pico up and mapped it out, it was’t responding as expected. Instead of dimming it would only turn on or off. So, I went into the device page on my hubitat and tried to dim the light from there. That approach created the same result. It didn’t dim up or down, just turned on or off. If I go into the device page for my other dimmers (GE, and Lutron) I can “start change level (up or down)” and the lights dim until I hit the “stop level change” button. These Inovelli dimmers are not responding in the same way. The Inovelli’s just turn on or off with no dimming. I suspect a parameter needs to be changed as @stu1811 alluded to, but anything I change, doesn’t fix the issue.

I’ve decided not to dim from the pico button, but instead to just change the bulb 10% of the time as there is too big of a delay with the pico button for dimming and I always overshoot with my other dimmers. Still, I’d like to get the Inovelli dimmers to operate as I want/ expect them to.

I don’t use Lutron, and my knowledge of Hubitat is limited. But generally, when you have a dimmer and you want to replicate the dimming function on another device like a bulb or switch, those two devices need to be bound with binding (if Zigbee) or association (if Zwave). Absent those, the only other technique I’m aware of that is widely used is to use scenes, we certain dim levels are defined and then called.

That being said, maybe there is some functionality in Hubitat that might allow what you’re seeking. AFAIK, Lutron is using it’s own proprietary signaling, so this may be difficult to accomplish.

Gonna to defer to @mamber.

Hubitat allows you to use a pico remote as a general button for any other device paired within hubitat. The Lutron devices are brought into Hubitat through a Lutron bridge. I’m able to successfully set the pico up to control other brand dimmers in my home the way I was trying to control the Inovelli dimmers. It’s only the Innovelli dimmers that aren’t responding.
Regardless, I should be able to dim the Inovelli dimmers directly within the Hubitat’s device page. This isn’t working either. So the issue isn’t the Pico remote, it’s more likely something like a setting of the parameters of the Inovelli dimmers. Or maybe a Firmware update or driver.

That’s older firmware. I would update your firmware. And remember it’s two files going to target0 and target1

Show us your Preferences 1-4

By two files, you mean the parent and child devices have separate firmware? I’m going to have to go back and refresh how to update the firmware on these dimmers, it’s been a long time.

Just as a test, set the Ramp rates to 3. I know Ramp is for on/off but earlier versions of the driver had a couple of those reversed. You may be running one of those older drivers

Not parent and child. The physical device has two chips that need to be updated. There is a .otz file (target0) and a .bin file (target1). The firmware updates let’s you specify the target0 or target1

1 Like

I’m reading the “how to” on updating the dimmer now. Which version of the firmware would you recommend?

Edit: I see that you included recommended firmware in your last response. Thanks!

Just to clarify. Is the dimmer a LZW31 or LZW31-SN. They have different firmware

They are Red Series. So LZW31-SN

Ok good. The -SN firmware is what I was showing.

1 Like

I’m updating one of the dimmers now. using the 1.61.otz

The Firmware sure is taking a long time! In the How To it says it could take 5-10 minutes. It’s been an hour now and and just at 70%. It’s still making progress, but I didn’t expect it to take this long.
Is this something to be concerned about?

It can be very slow if the device is not close to the hub. An hour is a long time but if it’s still making progress I would let it keep going

Firmware is updated and it’s showing the current firmware as 1.61 now.

There are multiple options for drivers. Which one should I be using now?:
Z-Wave Scene dimmer
Z-Wave Smart Dimmer
Z-Wave Smart Scene Dimmer

Edit: I also see a user created driver. That’s the one I was using before. Looks to have a lot more options and settings in the parameters.

So the firmware is updated and I changed the ramp rates to 3 but the dimmer function is still not working from the hub.

If I use the “Inovelli Z-Wave Red Scene Dimmer” driver the dimming function works as expected through the hub, but if I use that driver I lose some of the settings such as the “Default (Local) Level from the switch” setting.

I guess it’s a trade off.

I have another one of these dimmers that I’ll need to update. I also have two Red Series on/ off switches that I assume will also need firmware updates as well.

Did you update both firmware files? The .bin file (target1) is smaller and goes much quicker.

BTW, it works correctly for me and many many others. So something’s not quite right with your setup config.

Also the User driver should be much newer and better that the built-in drivers. Can’t go by just the name. You need to open it on Hubitat and check the date

You can get it here