Red Switch - Buttons Not Working in Hubitat

Hey Folks,

I’ve installed a LZW30-SN and paired it successfully. The notifications LEDs work great. I created a couple of rules in Hubitat to do things when I double-tap the Up button. When I test it from within the Hubitat web interface, it triggers fine. When I physically tap the Up button twice, it does nothing.

Is there something I need to do to get Hubitat to recognize the physical buttons? I’ve troubleshot this for a couple of days now without any luck. Any help would be greatly appreciated.


You don’t have local control (relay) disabled do you? I believe you can press the config button 8x to cycle it back on/off.

Local control is not disabled. I tried flipping it on to test just now and it has no effect either way.

Did you install the device drivers from GitHub?

I did. I even cleared all three of them out yesterday and started fresh.


Just so I’m clear… pressing the “Press Up X2” button in the Web UI results in the lastEvent and pushed fields being changed successfully and the script executing. I just can’t get the actual physical buttons on the switch to do the same.

Mine works fine, pressing up twice on the switch activates a push of button 2 which tells my RM rule to turn on a lamp, pushing down twice activates a hold of button 2 which turns off the lamp.

You do have to tap it pretty quickly though.

Thanks. This is the first confirmation I’ve seen of someone getting this to work in Hubitat. I’m starting to wonder if I have faulty hardware.

Per your suggestion, I’ve tried a series of double taps in various speeds without success.

Mine shows the last event as soon as I finish tapping as up up, down down, or up up up when I physically tap the switch 2 x up, 2 x down, or 3 x up in the devices page as you show. It also shows the button pushed or held. Maybe a setting that needs to be changed via the configuration button on the switch?

Also I have no idea what Child on or off do, if it’s talking about the child driver then maybe the child got turned off? Not sure why that would be an option though. Also the driver was updated a week or two ago maybe update yours, if you haven’t. I updated mine today and hadn’t tried the scene control features before the update, just the notification feature.

I have only used the Hold up or Hold down to activate actions via Advanced Button Controller.

can you post your RM that isnt working.

Here’s a sample rule. Activating the buttons within the Web UI works as expected. Still nothing in the logs that it’s picking up any kind of button presses from the switch though.

It leads me to believe it’s either a driver or a hardware issue. Do you guys have the “Child On” and “Child Off” buttons under your device info? They don’t seem to do anything. Perhaps I’ve stumbled across a bug and they shouldn’t even be there?

I have those buttons as well, never pressed them since I can’t think of what they are for. The way you have this pressing up twice quickly should set the level of you Room A and Room B to a random color and set level to 100 but that may not turn the light on just pre-assign the color and dimming level, if the light were already on you should see the changes otherwise you may want to add a light on as well. However if when you press up twice quickly and the Last Event info in the device page doesn’t update then your rules aren’t likely to work either.

Yeah, I make sure the LIFX lights are on during testing. This rule is configured just for troubleshooting the issue. It works fine when triggered from the Web UI. That means the rule is good. There’s just no changes to the Last Event log when I physically press the buttons. The switch just isn’t passing button tap traffic to Hubitat.

If you guys have gotten it to work, I’m leaning on it being a hardware issue at this point. I’ve got another switch that I’ll try out next week and see if it yields different results.

If Debug and Info Logging is enabled in your driver, What do you see in your logs when you cycle through the buttons?

Absolutely nothing on the physical button presses. When triggering from the Web UI, it shows up fine in the logs.

I saw this in my YouTube notifications today… I haven’t had a chance to watch it yet. Maybe it will help: Link.

Unfortunately, I was cheap and purchased the Black label so I can’t help much with the Inovelli scenes. But to be honest, where this switch will ultimately be installed, I won’t need scenes. I imagine I’ll be looking at this when the dimmers finally arrive

Do you have the latest red series driver (this was updated a few weeks ago) and child driver?

Thanks. That video was helpful. It seems to confirm that I’ve done everything correctly on my end.

And yes, using the latest drivers. I erased everything three days ago and started fresh to verify.

Is it possible its not really a red switch?
I think having the black switch with a red driver would exhibit what you are seeing.

After making sure you are using the newest driver - I’m on Oct 1

also go into the device page and click Configure

make sure Enable informational logging is enabled

I suppose it’s a possibility it was mispackaged.

I’m running the Oct 15 version of the code.

Logging has been enabled for both debug and informational.

Still no luck after trying the “Configure” button.