SOLVED: Blue series switch won't pull update in z2m

Hey all,

Just installed another blue switch (with IEEE 0x040d84…) and I cannot get it to update it’s firmware via OTA in z2m.

The device is definitely not up to date on it’s firmware e.g. Read result of 'genBasic': {"swBuildId":"2.00"}

I have a few other switches that updated just fine:


the logs in z2m don’t really point to anything helpful

2023-01-09 16:13:34 Checking if update available for 'Downstairs Bathroom Light Switch'
2023-01-09 16:13:36 No update available for 'Downstairs Bathroom Light Switch'

Any thoughts on how to work around this? Is there a method for manual update here?


Do you have the latest z2m? There was a bug that was recently fixed.

I just upgraded to 1.29.1 the other day. Wonder if it is another bug. I’ll just go ahead and submit an issue on the z2m github. Thanks

Here’s another thread on the issue

Issue created on the z2m github. Will keep this updated.


Try updating to 1.29.1 and try again

1 Like

I’ll be damned. that fixed it. that was nice and easy thankfully. Seems like when I did a pull on the code it updated 1 file…no clue how that got out of sync since i pulled the 1.29.1 tag previously but whatever…if it works it works!

thank you!!


I’m on 1.29.2-1 and i still cant update one of my switches past 2.0, says no update available

Try this… Set logging to Info. Then go to the device and select the Dev Console tab. Select End Point 1, Cluster=genBasic, Attribute=swBuildId and then click Read. What version does it report?

Anyway to get it to display correct version? Did what you said and my switches are up to date but Z2M doesn’t report that in OTA.