Tips for Blue 2in1 zigbee inclusion range

I’m doing these things and I’m still having a really hard time. I have poor signal any missing ZHA events, but it’s hard to tell if the signal quality is the issue or if the switch is not sending events when it should be.

I hear you. I have 4 APs. +1 on channel recommendations.


Also specifically noting usb2 is preferable for the extension. Whether that’s the port or the cable.


Updated my post to mention this.

1 Like

I’ve had my switch since Wednesday and still cannot get it to pair. I’m using zigbee2mqtt and a sonoff zigbee adapter. I have read everyone’s attempts to fix but… why do I need to stand on my head and face east to get thing to pair? lol. My cheap zigbee light bulbs have no issues. It seems like it is not just me either. Really disappointed so far.

Hopefully this is helpful, too… old zstack coordinator firmware is sketchy, and newer builds have made massive improvements in performance. Linking this post I just made in another thread re: updating firmware on CC13xx, CC2538 and CC26xx - based coordinators:


Yeah, I eventually was just hitting random buttons, resetting, air gap, breaker, and got my second one to include finally. Frustrating though, especially when other Sylvania/LEDVANCE lights would include 20 feet from the stick.

Repost from other thread:

In my testing this is the strongest device in my entire mesh (highest RSSI) so almost everything goes through it (if further from the coordinator, some actually go through it that are closer to the coordinator).

I agree that interference may be an issue either from the hub hardware or the wireless communication band. Get the usb dongle away from anything that could interfere.

I validate all of your experiences and also want to communicate that I took my beta unit, on an extension cord, to the end of my driveway one floor and ~75’ away from the coordinator and it paired flawlessly. There’s no shot that these are working in a “good” environment OR there is a hardware issue in the specific switch.

Leaning toward some bad devices. :frowning: Even after getting it to add, seems like a poor performer.

Do you have another you can swap in? That’s surprising to say the least. Have you shared your setup channels and whether you have an extension or not?

@kreene1987 Home assistant, ZHA, Sonoff 3.0 -P (latest firmware), plastic switch boxes. Channel 11, Wifi on 7 I think. Other devices in mesh function well & included easily without extension cable, but got one out and moved antenna within 5 ft for setup. Also left the switch hanging out of the single gang box. Tried to include through other nodes within 5 feet, no dice there either.

I started with 4 switches. 2 pre-order, 2 Sept order, arrived with 1.5 week of each other. One I installed in basement had trouble initially including, but it was furthest away from any existing node, so gave it a pass. Eventually included after multiple power cycles, inclusion reset procedure, random button pressing. That is node at bottom of my screenshot, seems ok.

2nd switch in the top right node location couldn’t get to work, so I installed the 3rd one (currently installed). Still had ton of trouble getting it to include (but finally did, same ton of resets, button, air gap mashing) and now current state of it’s connection to other nodes shown. Didn’t try the 4th switch of the bunch yet.

All seems to be in place. I’ve got nothing that can assist other than some of the good conversations happening above. Sorry for your experience, it differs VASTLY from my beta units.

1 Like

Will see how some others’ experiences are as these flood out to other pre-order holders. Fingers crossed for Inovelli. Want this to succeed!

Just wanted to pop in and say that we’re currently looking into this with the engineers. I know it isn’t helpful to the current situation, but as @kreene1987, this has caught us off-guard as none of this was brought up in beta (including my own switches) and so we’re trying to figure out if this is a production issue or if this is just growing pains of understanding Zigbee.

Hang in there, I promise we will get to the bottom of it.


This just got a good laugh out of me since it’s absolutely something that I would have done for “testing” purposes. I can already hear my wife asking why I’m trying to add a switch all the way out in the middle of the yard?

To add another data point, I’ve been having a good bit of trouble with getting my switches to join the network (and stay connected). I ordered a pack of 10, have 5 installed so far.

  1. paired immediately, but it’s all of 8 feet from my server through a tile floor.
  2. is ~25 feet away, through a wall and a floor and has never joined.
  3. is ~20 feet away through a wall (directly beneath 2 by one floor) and joined on the first try but hasn’t reliably maintained connection, nor has it been able to provide a path for 2 to join the network when it is connected.
  4. and 5. share a box ~15-20 feet from the server, but there’s a refrigerator and furnace between them. They only connected when I moved the zigbee receiver to get a clearer line of sight and they didn’t stay connected for long even so.
  • Zigbee dongle is a Sonoff Zigbee 3.0 Dongle-P freshly flashed to the latest development branch of Z-Stack 3.x.0. Currently on a 5 ft USB 2 extension cable but I’ve got a longer one coming tomorrow.
  • Zigbee is on channel 11 (zigbee2mqtt default), Wifi is on channel 11 (but only 2 devices are on the 2.4GHz network anyway).
  • Server is running Home Assistant using Zigbee2MQTT version 1.28.0-dev commit: [ddc4345] (the latest-dev docker image).
  • All switches have a neutral wire and are in plastic switch boxes, the only switch with a metal switch plate is the one that has stayed reliably connected.


These switches were intended to be the start/core of my zigbee mesh, so the only other devices I have on the network are a couple sengled lightbulbs. The Office Lamp bulb is in a metal lamp clear on the other side of the house from my server and the Bathroom Light switch was getting comparable signal to it (LQI in the 10s to 20s) until I mounted the zigbee dongle to the ceiling directly under the bathroom.

I think I’ve seen one of the other switches up to an LQI of 30 when I was moving the dongle around, but obviously they’re not registering as connected currently.

I’d welcome any suggestions, but at this point my plan is to use a longer USB extension cable to stick the dongle in the ceiling of the garage and try installing some of my remaining switches in locations that should be helpful for creating a mesh.

Maybe swap high/low Zigbee/wifi? The difference between zigbee channel 11 and wifi channel 11 is 57MHz. If you run zigbee channel 25 and wifi channel 1, the difference is 63MHz. Plus, zigbee ch 25 sits on the sideband of a wifi channel (11), while zigbee ch 11 sits inside the 20MHz peak for wifi ch 1. You might have neighbors on ch 1 (many access points and routers default to this). With as few zigbee devices as you have now, re-pairing after a channel change shouldn’t be too much work…

I’ve been able to pair three switches that are near my Sonoff ZBdongle-P, but one that’s further away isn’t showing up when I try to add it in Home Assistant ZHA :frowning: I’ve tried using “Add devices via this device” on a device that’s only about 10 feet away, but it’s still not seeing the switch.

I have the USB stick on an extension cable, I turned off 2.4GHz wifi on my two access points, and I’m using Zigbee channel 20.

In my efforts to find any network that I do not control deliberately, I remembered that Amazon Echo Devices secretly create a network they call Sidewalk. You can disable this feature with no issues for most users by viewing account settings in the Alexa App. This did not improve the performance in my network, but it is an interesting place to check.

1 Like

Swapped channels, signal got a little stronger for the nodes that showed connected in my first post but didn’t allow anything else to hop back on.

Moving the coordinator location around on the end of a 15 ft USB cable let me get everything I had installed yesterday joined, but I haven’t found a spot that lets everything stay connected at the same time. The two switches I installed today are farther from the coordinator (though not far from existing switches) and nothing I do seems to get them to pick up.

The only spot where the zigbee2mqtt map shows nodes connecting to each other is two switches that are in the same gang box, and it’s only showing a signal strength of 49/29 on that connection.