Two LZW31-SN in three-way using associations - LED sync

I agree with you that only the ‘master’ should be controlled from any dashboard / alexa / google home. I do not have any ‘slave’ dimmers exposed in my dashboards. Only the ‘master’ appears on my dashboards and only the ‘master’ is exposed to my Alexa skill. Its a good point for others to check, but was not the problem in my case :relaxed:

THAT is the key to making it fully work with z-wave commands to the master dimmer. :+1:

Some of the previous comments implied that all associated devices needed to have parameter12 set to 11. But I have learned that the ‘master’ dimmer (the one with the actual load connected) still needs to have parameter 12 set to 15 (15 is default) so it includes z-wave commands. The other (slaves) need to have parameter12 set to 11 so they exclude z-wave commands. Having the ‘master’ parameter12 set to 11 is what disabled the synchronization when z-wave commands were sent to the master.

I don’t completely agree. Its true that the LZW31 dimmers don’t generate ‘BasicSet’ commands from LOCAL button pushes and therefore don’t need Group 2 association to sync LOCAL button events. However, with z-wave commands enabled on the master (parameter12=15) it is possible for hub-based automations to send BasicSet commands to the master to turn it on/off and you need Association Group 2 enabled for those events to keep the on/off state in sync on the slaves when an automation sends a BasicSet command to the master.

Not necessarily! If you want to use a LZW31-SN to control a LZW30-SN (or other on/off switch), you definitely need group 2.


The above 10+ posts should be put in an N-way wiki and summarized.

Great info, thanks everyone!

1 Like

Can you provide a screen shot of you Hubitat settings for the associations?

Is there an equivalent to parameter 12 for the LZW36?

I finally grabbed a video of the delay I see with the setup I described in reply 24.

The setup has been very reliable but the delay when using the secondary switches is enough to be annoying.

Take a look at:

I don’t have a great way to measure but a rough estimate is between 200 and 700ms of latency when I interact with a secondary switch before the primary reacts. It seems to be longer if the switches have been untouched for a several minutes.

It is enough of a delay that I’m going to swap it out for the GE Enbrighten Add-On Switches, which have no delay but don’t look nearly as nice:

@Eric_Inovelli I would LOVE it if the LZW31-SNs could use the traveler to communicate or if you were able to get an add-on with the LED strip available. We have 7 multi-way lighting circuits and they are some of the most heavily used. I’d love to have the LED indicator on all of them vs whichever junction box happens to have the Load wire in it.

Here are two screenshots for a 4-way setup. Each of the 9 association tool children I setup looks similar to that screenshot but for each of the groups and each of the source → dest combinations.

I see this behavior as well. I’m going to be removing the Association Group setup and switching to the GE AddOn switches to get rid of the delay. If I wasn’t I’d probably look at creating a custom app or device in hubitat that kept the secondary switches in sync with the primary for “soft” commands.

Ok so I’m very very new here… Just got 10 Red dimmers and 10 Red on off switches and am hoping to install them on both ends of my 3 and 4 way switch setups.

I’ll be using Home Assistant. Anyone have a step by step guide on how to accomplish this? I’ve read through the above thread but most seems to be on different smart hubs. My HA deployment is new and as of now, am planning to go the Z-Wave JS route and use Node Red for my automations. I’ve not seen anywhere in HA for device associations?

So there are two pieces to the installation. The first is getting the switches installed. The second is pairing the switches with the hub. I’m not a HA guy, but there are plenty here that can help you with that. Here are links to the wiring diagrams for the switches and dimmers:

Thanks for that!

I assumed that if I was intending on using 2 Red switches for the same set of lights that I would need to associate them in order for the led indicator to sync between the two units. I must have read this incorrectly.

No, you’re correct. Sorry to mislead you. If you’re not going to use Auxs or dumb switches and want the Inovellis in all positions, you will have to associate them.

Installation for that configuration is straightforward. Just send a hot and neutral to each box.

Just note the on off switches require a neutral in box so if your switch boxes don’t have neutrals you may have to rewire.

Quick note that this thread solved all of my challenges with LED syncing in several 4-way configurations in my house. Thanks!

The last bit that I fixed just now was to address the problem I had of the secondary dimmers not synchronizing with the master when the master was switched on or off via Z-Wave command.

I just wanted to confirm that Group 2 is very much needed for that scenario - I had just 3 and 4 following an earlier note in this thread but wasn’t able to fix that last issue until I also added 2. As soon as I added the mesh of associations for that group, everything is golden.

Is there an official doc now that solves all the above issues for 3-way for LZW31-SN when using Home Assistant? Hard to figure out what is what in all the googling and docs I’m reading.

What are you trying to do? What is the problem?

@iDVB has a fair question. I got my three-way working using wave associations but it’s not clear to me if there is the official documentation on how to do it. To be honest, I feel like I pieced it together through reading a bunch of threads but now I can’t remember exactly how to do it again due to it being so long ago.

Can we confirm this is now in the official, how to do 3 way switching docs and up to date?

@iDVB @BuilderTroy I believe the official documentation is out of date. This is the procedure I’ve done for multiple 3-ways with LZW31-SNs.

  1. Pair both switches with the same security level
  2. Associate load switch to non load with groups 3 and 4
  3. Associate non load switch to load switch with groups 3 and 4
  4. On non load switch set parameter 12 (association behavior) to 11

Note: In Home Assistant Group 3= Switch Multilevel Set and Group 4= Switch Multilevel Start/Stop

Official docs for reference:


On my associated pair of red and black dimmers I have both set both the manual and Z-wave ramp rates to 0. But, the one not being manually switched on or off will still ramp while the one being manually switched will immediately switch. The one not being controlled is following the dimming speed and not the ramp rate. I noticed this was mentioned earlier in the thread but that comment was basically ignored by all other posters.

So, is this expected behavior or is it an issue that has been solved or is it a firmware bug that has yet to be addressed?

Which Device Driver are you using? Make sure you get the latest from here:

The old device handlers had ramp rate and dimming rate swapped. Might be what you are seeing. Easy test for you would be to try setting all 4 rates (both dimming rates and both ramp rates) to 0.