Two Red Series Dimmers dropped off Z-wave network; one won't re-include successfully

I have Home Assistant supervised, core-2021.6.6. Running ZwaveJS to MQTT v0.20.0. I have 37 Inovelli switches installed in my house, a mix of Black & Red Series, on/off, dimmers, and fan/light controls.

I opened a ticket (16910) after two of my Red Series dimmers just dropped dead off my network during/after an HA core upgrade. They would control their lights locally, but would not respond to re-interviewing. The response to the ticket recommended factory resetting the switches and posting here. Factory resetting allowed me to add one of the switches back to my network, and after reconfiguring it appears to be working fine. The other is still non-responsive. So I’m posting here for further assistance.

Incidentally, I also have an outstanding issue with a fan/light switch that ceased to work locally, which means I have no control over it at all. It’s the only ceiling fan on the first floor of this house with no air conditioning. It’s been nearly a week that I can control neither the light nor the fan… yet the ticket has been closed without resolution (16790). My wife does not hold Inovelli responsible for this problem. Any guesses who’s taking the blame?

I’m getting a bit sour with these issues. I’ve been promoting Inovelli over every other provider in online conversations due to the unparalleled feature set, the great looks, the customer service, and the price… but I’ve not had this percentage of failures with other manufacturers in my many (10, maybe?) years of Z-waving, even those I’ve bought used on eBay. I get that this is a tinkerer’s hobby, but at the end of the day I want to be able to install a switch once and have it work, rather than keep having to mess with it repeatedly. I would love to be able to say five years from now that Inovelli really knocked it out the park with these switches, instead of something like, “oh, yeah, I tried them, and over a year or two they all stopped working.”

Does non-responsive mean the switch powers up fine but you can’t get it back into HA? I’m not an HA guy, but when devices won’t add, the first thing I do is a general exclusion to make sure there isn’t a conflict within the hub, in addition to the factory reset. It seems to me that there is something going on hub-side if the issue occurred during/after an HA upgrade.

What is the configuration of the switch that isn’t responding? Single switch or three-way? Neutral or non-neutral?

Inovelli is tracking the fan/light issue and is working with the manufacturer to correct the issue.

The switch works locally. I’ve done a factory reset of the switch followed by several unsuccessful exclude/include cycles. After the factory reset and exclusion, one of the switches added upon inclusion, and the other didn’t.

I now have 35 working Inovelli switches, one dead dimmer, and one fan/light that’s not dead, but not communicating with its canopy module.

The one that I was able to get working again is three-way with a dumb switch and a neutral wire. The one that I can’t get to include is a single switch with a neutral wire.

Yes, I posted in that thread.

1 Like

Does that mean a general exclusion from the hub? I don’t know HA, but I would think it has that capability. A general exclusion is different than a specific device exclusion.

You can do that from the jwavejs ui.

You can also remove failed nodes from the advanced options on a node.

Yes, correct. I’ve done both of those. Once I attempted to re-interview and found that, after 24 hours, the switches weren’t responding, I removed the failed nodes, excluded, and then both failed to include. At the suggestion of customer support, I did a factory reset on both switches this morning, then excluded, then attempted inclusion. One included successfully, and the other did not. It was recommended I post this here, so I did.

I have run into this once. I had to do a general exclusion from my hub AGAIN and hit the config 3 times. It flashed green as if it was excluded a second time. It somehow thought it was still included for some reason (even after hard reset), but then I was able to include again.

Worth a shot.

1 Like

I’ll give it a try. None of the exclusions resulted in any response from the hub… I did at least two, maybe three on each switch. Typically an exclusion (of a currently-included switch, anyway) results in some “node removed” dialog from ZwaveJS. But I’m getting nothing from these. That’s not entirely unexpected if they’re factory reset… anyway, thanks, I’ll try that when I have a moment.

I’ve just attempted to exclude 5 times. I mixed up the order (switch in include/exclude mode, then HA; HA, then switch) after a few times. Each time, the switch ended its cycle with a red LED, and ZwaveJS delivered this:


I then tried including twice, unsuccessfully.

I suppose it’s worth mentioning that this switch is one of the closest ones to my hub. It’s on the same floor about 10 feet from my NAS, where HA is running on a VM with a USB stick. There are two Inovelli switches directly between this failed one and the hub that are working. I have other devices (Inovelli, GE/Jasco, Zooz) in another building that never failed and are still working, but I can’t get this one to include.

So… ticket’s in. Post is done. Not sure where to go from here.

Very strange. Maybe try a network heal?

From what I can tell, ZwaveJS to MQTT does a nightly network heal… and it’s been a few days. I can perform a heal to see what happens, but if that switch isn’t on the network, I don’t know if it’ll get me anywhere.

Is the switch hard reset working properly (hold for 20s until red, blinks red, green, blue, then comes back on blue?). I’ve never had a hard reset fail me but might be worth trying again.

Good to know. I was just throwing out ideas.

I held the config button and it cycled green, then yellow, then red, at which point I released the config button. I was following the instructions here under “Factory Reset.”

I guess is the RESULT as expected. Asked the wrong question.

The factory reset? It seems to actually reset the switch, yes. The one that I got working had all of the configuration parameters reset.

Thanks for all the help on this. Hopefully we can get things up and running. Not trying to point fingers, but from my experience, if a device doesn’t exclude there is something going on with the hub / network. I’m guessing you have tried to reboot HA? If an exclusion ends with the switch LEDs flashing red that means that exclusion failed.

One thing I would recommend with HA is to not do a secure inclusion. So, if you can reboot your HA, exclude the the device (maybe just do a factory reset on it), then include it without security. This usually makes the network run a lot more reliably and faster.

Another tip, if your USB stick is plugged directly into your server, add a USB extension cable and move the stick away from the RF blocking server. :wink:

1 Like